summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-10-16 19:36:25 +0200
committerMartchus2017-10-16 19:36:25 +0200
commit3611de14af0ef8a8cc0ae90027978ebde293ec0b (patch)
tree1c40947fb75a9a70701d2a86c9b215a9223f70f0
parent4af11aec13f5c6a057853f39cd1d034c8abd1588 (diff)
downloadaur-3611de14af0ef8a8cc0ae90027978ebde293ec0b.tar.gz
Update to 5.9.2
-rw-r--r--.SRCINFO14
-rw-r--r--0001-Fix-linguist-macro.patch6
-rw-r--r--0002-Prevent-linking-qhelpconverter-against-static-bearer.patch31
-rw-r--r--[-rwxr-xr-x]PKGBUILD17
4 files changed, 54 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ec7fd85d85a..a03690f2cad4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jul 6 21:13:09 UTC 2017
+# Mon Oct 16 17:36:25 UTC 2017
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.9.1
+ pkgver = 5.9.2
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -14,16 +14,20 @@ pkgbase = mingw-w64-qt5-tools
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = mingw-w64-postgresql
+ makedepends = mingw-w64-mariadb-connector-c
makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-declarative
optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.9/5.9.1/submodules/qttools-opensource-src-5.9.1.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.9/5.9.2/submodules/qttools-opensource-src-5.9.2.tar.xz
source = 0001-Fix-linguist-macro.patch
- sha256sums = c4eb56cf24a75661b8317b566be37396c90357b4f6730ef12b8c97a7079ca0e8
- sha256sums = de1f0114b723d07f1c7a2c11c15e8c5b05852c690e3a36d3f65f3a411fd81127
+ source = 0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
+ sha256sums = 2bb996118b68e9939c185a593837e5a41bb3667bf5d4d5134fac02598bd2d81a
+ sha256sums = 76cc91d9b26bc89365ab84bffa20a1ab1f92eb1771c3250914997ffa30628ba0
+ sha256sums = c04718ab919840800149d927d0741c27d8e0703a103f592806935323b75b775c
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 5467f679464a..924cbd2ef5cb 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,7 +1,7 @@
-From 74188cdf0f85a90bf86f251480d6a41b7ea61be2 Mon Sep 17 00:00:00 2001
+From 151ff9811016c842533b36a091fad2bcb804aa28 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
-Subject: [PATCH] Fix linguist macro
+Subject: [PATCH 1/2] Fix linguist macro
- Prevent CMake appending extra 'Qt5::lupdate'/'Qt5::lrelease' to
command line when invoking lupdate/lrelease
@@ -38,5 +38,5 @@ index 6013cc6e..2e797326 100644
DEPENDS ${_abs_FILE} VERBATIM
)
--
-2.13.2
+2.14.2
diff --git a/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch b/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
new file mode 100644
index 000000000000..048895c3f0cc
--- /dev/null
+++ b/0002-Prevent-linking-qhelpconverter-against-static-bearer.patch
@@ -0,0 +1,31 @@
+From b9026077022561e57a47e69bab84dc547344d0ab Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 15 Oct 2017 22:25:22 +0200
+Subject: [PATCH 2/2] Prevent linking qhelpconverter against static bearer
+ plugins
+
+This would lead to linker errors since Qt Network isn't used
+by qhelpconverter and hence its dependencies aren't pulled.
+
+FIXME:
+* Find out why qmake attempts to link against plugins
+ by default which are from a module which isn't even used.
+* Fix pulling dependencies of static modules when only
+ the plugin, but not the related module itself, is used.
+---
+ src/assistant/qhelpconverter/qhelpconverter.pro | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/assistant/qhelpconverter/qhelpconverter.pro b/src/assistant/qhelpconverter/qhelpconverter.pro
+index d60aae7c..99943618 100644
+--- a/src/assistant/qhelpconverter/qhelpconverter.pro
++++ b/src/assistant/qhelpconverter/qhelpconverter.pro
+@@ -1,4 +1,5 @@
+ QT += help widgets
++QTPLUGIN.bearer=-
+
+ SOURCES += conversionwizard.cpp \
+ inputpage.cpp \
+--
+2.14.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 54f365d5189e..a6ba5e2a5286 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,27 +16,31 @@
_qt_module=qttools
pkgname="mingw-w64-qt5-tools"
-pkgver=5.9.1
+pkgver=5.9.2
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
-makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
- '0001-Fix-linguist-macro.patch')
-sha256sums=('c4eb56cf24a75661b8317b566be37396c90357b4f6730ef12b8c97a7079ca0e8'
- 'de1f0114b723d07f1c7a2c11c15e8c5b05852c690e3a36d3f65f3a411fd81127')
+ '0001-Fix-linguist-macro.patch'
+ '0002-Prevent-linking-qhelpconverter-against-static-bearer.patch')
+sha256sums=('2bb996118b68e9939c185a593837e5a41bb3667bf5d4d5134fac02598bd2d81a'
+ '76cc91d9b26bc89365ab84bffa20a1ab1f92eb1771c3250914997ffa30628ba0'
+ 'c04718ab919840800149d927d0741c27d8e0703a103f592806935323b75b775c')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+# can not use static MySQL plugin because mariadb-connector-c uses already OpenSSL 1.1 -> Qt 5.10 will fix this
+# for now, disable linking against that plugin (by adding other SQL plugins explicitely)
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge QTPLUGIN.sqldrivers=qsqlite QTPLUGIN.sqldrivers+=qsqlpsql QTPLUGIN.sqldrivers+=qsqlodbc CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -64,6 +68,7 @@ build() {
find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5QmlDevTools -lQt5Bootstrap|-L/usr/lib /usr/$_arch/lib/libQt5QmlDevTools.so /usr/$_arch/lib/libQt5Bootstrap.so|g" {} \;
find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5QmlDevTools|-L/usr/lib /usr/$_arch/lib/libQt5QmlDevTools.so|g" {} \;
find . -type f -iname 'Makefile' -exec sed -i "s|-L/usr/$_arch/lib -lQt5Bootstrap|-L/usr/lib /usr/$_arch/lib/libQt5Bootstrap.so|g" {} \;
+ find . -type f -iname 'Makefile' -exec sed -i "s|-lQt5Bootstrap ||g" {} \;
make
popd