summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-12-24 13:06:45 +0100
committerMartchus2016-12-24 13:06:45 +0100
commit5d5f1b675bf3887fa252753a645e1d93d8758156 (patch)
tree7e1378736cdf0347506e09760b01afed55e3108c
parentf54912bb640d79f2805e473a419ad95b21db7951 (diff)
downloadaur-5d5f1b675bf3887fa252753a645e1d93d8758156.tar.gz
Update to 5.7.1
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Fix-linguist-macro.patch6
-rwxr-xr-xPKGBUILD8
-rw-r--r--qt5-fix-linguist-cmake-macro.patch25
4 files changed, 13 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2915c66477c4..4d878067ef65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 8 19:41:02 UTC 2016
+# Sat Dec 24 12:06:45 UTC 2016
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.7.0
- pkgrel = 3
+ pkgver = 5.7.1
+ pkgrel = 1
url = https://www.qt.io/
arch = i686
arch = x86_64
@@ -18,10 +18,10 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qttools-opensource-src-5.7.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.7/5.7.1/submodules/qttools-opensource-src-5.7.1.tar.xz
source = 0001-Fix-linguist-macro.patch
- md5sums = 29eb3fd31582b5801e264c62d1158553
- md5sums = 3528c03fc5332ca448e9114bd6be78b1
+ md5sums = 74b74b9e354368fea6635e2166a9c481
+ md5sums = cb992a5fc5abcd9df8a4122e6fdf2cf4
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 5d8ea27c7b35..77d6d2cc1fc9 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 1f1a8e6109b99b797efe52e91c47c1c04c629b83 Mon Sep 17 00:00:00 2001
+From 77e3129a33d3297bddc514edb773bf30133fa838 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH] Fix linguist macro
@@ -11,7 +11,7 @@ Subject: [PATCH] Fix linguist macro
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/src/linguist/Qt5LinguistToolsMacros.cmake b/src/linguist/Qt5LinguistToolsMacros.cmake
-index 6013cc6..2e79732 100644
+index 6013cc6e..2e797326 100644
--- a/src/linguist/Qt5LinguistToolsMacros.cmake
+++ b/src/linguist/Qt5LinguistToolsMacros.cmake
@@ -71,8 +71,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
@@ -38,5 +38,5 @@ index 6013cc6..2e79732 100644
DEPENDS ${_abs_FILE} VERBATIM
)
--
-2.10.0
+2.11.0
diff --git a/PKGBUILD b/PKGBUILD
index 8a91c63e3ca1..ac251646a107 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,8 @@
_qt_module=qttools
pkgname="mingw-w64-qt5-tools"
-pkgver=5.7.0
-pkgrel=3
+pkgver=5.7.1
+pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
@@ -28,8 +28,8 @@ url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Fix-linguist-macro.patch')
-md5sums=('29eb3fd31582b5801e264c62d1158553'
- '3528c03fc5332ca448e9114bd6be78b1')
+md5sums=('74b74b9e354368fea6635e2166a9c481'
+ 'cb992a5fc5abcd9df8a4122e6fdf2cf4')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
diff --git a/qt5-fix-linguist-cmake-macro.patch b/qt5-fix-linguist-cmake-macro.patch
deleted file mode 100644
index b49d14018797..000000000000
--- a/qt5-fix-linguist-cmake-macro.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/linguist/Qt5LinguistToolsMacros.cmake.orig 2016-06-19 17:29:46.000000000 +0200
-+++ src/linguist/Qt5LinguistToolsMacros.cmake 2016-07-23 00:39:31.718139700 +0200
-@@ -71,8 +71,10 @@
-
- file(WRITE ${_ts_lst_file} "${_lst_file_srcs}")
- endif()
-+
-+ get_target_property(LUPDATE_LOC ${Qt5_LUPDATE_EXECUTABLE} IMPORTED_LOCATION)
- add_custom_command(OUTPUT ${_ts_file}
-- COMMAND ${Qt5_LUPDATE_EXECUTABLE}
-+ COMMAND ${LUPDATE_LOC}
- ARGS ${_lupdate_options} "@${_ts_lst_file}" -ts ${_ts_file}
- DEPENDS ${_my_sources} ${_ts_lst_file} VERBATIM)
- endforeach()
-@@ -93,8 +95,9 @@
- set(qm "${CMAKE_CURRENT_BINARY_DIR}/${qm}.qm")
- endif()
-
-+ get_target_property(LRELEASE_LOC ${Qt5_LRELEASE_EXECUTABLE} IMPORTED_LOCATION)
- add_custom_command(OUTPUT ${qm}
-- COMMAND ${Qt5_LRELEASE_EXECUTABLE}
-+ COMMAND ${LRELEASE_LOC}
- ARGS ${_abs_FILE} -qm ${qm}
- DEPENDS ${_abs_FILE} VERBATIM
- )