summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-03-28 19:40:38 +0200
committerMartchus2016-03-28 19:40:38 +0200
commit7591c8913aa854bef52bf22b99152d4221c64ebc (patch)
tree3ec97efabf18f0b9eec1874217100537bb3ac9f4
parent0ac4985ec1c0a89ee3358b7d316b1d414b0d7947 (diff)
downloadaur-7591c8913aa854bef52bf22b99152d4221c64ebc.tar.gz
updated to 5.6.0
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD13
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c432aff0f4b5..e9e734f69231 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Feb 3 22:50:58 UTC 2016
+# Mon Mar 28 17:31:59 UTC 2016
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.5.1
+ pkgver = 5.6.0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -13,8 +13,8 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.5/5.5.1/submodules/qttools-opensource-src-5.5.1.tar.xz
- md5sums = 535ff9df9d83e9bde08ee3913b751d07
+ source = https://download.qt.io/official_releases/qt/5.6/5.6.0/submodules/qttools-opensource-src-5.6.0.tar.xz
+ md5sums = 5dd6204df7c81c684607f2fc8a5d351a
pkgname = mingw-w64-qt5-tools
diff --git a/PKGBUILD b/PKGBUILD
index 2a960458ad8b..29180ddea474 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,12 @@
# Contributor: ant32 <antreimer@gmail.com>
# Contributor: Filip Brcic <brcha@gna.org>
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
_qt_module=qttools
pkgname="mingw-w64-qt5-tools"
-pkgver=5.5.1
+pkgver=5.6.0
pkgrel=1
arch=('any')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
@@ -15,7 +18,7 @@ license=('GPL3' 'LGPL')
url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-md5sums=('535ff9df9d83e9bde08ee3913b751d07')
+md5sums=('5dd6204df7c81c684607f2fc8a5d351a')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -27,12 +30,12 @@ build()
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-qmake-qt5 ../${_qt_module}.pro
-
+
# Something is messed up with Qt5Bootstrap
make qmake_all
-
find ./src -type f -exec sed -i "s|-L/usr/${_arch}/lib -lQt5Bootstrap|/usr/lib/libstdc++.so.6 -L/usr/${_arch}/lib -lQt5Bootstrap|g" {} \;
find ./src -type f -exec sed -i "s|-L/usr/${_arch}/lib -lQt5QmlDevTools|/usr/lib/libstdc++.so.6 -L/usr/${_arch}/lib -lQt5QmlDevTools|g" {} \;
+
make
popd
@@ -62,7 +65,7 @@ package() {
for tool in lconvert lupdate lrelease; do
ln -s ../${_arch}/lib/qt/bin/${tool} "${pkgdir}/usr/bin/${_arch}-$tool-qt5"
done
-
+
${_arch}-strip --strip-all "${pkgdir}/usr/${_arch}/bin/"*.exe
${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a