summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-06-22 20:36:06 +0200
committerMartchus2016-06-22 20:36:06 +0200
commit7bd28e1ca766083a07f627640be50c3a883c9ebd (patch)
tree8b5eac12825af5dbed1530509fe4a18028250d5a
parentccef5f4cf6138aad4c85550478fdfd819d37196d (diff)
downloadaur-7bd28e1ca766083a07f627640be50c3a883c9ebd.tar.gz
Update to 5.7.0
-rw-r--r--.SRCINFO11
-rwxr-xr-xPKGBUILD15
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a03d850bedae..7ee11d58cc1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
# Generated by mksrcinfo v8
-# Thu Jun 16 08:09:00 UTC 2016
+# Wed Jun 22 18:36:03 UTC 2016
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.6.1
+ pkgver = 5.7.0
pkgrel = 1
url = https://www.qt.io/
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL3
license = LGPL
makedepends = mingw-w64-gcc
@@ -13,8 +14,8 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.6/5.6.1/submodules/qttools-opensource-src-5.6.1.tar.xz
- md5sums = bf2cea01e94140524a3fc58c2f2ddebc
+ source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qttools-opensource-src-5.7.0.tar.xz
+ md5sums = 29eb3fd31582b5801e264c62d1158553
pkgname = mingw-w64-qt5-tools
diff --git a/PKGBUILD b/PKGBUILD
index b10fe8ce9c66..c53e16cdd96f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@
_qt_module=qttools
pkgname="mingw-w64-qt5-tools"
-pkgver=5.6.1
+pkgver=5.7.0
pkgrel=1
-arch=('any')
+arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc')
@@ -18,7 +18,7 @@ license=('GPL3' 'LGPL')
url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-md5sums=('bf2cea01e94140524a3fc58c2f2ddebc')
+md5sums=('29eb3fd31582b5801e264c62d1158553')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -31,13 +31,13 @@ build()
${_arch}-qmake-qt5 ../${_qt_module}.pro
- # Something is messed up with Qt5Bootstrap
+ # search paths for host standard library (/usr/lib) and for Qt5Bootstrap (/usr/$_arch/lib) are not set correctly by qmake
+ # hence we need insert those paths manually
make qmake_all
- find ./src -type f -exec sed -i "s|-L/usr/${_arch}/lib -lQt5Bootstrap|/usr/lib/libstdc++.so.6 -L/usr/${_arch}/lib -lQt5Bootstrap|g" {} \;
- find ./src -type f -exec sed -i "s|-L/usr/${_arch}/lib -lQt5QmlDevTools|/usr/lib/libstdc++.so.6 -L/usr/${_arch}/lib -lQt5QmlDevTools|g" {} \;
+ find . -type f -iname 'Makefile' -exec sed -i "s|-lQt5QmlDevTools -lQt5Bootstrap|-L/usr/lib -L/usr/$_arch/lib -lQt5QmlDevTools -lQt5Bootstrap|g" {} \;
+ find . -type f -iname 'Makefile' -exec sed -i "s|-lQt5Bootstrap|-L/usr/lib -L/usr/$_arch/lib -lQt5Bootstrap|g" {} \;
make
-
popd
done
}
@@ -69,6 +69,7 @@ package() {
${_arch}-strip --strip-all "${pkgdir}/usr/${_arch}/bin/"*.exe
${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+ strip --strip-all "${pkgdir}/usr/${_arch}/lib/qt/bin/"*
popd
done