summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-04-14 11:37:24 +0200
committerMartchus2021-04-14 11:37:24 +0200
commita5f6d27c7b1f5eaf8e0ba43798bb08637a946d78 (patch)
treee7ef427649dfc1c77dc9f512cd1d6d196f92e452
parent7d5ea5f7d55ab49dfcb05d14fea457ba8e3e0211 (diff)
downloadaur-a5f6d27c7b1f5eaf8e0ba43798bb08637a946d78.tar.gz
Update to use KDE fork patches
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Fix-linguist-macro.patch14
-rw-r--r--[-rwxr-xr-x]PKGBUILD18
3 files changed, 26 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1281468807a6..8be8505d4e8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.2+kde+r17
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -15,14 +15,15 @@ pkgbase = mingw-w64-qt5-tools
makedepends = mingw-w64-postgresql
makedepends = mingw-w64-mariadb-connector-c
makedepends = mingw-w64-vulkan-headers
+ makedepends = git
depends = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qttools-everywhere-src-5.15.2.tar.xz
+ source = git+https://invent.kde.org/qt/qt/qttools#commit=33693a928986006d79c1ee743733cde5966ac402
source = 0001-Fix-linguist-macro.patch
- sha256sums = c189d0ce1ff7c739db9a3ace52ac3e24cb8fd6dbf234e49f075249b38f43c1cc
- sha256sums = e2ce8a553c78fd0dc6934be7d58a9bb90fe465619ac20a567d579c4c90bc01ab
+ sha256sums = SKIP
+ sha256sums = cf7fcd9b2cfa110e95bde957a00c600da17bc75fdf7be1f72204eb5364cbf397
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 44200a934d3e..8927b419a50c 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 43c51a28149ae923fedbf215a64a5456dc44a664 Mon Sep 17 00:00:00 2001
+From 4818c98b4cc9441fecea9c63479ca7d5c05ed967 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH] Fix linguist macro
@@ -11,10 +11,10 @@ Subject: [PATCH] Fix linguist macro
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/src/linguist/Qt5LinguistToolsMacros.cmake b/src/linguist/Qt5LinguistToolsMacros.cmake
-index ab271d56..f54c99c4 100644
+index 20fb1493..406d3d3a 100644
--- a/src/linguist/Qt5LinguistToolsMacros.cmake
+++ b/src/linguist/Qt5LinguistToolsMacros.cmake
-@@ -71,8 +71,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
+@@ -90,8 +90,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
file(WRITE ${_ts_lst_file} "${_lst_file_srcs}")
endif()
@@ -24,9 +24,9 @@ index ab271d56..f54c99c4 100644
- COMMAND ${Qt5_LUPDATE_EXECUTABLE}
+ COMMAND ${LUPDATE_LOC}
ARGS ${_lupdate_options} "@${_ts_lst_file}" -ts ${_ts_file}
- DEPENDS ${_my_sources}
- BYPRODUCTS ${_ts_lst_file} VERBATIM)
-@@ -114,8 +116,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
+ DEPENDS ${_dependencies}
+ VERBATIM)
+@@ -133,8 +135,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
set(qm "${CMAKE_CURRENT_BINARY_DIR}/${FILE_NAME}.qm")
endif()
@@ -38,5 +38,5 @@ index ab271d56..f54c99c4 100644
DEPENDS ${_abs_FILE} VERBATIM
)
--
-2.29.2
+2.31.1
diff --git a/PKGBUILD b/PKGBUILD
index 9b985ddd5d99..29c9af2a1a70 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,22 +30,32 @@ pkgdesc="A cross-platform application and UI framework (Development Tools, QtHel
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=33693a928986006d79c1ee743733cde5966ac402
+pkgver+=+kde+r17
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
'0001-Fix-linguist-macro.patch')
-sha256sums=('c189d0ce1ff7c739db9a3ace52ac3e24cb8fd6dbf234e49f075249b38f43c1cc'
- 'e2ce8a553c78fd0dc6934be7d58a9bb90fe465619ac20a567d579c4c90bc01ab')
+sha256sums=('SKIP'
+ 'cf7fcd9b2cfa110e95bde957a00c600da17bc75fdf7be1f72204eb5364cbf397')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "5.15.2+kde+r"`git rev-list --count origin/5.15.2..$_commit`
+}
+
prepare() {
cd "${srcdir}/${_pkgfqn}"
+ git revert -n dbe0567470db2b369a9fdb28d9fbac38be3e2d60 # Revert version bump
+
# apply patches; further descriptions can be found in patch files itself
for patch in "$srcdir/"*.patch; do
patch -p1 -i "$patch"