summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:01 +0100
committerMartchus2022-03-08 23:35:01 +0100
commitd03ee9cbb797a9bcc6ced361506764d96c9d5027 (patch)
tree9661a3f3f9a209fd0a05b20d039a4535a71af276
parenta5f6d27c7b1f5eaf8e0ba43798bb08637a946d78 (diff)
downloadaur-d03ee9cbb797a9bcc6ced361506764d96c9d5027.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO7
-rw-r--r--0001-Fix-linguist-macro.patch6
-rw-r--r--PKGBUILD13
-rw-r--r--PKGBUILD.sh.ep2
4 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8be8505d4e8d..62d26e785155 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.15.2+kde+r17
+ pkgver = 5.15.3+kde+r1
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -20,10 +20,9 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://invent.kde.org/qt/qt/qttools#commit=33693a928986006d79c1ee743733cde5966ac402
+ source = git+https://invent.kde.org/qt/qt/qttools#commit=a3e5b2eb8ef5982bc1fffb390ebcd141be1deee4
source = 0001-Fix-linguist-macro.patch
sha256sums = SKIP
- sha256sums = cf7fcd9b2cfa110e95bde957a00c600da17bc75fdf7be1f72204eb5364cbf397
+ sha256sums = 4808f9bc8db99b2d719a0aecc4a296580f9a92b95c03ddbbd78470c1a903d082
pkgname = mingw-w64-qt5-tools
-
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 8927b419a50c..7f5504f186c2 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 4818c98b4cc9441fecea9c63479ca7d5c05ed967 Mon Sep 17 00:00:00 2001
+From 91a31449aefc95da17c08fb11cd3d77939ff942e Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH] Fix linguist macro
@@ -11,7 +11,7 @@ Subject: [PATCH] Fix linguist macro
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/src/linguist/Qt5LinguistToolsMacros.cmake b/src/linguist/Qt5LinguistToolsMacros.cmake
-index 20fb1493..406d3d3a 100644
+index 20fb14935..406d3d3a3 100644
--- a/src/linguist/Qt5LinguistToolsMacros.cmake
+++ b/src/linguist/Qt5LinguistToolsMacros.cmake
@@ -90,8 +90,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
@@ -38,5 +38,5 @@ index 20fb1493..406d3d3a 100644
DEPENDS ${_abs_FILE} VERBATIM
)
--
-2.31.1
+2.35.1
diff --git a/PKGBUILD b/PKGBUILD
index 29c9af2a1a70..0066ede7fbbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,15 +23,16 @@
_qt_module=qttools
pkgname=mingw-w64-qt5-tools
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
-_commit=33693a928986006d79c1ee743733cde5966ac402
-pkgver+=+kde+r17
+_commit=a3e5b2eb8ef5982bc1fffb390ebcd141be1deee4
+_basever=$pkgver
+pkgver+=+kde+r1
makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
@@ -40,7 +41,7 @@ _pkgfqn=${_qt_module}
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
'0001-Fix-linguist-macro.patch')
sha256sums=('SKIP'
- 'cf7fcd9b2cfa110e95bde957a00c600da17bc75fdf7be1f72204eb5364cbf397')
+ '4808f9bc8db99b2d719a0aecc4a296580f9a92b95c03ddbbd78470c1a903d082')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -48,14 +49,12 @@ _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
pkgver() {
cd $_pkgfqn
- echo "5.15.2+kde+r"`git rev-list --count origin/5.15.2..$_commit`
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
}
prepare() {
cd "${srcdir}/${_pkgfqn}"
- git revert -n dbe0567470db2b369a9fdb28d9fbac38be3e2d60 # Revert version bump
-
# apply patches; further descriptions can be found in patch files itself
for patch in "$srcdir/"*.patch; do
patch -p1 -i "$patch"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index ce10c78348a8..9069aa85ae68 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -18,7 +18,7 @@
% end
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=(<%== include 'fragments/mingw-w64-qt5-non_any_archs' %>)
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"