summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:09:07 +0100
committerMartchus2020-01-29 19:09:07 +0100
commitedaa965707bef15e79be2643fc47e56c4cd1b3e2 (patch)
tree83ad753a3866f6de46615bab7f1498a30d8affac
parent718efceb8028e57c6ff464903fc38e645f11eef7 (diff)
downloadaur-edaa965707bef15e79be2643fc47e56c4cd1b3e2.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-linguist-macro.patch4
-rwxr-xr-xPKGBUILD38
-rw-r--r--PKGBUILD.sh.ep45
-rw-r--r--qttools-sha256.txt1
5 files changed, 71 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2162bb2bc54..8ba462983939 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -21,10 +21,10 @@ pkgbase = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qttools-everywhere-src-5.14.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qttools-everywhere-src-5.14.1.tar.xz
source = 0001-Fix-linguist-macro.patch
- sha256sums = 8d7f8612ab6078fe7289d8a8dd8112b550fd0f51b5455df2dcfba651c30c3adf
- sha256sums = 4f21d5bf00a1bb868b1ba88de8b8eee2a6977b24a74e9dd3c7c7eb2ee09ba6e6
+ sha256sums = 7f5e6370cf4ed59f2bdd6517870cdcb1df9a055bbd885d056d90938ab302c70c
+ sha256sums = d40cb534f47950c6a7d372e40ed07efede64bf92810a6929372e531549d6d0f0
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 52f63115f5cd..20426192dd7c 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 50fe4fb54077f761822db5fd9b61fe8d919959a2 Mon Sep 17 00:00:00 2001
+From 035266019df7c3ea1c010471b5b4dd9d932f5425 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH] Fix linguist macro
@@ -38,5 +38,5 @@ index 23beeb39..bf1b0ad6 100644
DEPENDS ${_abs_FILE} VERBATIM
)
--
-2.24.1
+2.25.0
diff --git a/PKGBUILD b/PKGBUILD
index b789f6ae2951..b418c817d751 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,43 +5,49 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
+# All patches are managed at https://github.com/Martchus/qttools
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
# For QQuickWidgetPlugin, add mingw-w64-qt5-declarative to dependencies (already present by default)
-# For QWebViewPlugin, add mingw-w64-qt5-webkit to dependencies
+# For QWebViewPlugin, add mingw-w64-qt5-webkit to dependencies (mingw-w64-qt5-webkit is no longer updated)
# For QAxWidgetPlugin, add mingw-w64-qt5-activeqt to dependencies
-# All patches are managed at https://github.com/Martchus/qttools
+# Note that static MySQL and PostgreSQL plugins are disabled because mariadb-connector-c and posgresql come with their own pthread
+# implementation which has conflicting symbols with the pthread library Qt uses leading to errors like:
+# /usr/lib/gcc/i686-w64-mingw32/8.2.0/../../../../i686-w64-mingw32/bin/ld: /usr/i686-w64-mingw32/lib/libpthread.a(libwinpthread_la-mutex.o):
+# in function `pthread_mutex_lock': /build/mingw-w64-winpthreads/src/mingw-w64-v6.0.0/mingw-w64-libraries/winpthreads/src/mutex.c:187:
+# multiple definition of `pthread_mutex_lock'; /usr/i686-w64-mingw32/lib/libpq.a(pthread-win32.o):(.text+0x70): first defined here
_qt_module=qttools
-pkgname="mingw-w64-qt5-tools"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-tools
+pkgver=5.14.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL3' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Fix-linguist-macro.patch')
-sha256sums=('8d7f8612ab6078fe7289d8a8dd8112b550fd0f51b5455df2dcfba651c30c3adf'
- '4f21d5bf00a1bb868b1ba88de8b8eee2a6977b24a74e9dd3c7c7eb2ee09ba6e6')
+sha256sums=('7f5e6370cf4ed59f2bdd6517870cdcb1df9a055bbd885d056d90938ab302c70c'
+ 'd40cb534f47950c6a7d372e40ed07efede64bf92810a6929372e531549d6d0f0')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-# can not use static MySQL and PostgreSQL plugin because mariadb-connector-c and posgresql come with their own pthread implementation
-# which has conflicting symbols with the pthread library Qt uses, e.g. one would get the following error message:
-#/usr/lib/gcc/i686-w64-mingw32/8.2.0/../../../../i686-w64-mingw32/bin/ld: /usr/i686-w64-mingw32/lib/libpthread.a(libwinpthread_la-mutex.o): in function `pthread_mutex_lock': /build/mingw-w64-winpthreads/src/mingw-w64-v6.0.0/mingw-w64-libraries/winpthreads/src/mutex.c:187: multiple definition of `pthread_mutex_lock'; /usr/i686-w64-mingw32/lib/libpq.a(pthread-win32.o):(.text+0x70): first defined here
-
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=no_smart_library_merge QTPLUGIN.sqldrivers=qsqlite QTPLUGIN.sqldrivers+=qsqlodbc CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=no_smart_library_merge QTPLUGIN.sqldrivers=qsqlite QTPLUGIN.sqldrivers+=qsqlodbc CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -61,8 +67,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
-
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
@@ -118,11 +123,6 @@ package() {
for tool in lconvert lupdate lrelease windeployqt; do
ln -sf "../${_arch}/lib/qt/bin/${tool}" "${pkgdir}/usr/bin/${_arch}-$tool-qt5"
done
-
- # remove phrasebooks
- # Would save around 300 KiB on your floppy disk, I keep them by default because
- # phrasebooks might be useful when using Linguist
- #rm -r "${pkgdir}/usr/${_arch}/share"
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..4c20da7ce3c4
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,45 @@
+% layout 'mingw-w64-qt5-module';
+\
+% content_for additional_contributors => begin
+# Contributor: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+% end
+\
+% content_for comment_header => begin
+# For QQuickWidgetPlugin, add mingw-w64-qt5-declarative to dependencies (already present by default)
+# For QWebViewPlugin, add mingw-w64-qt5-webkit to dependencies (mingw-w64-qt5-webkit is no longer updated)
+# For QAxWidgetPlugin, add mingw-w64-qt5-activeqt to dependencies
+
+# Note that static MySQL and PostgreSQL plugins are disabled because mariadb-connector-c and posgresql come with their own pthread
+# implementation which has conflicting symbols with the pthread library Qt uses leading to errors like:
+# /usr/lib/gcc/i686-w64-mingw32/8.2.0/../../../../i686-w64-mingw32/bin/ld: /usr/i686-w64-mingw32/lib/libpthread.a(libwinpthread_la-mutex.o):
+# in function `pthread_mutex_lock': /build/mingw-w64-winpthreads/src/mingw-w64-v6.0.0/mingw-w64-libraries/winpthreads/src/mutex.c:187:
+# multiple definition of `pthread_mutex_lock'; /usr/i686-w64-mingw32/lib/libpq.a(pthread-win32.o):(.text+0x70): first defined here
+
+% end
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
+depends=('mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+\
+% content_for static_config => begin
+CONFIG+=no_smart_library_merge QTPLUGIN.sqldrivers=qsqlite QTPLUGIN.sqldrivers+=qsqlodbc \
+% end
+\
+% content_for package_config => begin
+
+ # create symlinks for tools
+ mkdir -p "${pkgdir}/usr/bin"
+ for tool in lconvert lupdate lrelease windeployqt; do
+ ln -sf "../${_arch}/lib/qt/bin/${tool}" "${pkgdir}/usr/bin/${_arch}-$tool-qt5"
+ done
+% end
+\
+% content_for package => begin
+
+<%== include 'fragments/mingw-w64-qt5-executable_suffix' %>\
+% end
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
new file mode 100644
index 000000000000..c407bfb790a1
--- /dev/null
+++ b/qttools-sha256.txt
@@ -0,0 +1 @@
+7f5e6370cf4ed59f2bdd6517870cdcb1df9a055bbd885d056d90938ab302c70c