summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-12-08 20:41:04 +0100
committerMartchus2016-12-08 20:41:04 +0100
commitf54912bb640d79f2805e473a419ad95b21db7951 (patch)
treebff3e0e3197ae7c943c167fb5ce82c0e728d3f3e
parent6620d46c3cee334320b2dc062f6c214bed6baca6 (diff)
downloadaur-f54912bb640d79f2805e473a419ad95b21db7951.tar.gz
Fix misc issues
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-linguist-macro.patch42
-rwxr-xr-xPKGBUILD16
3 files changed, 55 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1362968a2545..2915c66477c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Aug 19 20:10:25 UTC 2016
+# Thu Dec 8 19:41:02 UTC 2016
pkgbase = mingw-w64-qt5-tools
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
pkgver = 5.7.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.qt.io/
arch = i686
arch = x86_64
@@ -19,9 +19,9 @@ pkgbase = mingw-w64-qt5-tools
options = !buildflags
options = staticlibs
source = https://download.qt.io/official_releases/qt/5.7/5.7.0/submodules/qttools-opensource-src-5.7.0.tar.xz
- source = qt5-fix-linguist-cmake-macro.patch
+ source = 0001-Fix-linguist-macro.patch
md5sums = 29eb3fd31582b5801e264c62d1158553
- md5sums = ffc29956ebb79ba4fe8cac0b447c4214
+ md5sums = 3528c03fc5332ca448e9114bd6be78b1
pkgname = mingw-w64-qt5-tools
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
new file mode 100644
index 000000000000..5d8ea27c7b35
--- /dev/null
+++ b/0001-Fix-linguist-macro.patch
@@ -0,0 +1,42 @@
+From 1f1a8e6109b99b797efe52e91c47c1c04c629b83 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 25 Sep 2016 21:44:42 +0200
+Subject: [PATCH] Fix linguist macro
+
+- Prevent CMake appending extra 'Qt5::lupdate'/'Qt5::lrelease' to
+ command line when invoking lupdate/lrelease
+- Achieved by resolveing the IMPORTED_LOCATION manually
+---
+ src/linguist/Qt5LinguistToolsMacros.cmake | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/linguist/Qt5LinguistToolsMacros.cmake b/src/linguist/Qt5LinguistToolsMacros.cmake
+index 6013cc6..2e79732 100644
+--- a/src/linguist/Qt5LinguistToolsMacros.cmake
++++ b/src/linguist/Qt5LinguistToolsMacros.cmake
+@@ -71,8 +71,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
+
+ file(WRITE ${_ts_lst_file} "${_lst_file_srcs}")
+ endif()
++
++ get_target_property(LUPDATE_LOC ${Qt5_LUPDATE_EXECUTABLE} IMPORTED_LOCATION)
+ add_custom_command(OUTPUT ${_ts_file}
+- COMMAND ${Qt5_LUPDATE_EXECUTABLE}
++ COMMAND ${LUPDATE_LOC}
+ ARGS ${_lupdate_options} "@${_ts_lst_file}" -ts ${_ts_file}
+ DEPENDS ${_my_sources} ${_ts_lst_file} VERBATIM)
+ endforeach()
+@@ -93,8 +95,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
+ set(qm "${CMAKE_CURRENT_BINARY_DIR}/${qm}.qm")
+ endif()
+
++ get_target_property(LRELEASE_LOC ${Qt5_LRELEASE_EXECUTABLE} IMPORTED_LOCATION)
+ add_custom_command(OUTPUT ${qm}
+- COMMAND ${Qt5_LRELEASE_EXECUTABLE}
++ COMMAND ${LRELEASE_LOC}
+ ARGS ${_abs_FILE} -qm ${qm}
+ DEPENDS ${_abs_FILE} VERBATIM
+ )
+--
+2.10.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 73dac2e9afad..8a91c63e3ca1 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,10 +12,12 @@
# For QWebViewPlugin, add mingw-w64-qt5-webkit to dependencies
# For QAxWidgetPlugin, add mingw-w64-qt5-activeqt to dependencies
+# All patches are managed at https://github.com/Martchus/qttools
+
_qt_module=qttools
pkgname="mingw-w64-qt5-tools"
pkgver=5.7.0
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative')
@@ -25,9 +27,9 @@ license=('GPL3' 'LGPL3' 'FDL' 'custom')
url="https://www.qt.io/"
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
- "qt5-fix-linguist-cmake-macro.patch")
+ '0001-Fix-linguist-macro.patch')
md5sums=('29eb3fd31582b5801e264c62d1158553'
- 'ffc29956ebb79ba4fe8cac0b447c4214')
+ '3528c03fc5332ca448e9114bd6be78b1')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -40,10 +42,10 @@ _architectures='i686-w64-mingw32 x86_64-w64-mingw32'
prepare() {
cd "${srcdir}/${_pkgfqn}"
- # Somehow the linguist macro stopped working for me. CMake always appended
- # and extra Qt5::lupdate/Qt5::lrelease to the command when invoking lupdate/lrelease.
- # This patch resolves the IMPORTED_LOCATION manually which seems to work.
- patch -p0 -i ../qt5-fix-linguist-cmake-macro.patch
+ # Apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
}
build() {