summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:26:35 +0200
committerMartchus2020-09-13 13:26:35 +0200
commit4f320441dc2561b1e1ab36cff3575c67db91dda6 (patch)
tree8016db56132d82b4eb529d13759507d48ad38efa
downloadaur-4f320441dc2561b1e1ab36cff3575c67db91dda6.tar.gz
Update to 5.15.1
-rw-r--r--.SRCINFO28
-rw-r--r--0001-Fix-linguist-macro.patch42
-rw-r--r--PKGBUILD133
-rw-r--r--PKGBUILD.sh.ep1
-rw-r--r--qttools-sha256.txt1
5 files changed, 205 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d8bf02fa4e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = mingw-w64-qt5-tools-static
+ pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
+ pkgver = 5.15.1
+ pkgrel = 1
+ url = https://www.qt.io/
+ arch = any
+ groups = mingw-w64-qt5
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ makedepends = mingw-w64-postgresql
+ makedepends = mingw-w64-mariadb-connector-c
+ makedepends = mingw-w64-vulkan-headers
+ depends = mingw-w64-qt5-declarative-static
+ depends = mingw-w64-qt5-tools
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qttools-everywhere-src-5.15.1.tar.xz
+ source = 0001-Fix-linguist-macro.patch
+ sha256sums = c98ee5f0f980bf68cbf0c94d62434816a92441733de50bd9adbe9b9055f03498
+ sha256sums = ca4cdea138d38a8f55a20f4821d35138035115dd1c61ae1b28156d90aa75b38a
+
+pkgname = mingw-w64-qt5-tools-static
+
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
new file mode 100644
index 000000000000..429a07f66f92
--- /dev/null
+++ b/0001-Fix-linguist-macro.patch
@@ -0,0 +1,42 @@
+From 4b848e15c429260e3c78d897b30dc03adcf23fad Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 25 Sep 2016 21:44:42 +0200
+Subject: [PATCH] Fix linguist macro
+
+- Prevent CMake appending extra 'Qt5::lupdate'/'Qt5::lrelease' to
+ command line when invoking lupdate/lrelease
+- Achieved by resolveing the IMPORTED_LOCATION manually
+---
+ src/linguist/Qt5LinguistToolsMacros.cmake | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/src/linguist/Qt5LinguistToolsMacros.cmake b/src/linguist/Qt5LinguistToolsMacros.cmake
+index ab271d56..f54c99c4 100644
+--- a/src/linguist/Qt5LinguistToolsMacros.cmake
++++ b/src/linguist/Qt5LinguistToolsMacros.cmake
+@@ -71,8 +71,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
+
+ file(WRITE ${_ts_lst_file} "${_lst_file_srcs}")
+ endif()
++
++ get_target_property(LUPDATE_LOC ${Qt5_LUPDATE_EXECUTABLE} IMPORTED_LOCATION)
+ add_custom_command(OUTPUT ${_ts_file}
+- COMMAND ${Qt5_LUPDATE_EXECUTABLE}
++ COMMAND ${LUPDATE_LOC}
+ ARGS ${_lupdate_options} "@${_ts_lst_file}" -ts ${_ts_file}
+ DEPENDS ${_my_sources}
+ BYPRODUCTS ${_ts_lst_file} VERBATIM)
+@@ -114,8 +116,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
+ set(qm "${CMAKE_CURRENT_BINARY_DIR}/${FILE_NAME}.qm")
+ endif()
+
++ get_target_property(LRELEASE_LOC ${Qt5_LRELEASE_EXECUTABLE} IMPORTED_LOCATION)
+ add_custom_command(OUTPUT ${qm}
+- COMMAND ${Qt5_LRELEASE_EXECUTABLE}
++ COMMAND ${LRELEASE_LOC}
+ ARGS ${_LRELEASE_OPTIONS} ${_abs_FILE} -qm ${qm}
+ DEPENDS ${_abs_FILE} VERBATIM
+ )
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..634c8f6221f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,133 @@
+# Maintainer: Martchus <martchus@gmx.net>
+# Contributor: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
+# All patches are managed at https://github.com/Martchus/qttools
+
+# For QQuickWidgetPlugin, add mingw-w64-qt5-declarative to dependencies (already present by default)
+# For QWebViewPlugin, add mingw-w64-qt5-webkit to dependencies (mingw-w64-qt5-webkit is no longer updated)
+# For QAxWidgetPlugin, add mingw-w64-qt5-activeqt to dependencies
+
+# Note that static MySQL and PostgreSQL plugins are disabled because mariadb-connector-c and posgresql come with their own pthread
+# implementation which has conflicting symbols with the pthread library Qt uses leading to errors like:
+# /usr/lib/gcc/i686-w64-mingw32/8.2.0/../../../../i686-w64-mingw32/bin/ld: /usr/i686-w64-mingw32/lib/libpthread.a(libwinpthread_la-mutex.o):
+# in function `pthread_mutex_lock': /build/mingw-w64-winpthreads/src/mingw-w64-v6.0.0/mingw-w64-libraries/winpthreads/src/mutex.c:187:
+# multiple definition of `pthread_mutex_lock'; /usr/i686-w64-mingw32/lib/libpq.a(pthread-win32.o):(.text+0x70): first defined here
+
+_qt_module=qttools
+pkgname=mingw-w64-qt5-tools-static
+pkgver=5.15.1
+pkgrel=1
+arch=('any')
+pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
+depends=('mingw-w64-qt5-declarative-static')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+options=('!strip' '!buildflags' 'staticlibs')
+groups=('mingw-w64-qt5')
+url='https://www.qt.io/'
+_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Fix-linguist-macro.patch')
+sha256sums=('c98ee5f0f980bf68cbf0c94d62434816a92441733de50bd9adbe9b9055f03498'
+ 'ca4cdea138d38a8f55a20f4821d35138035115dd1c61ae1b28156d90aa75b38a')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
+_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=no_smart_library_merge QTPLUGIN.sqldrivers=qsqlite QTPLUGIN.sqldrivers+=qsqlodbc CONFIG+=static')
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
+}
+
+build() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
+ make
+ popd
+ done
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ # use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
+ # replace library path in *.prl files so it points to the installed location and not the build directory
+ find "${pkgdir}/usr/${_arch}/lib" \( -type f -name '*.prl' -o -name '*.pc' \) -exec sed -i -e "s:$PWD/lib:/usr/$_arch/lib:g" {} \;
+
+ # remove prl files for debug version
+ if ! [[ $MINGW_W64_QT_DEBUG_BUILD ]]; then
+ for file in $(find "${pkgdir}/usr/${_arch}" -name '*d.prl' -o -name '*d.static.prl'); do
+ [ -f "${file%d*}${file##*d}" ] && rm "${file}";
+ done
+ fi
+
+ # remove '.static.prl' files
+ find "${pkgdir}/usr/${_arch}" -name '.static.prl' -delete
+
+ # delete duplicate files that are in the shared package
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -delete
+ for shared_path in "${pkgdir}/usr/${_arch}/"{include,share} "${pkgdir}/usr/${_arch}/lib/"{qt/bin,qt/mkspecs}; do
+ [[ -d $shared_path ]] && rm -fR "$shared_path"
+ done
+ for file in $(find "$pkgdir/usr/$_arch/lib"); do
+ [[ -f "${file##$pkgdir}" ]] && rm "$file"
+ done
+
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name '*.dll' -delete
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" \( -name '*.a' -not -name 'libQt5QmlDevTools.a' -not -name 'libQt5Bootstrap.a' \) -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+
+ # create symlinks for tools
+ mkdir -p "${pkgdir}/usr/bin"
+ for tool in lconvert lupdate lrelease windeployqt; do
+ ln -sf "../${_arch}/lib/qt/bin/${tool}" "${pkgdir}/usr/bin/${_arch}-$tool-qt5"
+ done
+ popd
+ done
+
+ # drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+ done
+
+}
+
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..87756da456f4
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1 @@
+%= include "$default_package_name/mingw-w64/PKGBUILD";
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
new file mode 100644
index 000000000000..882e147262cd
--- /dev/null
+++ b/qttools-sha256.txt
@@ -0,0 +1 @@
+c98ee5f0f980bf68cbf0c94d62434816a92441733de50bd9adbe9b9055f03498