summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-04-10 21:44:06 +0200
committerMartchus2023-04-10 21:44:06 +0200
commitae7fea133b2ab54eb305c440f755532f78b6f34b (patch)
treec691de1d0bcf375a93ed55035b3f536581b44f2f
parent18e1626809889d9fbc80b95b792d82dd95cb4eb4 (diff)
downloadaur-ae7fea133b2ab54eb305c440f755532f78b6f34b.tar.gz
Rebase on 5.15.9
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Fix-linguist-macro.patch30
-rw-r--r--PKGBUILD6
3 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 167e7836321e..a5f97db894c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-tools-static
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.15.8+kde+r1
+ pkgver = 5.15.9+kde+r1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -20,9 +20,9 @@ pkgbase = mingw-w64-qt5-tools-static
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://invent.kde.org/qt/qt/qttools#commit=090e526e713d01eac34c64e4a09ad961c612febf
+ source = git+https://invent.kde.org/qt/qt/qttools#commit=5649efd376ed7dbb171905e9edebbd547d1f73eb
source = 0001-Fix-linguist-macro.patch
sha256sums = SKIP
- sha256sums = fb54af0dde92a4c5390f887cfae7f95c75ab22887e1e5c5f1a88d083837310a3
+ sha256sums = 6b99ea86a90d88227a4758e029e0e99db7ed5e683aec33ac82a49df8790c24e7
pkgname = mingw-w64-qt5-tools-static
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 453fde29422a..cdaf252beb2e 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From a903fff188187e93c49724a797c257e4173fbf0f Mon Sep 17 00:00:00 2001
+From 526d7e1fbdd80578a112c2c67ead312278321769 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH] Fix linguist macro
@@ -6,37 +6,39 @@ Subject: [PATCH] Fix linguist macro
- Prevent CMake appending extra 'Qt5::lupdate'/'Qt5::lrelease' to
command line when invoking lupdate/lrelease
- Achieved by resolveing the IMPORTED_LOCATION manually
+
+Change-Id: Ie502d6237f0fed14f377912463f394c8d6ae396d
---
- src/linguist/Qt5LinguistToolsMacros.cmake | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
+ src/linguist/Qt5LinguistToolsMacros.cmake | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/src/linguist/Qt5LinguistToolsMacros.cmake b/src/linguist/Qt5LinguistToolsMacros.cmake
-index ab1534144..1106633d0 100644
+index 6a45e57be..c034f2749 100644
--- a/src/linguist/Qt5LinguistToolsMacros.cmake
+++ b/src/linguist/Qt5LinguistToolsMacros.cmake
-@@ -90,8 +90,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
-
+@@ -96,8 +96,9 @@ function(QT5_CREATE_TRANSLATION _qm_files)
file(WRITE ${_ts_lst_file} "${_lst_file_srcs}")
endif()
-+
+ set(stamp_file "${stamp_file_dir}/${_ts_name}.stamp")
+ get_target_property(LUPDATE_LOC ${Qt5_LUPDATE_EXECUTABLE} IMPORTED_LOCATION)
- add_custom_command(OUTPUT ${_ts_file}
+ add_custom_command(OUTPUT ${stamp_file}
- COMMAND ${Qt5_LUPDATE_EXECUTABLE}
+ COMMAND ${LUPDATE_LOC}
ARGS ${_lupdate_options} "@${_ts_lst_file}" -ts ${_ts_file}
+ COMMAND ${CMAKE_COMMAND} -E touch "${stamp_file}"
DEPENDS ${_dependencies}
- VERBATIM)
-@@ -133,8 +135,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
- set(qm "${CMAKE_CURRENT_BINARY_DIR}/${FILE_NAME}.qm")
+@@ -146,9 +147,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
+ else()
+ set(qm_dep "${_abs_FILE}")
endif()
-
+-
+ get_target_property(LRELEASE_LOC ${Qt5_LRELEASE_EXECUTABLE} IMPORTED_LOCATION)
add_custom_command(OUTPUT ${qm}
- COMMAND ${Qt5_LRELEASE_EXECUTABLE}
+ COMMAND ${LRELEASE_LOC}
ARGS ${_LRELEASE_OPTIONS} ${_abs_FILE} -qm ${qm}
- DEPENDS ${_abs_FILE} VERBATIM
+ DEPENDS ${qm_dep} VERBATIM
)
--
-2.39.0
+2.40.0
diff --git a/PKGBUILD b/PKGBUILD
index d83a76b8cfa2..0e11e1d71d63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,14 +23,14 @@
_qt_module=qttools
pkgname=mingw-w64-qt5-tools-static
-pkgver=5.15.8
+pkgver=5.15.9
pkgrel=1
arch=('any')
pkgdesc="A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)"
depends=('mingw-w64-qt5-declarative-static')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
-_commit=090e526e713d01eac34c64e4a09ad961c612febf
+_commit=5649efd376ed7dbb171905e9edebbd547d1f73eb
_basever=$pkgver
pkgver+=+kde+r1
makedepends+=('git')
@@ -41,7 +41,7 @@ _pkgfqn=${_qt_module}
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
'0001-Fix-linguist-macro.patch')
sha256sums=('SKIP'
- 'fb54af0dde92a4c5390f887cfae7f95c75ab22887e1e5c5f1a88d083837310a3')
+ '6b99ea86a90d88227a4758e029e0e99db7ed5e683aec33ac82a49df8790c24e7')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'