summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-04-14 11:37:28 +0200
committerMartchus2021-04-14 11:37:28 +0200
commitdb44239183026aa754c7f8119f4d9b087ec5d5c4 (patch)
treec9ba7ad91d6d0a63f2979a943f052247613823ca
parenta3a0c56ad8ff8bdbff06acb3c6a578952cad24f7 (diff)
downloadaur-db44239183026aa754c7f8119f4d9b087ec5d5c4.tar.gz
Update to use KDE fork patches
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Fix-linguist-macro.patch14
-rwxr-xr-xPKGBUILD18
-rw-r--r--qttools-sha256.txt2
4 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 184d25a1d84e..b6b8c4dcd505 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-tools-static
pkgdesc = A cross-platform application and UI framework (Development Tools, QtHelp; mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.2+kde+r17
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -14,15 +14,16 @@ pkgbase = mingw-w64-qt5-tools-static
makedepends = mingw-w64-postgresql
makedepends = mingw-w64-mariadb-connector-c
makedepends = mingw-w64-vulkan-headers
+ makedepends = git
depends = mingw-w64-qt5-declarative-static
depends = mingw-w64-qt5-tools
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qttools-everywhere-src-5.15.2.tar.xz
+ source = git+https://invent.kde.org/qt/qt/qttools#commit=33693a928986006d79c1ee743733cde5966ac402
source = 0001-Fix-linguist-macro.patch
- sha256sums = c189d0ce1ff7c739db9a3ace52ac3e24cb8fd6dbf234e49f075249b38f43c1cc
- sha256sums = e2ce8a553c78fd0dc6934be7d58a9bb90fe465619ac20a567d579c4c90bc01ab
+ sha256sums = SKIP
+ sha256sums = cf7fcd9b2cfa110e95bde957a00c600da17bc75fdf7be1f72204eb5364cbf397
pkgname = mingw-w64-qt5-tools-static
diff --git a/0001-Fix-linguist-macro.patch b/0001-Fix-linguist-macro.patch
index 44200a934d3e..8927b419a50c 100644
--- a/0001-Fix-linguist-macro.patch
+++ b/0001-Fix-linguist-macro.patch
@@ -1,4 +1,4 @@
-From 43c51a28149ae923fedbf215a64a5456dc44a664 Mon Sep 17 00:00:00 2001
+From 4818c98b4cc9441fecea9c63479ca7d5c05ed967 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Sun, 25 Sep 2016 21:44:42 +0200
Subject: [PATCH] Fix linguist macro
@@ -11,10 +11,10 @@ Subject: [PATCH] Fix linguist macro
1 file changed, 5 insertions(+), 2 deletions(-)
diff --git a/src/linguist/Qt5LinguistToolsMacros.cmake b/src/linguist/Qt5LinguistToolsMacros.cmake
-index ab271d56..f54c99c4 100644
+index 20fb1493..406d3d3a 100644
--- a/src/linguist/Qt5LinguistToolsMacros.cmake
+++ b/src/linguist/Qt5LinguistToolsMacros.cmake
-@@ -71,8 +71,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
+@@ -90,8 +90,10 @@ function(QT5_CREATE_TRANSLATION _qm_files)
file(WRITE ${_ts_lst_file} "${_lst_file_srcs}")
endif()
@@ -24,9 +24,9 @@ index ab271d56..f54c99c4 100644
- COMMAND ${Qt5_LUPDATE_EXECUTABLE}
+ COMMAND ${LUPDATE_LOC}
ARGS ${_lupdate_options} "@${_ts_lst_file}" -ts ${_ts_file}
- DEPENDS ${_my_sources}
- BYPRODUCTS ${_ts_lst_file} VERBATIM)
-@@ -114,8 +116,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
+ DEPENDS ${_dependencies}
+ VERBATIM)
+@@ -133,8 +135,9 @@ function(QT5_ADD_TRANSLATION _qm_files)
set(qm "${CMAKE_CURRENT_BINARY_DIR}/${FILE_NAME}.qm")
endif()
@@ -38,5 +38,5 @@ index ab271d56..f54c99c4 100644
DEPENDS ${_abs_FILE} VERBATIM
)
--
-2.29.2
+2.31.1
diff --git a/PKGBUILD b/PKGBUILD
index bcb8cf1bd099..b252095899a3 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,23 +30,33 @@ pkgdesc="A cross-platform application and UI framework (Development Tools, QtHel
depends=('mingw-w64-qt5-declarative-static')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config' 'mingw-w64-postgresql' 'mingw-w64-mariadb-connector-c' 'mingw-w64-vulkan-headers')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=33693a928986006d79c1ee743733cde5966ac402
+pkgver+=+kde+r17
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
'0001-Fix-linguist-macro.patch')
-sha256sums=('c189d0ce1ff7c739db9a3ace52ac3e24cb8fd6dbf234e49f075249b38f43c1cc'
- 'e2ce8a553c78fd0dc6934be7d58a9bb90fe465619ac20a567d579c4c90bc01ab')
+sha256sums=('SKIP'
+ 'cf7fcd9b2cfa110e95bde957a00c600da17bc75fdf7be1f72204eb5364cbf397')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=no_smart_library_merge QTPLUGIN.sqldrivers=qsqlite QTPLUGIN.sqldrivers+=qsqlodbc CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "5.15.2+kde+r"`git rev-list --count origin/5.15.2..$_commit`
+}
+
prepare() {
cd "${srcdir}/${_pkgfqn}"
+ git revert -n dbe0567470db2b369a9fdb28d9fbac38be3e2d60 # Revert version bump
+
# apply patches; further descriptions can be found in patch files itself
for patch in "$srcdir/"*.patch; do
patch -p1 -i "$patch"
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
index 73691a3fd8a3..cc2ecb636e3a 100644
--- a/qttools-sha256.txt
+++ b/qttools-sha256.txt
@@ -1 +1 @@
-c189d0ce1ff7c739db9a3ace52ac3e24cb8fd6dbf234e49f075249b38f43c1cc
+SKIP