summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip A Reimer2015-06-12 22:07:10 -0600
committerPhilip A Reimer2015-06-12 22:07:10 -0600
commit10125a22b2c35ff2b372c2f31bad632a644659b0 (patch)
tree03ab05e23b2201a11ec77963b57c4314c00678cf
downloadaur-10125a22b2c35ff2b372c2f31bad632a644659b0.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3555f142a39e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mingw-w64-qt5-translations
+ pkgdesc = Qt5 for Windows -- QtTranslations module (mingw-w64)
+ pkgver = 5.4.2
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = any
+ license = GPL3
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-qt5-tools
+ depends = mingw-w64-qt5-base
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://download.qt-project.org/official_releases/qt/5.4/5.4.2/submodules/qttranslations-opensource-src-5.4.2.tar.xz
+ md5sums = 35151a736e3b720de4f5128386f9c834
+
+pkgname = mingw-w64-qt5-translations
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e3f4cfd30b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: ant32 <antreimer@gmail.com>
+# Contributor: Filip Brcic <brcha@gna.org>
+
+_qt_module=qttranslations
+pkgname="mingw-w64-qt5-translations"
+pkgver=5.4.2
+pkgrel=1
+arch=('any')
+pkgdesc="Qt5 for Windows -- QtTranslations module (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc' 'mingw-w64-qt5-tools')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('GPL3' 'LGPL')
+url="http://qt-project.org/"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+source=("http://download.qt-project.org/official_releases/qt/5.4/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('35151a736e3b720de4f5128386f9c834')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build()
+{
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ popd
+ done
+}