summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:09 +0100
committerMartchus2022-03-08 23:35:09 +0100
commit28004ca04df0fb8ee998f7a970f48f6fbca20a3d (patch)
tree30412d3c835571fe8f3200d136c02563cd2a4533
parenteb63a53cb18aeee442c3e6a72b89dabbc4ce686c (diff)
downloadaur-28004ca04df0fb8ee998f7a970f48f6fbca20a3d.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf7887ef1a57..ffccbdb81d98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-webchannel
pkgdesc = Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r3
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,12 +11,12 @@ pkgbase = mingw-w64-qt5-webchannel
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-declarative
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtwebchannel-everywhere-src-5.15.2.tar.xz
- sha256sums = 127fe79c43b386713f151ed7d411cd81e45e29f9c955584f29736f78c9303ec1
+ source = git+https://invent.kde.org/qt/qt/qtwebchannel#commit=611016a49f3a9ba7b58bef29bc295323e06373ae
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-webchannel
-
diff --git a/PKGBUILD b/PKGBUILD
index c4fa30a6bda8..135a41ffd139 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,24 +9,37 @@
_qt_module=qtwebchannel
pkgname=mingw-w64-qt5-webchannel
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)'
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL' 'FDL' 'custom')
+_commit=611016a49f3a9ba7b58bef29bc295323e06373ae
+_basever=$pkgver
+pkgver+=+kde+r3
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('127fe79c43b386713f151ed7d411cd81e45e29f9c955584f29736f78c9303ec1')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 2b4f5a333418..0085a229a690 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt5-module';
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)'