summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:09:27 +0100
committerMartchus2020-01-29 19:09:27 +0100
commit325c8769b823009fc8d9de3fb62fe3b67db0edcf (patch)
treec1835d7af3b1a077a4ed9a3a87f535aac7e0410a
parentdd1729c090fbf0805be02d5707cacf2082d598ad (diff)
downloadaur-325c8769b823009fc8d9de3fb62fe3b67db0edcf.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--PKGBUILD.sh.ep9
-rw-r--r--qtwebchannel-sha256.txt1
4 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 133fedcd5403..250dd360ed31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-webchannel
pkgdesc = Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -17,8 +17,8 @@ pkgbase = mingw-w64-qt5-webchannel
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtwebchannel-everywhere-src-5.14.0.tar.xz
- sha256sums = 0cb8dd07b34da8d44f8a14701409ce87fce5010f9b57273b357717c2dfd35383
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtwebchannel-everywhere-src-5.14.1.tar.xz
+ sha256sums = 3af5262fde14c7dfe7bcc12d5796a482837bd09f0878851fd8de5db0b1985e6a
pkgname = mingw-w64-qt5-webchannel
diff --git a/PKGBUILD b/PKGBUILD
index 498b49e30ace..49112b4ef40e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,35 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtwebchannel
pkgname=mingw-w64-qt5-webchannel
-pkgver=5.14.0
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)'
depends=('mingw-w64-qt5-declarative')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-groups=('mingw-w64-qt5')
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('0cb8dd07b34da8d44f8a14701409ce87fce5010f9b57273b357717c2dfd35383')
+sha256sums=('3af5262fde14c7dfe7bcc12d5796a482837bd09f0878851fd8de5db0b1985e6a')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -38,7 +42,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..642bd31d9462
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,9 @@
+% layout 'mingw-w64-qt5-module';
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)'
+depends=('mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
diff --git a/qtwebchannel-sha256.txt b/qtwebchannel-sha256.txt
new file mode 100644
index 000000000000..fb5932472bb5
--- /dev/null
+++ b/qtwebchannel-sha256.txt
@@ -0,0 +1 @@
+3af5262fde14c7dfe7bcc12d5796a482837bd09f0878851fd8de5db0b1985e6a