summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-01-25 20:45:53 +0100
committerMartchus2016-01-25 20:45:53 +0100
commit64e508de0ff44720f87119b1820d31501b0734e4 (patch)
tree33c5119a2a619f289e752d9412c8328895ca5c2e
downloadaur-64e508de0ff44720f87119b1820d31501b0734e4.tar.gz
initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD47
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5980c2c4e55e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Mon Jan 25 19:43:34 UTC 2016
+pkgbase = mingw-w64-qt5-webchannel
+ pkgdesc = Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)
+ pkgver = 5.5.1
+ pkgrel = 1
+ url = http://qt-project.org
+ arch = any
+ groups = mingw-w64-qt
+ groups = mingw-w64-qt5
+ license = custom
+ license = FDL
+ license = GPL3
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-qt5-declarative
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://download.qt-project.org/official_releases/qt/5.5/5.5.1/submodules/qtwebchannel-opensource-src-5.5.1.tar.xz
+ md5sums = f2e15d52c1b7732c2afbfb7e843091cf
+
+pkgname = mingw-w64-qt5-webchannel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac39b0eb4e66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+_qt_module=qtwebchannel
+pkgname=mingw-w64-qt5-webchannel
+pkgver=5.5.1
+pkgrel=1
+arch=('any')
+pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)'
+depends=('mingw-w64-qt5-declarative')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('custom' 'FDL' 'GPL3' 'LGPL')
+url="http://qt-project.org"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+groups=(mingw-w64-qt mingw-w64-qt5)
+source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('f2e15d52c1b7732c2afbfb7e843091cf')
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
+build() {
+ unset PKG_CONFIG_PATH
+ cd "${srcdir}/${_pkgfqn}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${_pkgfqn}/build-${_arch}"
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # The .dll's are installed in both bindir and libdir
+ # One copy of the .dll's is sufficient
+ rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -o -name "*.bat" -o -name "*.def" -o -name "*.exp" -o -name '*.prl' | xargs -rtl1 rm
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -o -name "*.dll" | xargs -rtl1 ${_arch}-strip -g
+ done
+}