summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-08-19 22:10:31 +0200
committerMartchus2016-08-19 22:10:31 +0200
commitf6870564aa0465e58d9762750db108f63858c308 (patch)
tree522130c866551fe4c7066e50879c72650fcf3208
parentf0b01c9470ac4e4ff25f6a893430a03fee362d2d (diff)
downloadaur-f6870564aa0465e58d9762750db108f63858c308.tar.gz
Add static version of further Qt modules
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD55
2 files changed, 40 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a7f5825be87..1a99eb33b58e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jun 22 18:36:06 UTC 2016
+# Fri Aug 19 20:10:31 UTC 2016
pkgbase = mingw-w64-qt5-webchannel
pkgdesc = Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)
pkgver = 5.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io/
arch = any
groups = mingw-w64-qt
@@ -13,7 +13,9 @@ pkgbase = mingw-w64-qt5-webchannel
license = GPL3
license = LGPL
makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-declarative
+ optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index be319ca34073..e84a8328ca04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,13 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# Includes dynamic and static versions; if only one version is requried, just
+# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
+
_qt_module=qtwebchannel
pkgname=mingw-w64-qt5-webchannel
pkgver=5.7.0
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)'
depends=('mingw-w64-qt5-declarative')
@@ -18,33 +21,47 @@ _pkgfqn="${_qt_module}-opensource-src-${pkgver}"
groups=(mingw-w64-qt mingw-w64-qt5)
source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
md5sums=('dd7699ddeb203d77237ab58a06f9fbfa')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "${srcdir}/${_pkgfqn}"
-}
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+[[ $NO_STATIC_LIBS ]] || \
+ makedepends+=('mingw-w64-qt5-base-static') \
+ optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
+ _configurations+=('CONFIG+=static')
+[[ $NO_SHARED_LIBS ]] || \
+ _configurations+=('CONFIG+=shared')
build() {
- unset PKG_CONFIG_PATH
cd "${srcdir}/${_pkgfqn}"
+
for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro
- make
- popd
+ for _config in "${_configurations[@]}"; do
+ msg2 "Building ${_config##*=} version for ${_arch}"
+ mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ make
+ popd
+ done
done
}
package() {
+ cd "${srcdir}/${_pkgfqn}"
+
for _arch in ${_architectures}; do
- cd "${srcdir}/${_pkgfqn}/build-${_arch}"
- make INSTALL_ROOT="${pkgdir}" install
-
- # The .dll's are installed in both bindir and libdir
- # One copy of the .dll's is sufficient
- rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
- find "${pkgdir}/usr/${_arch}" -name "*.exe" -o -name "*.bat" -o -name "*.def" -o -name "*.exp" -o -name '*.prl' | xargs -rtl1 rm
- find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
- find "${pkgdir}/usr/${_arch}" -name "*.a" -o -name "*.dll" | xargs -rtl1 ${_arch}-strip -g
+ for _config in "${_configurations[@]}"; do
+ pushd build-${_arch}-${_config##*=}
+
+ make INSTALL_ROOT="$pkgdir" install
+ find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
+ [ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
+ find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.dll" -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name "*.a" -exec ${_arch}-strip -g {} \;
+ [[ -d "${pkgdir}/usr/${_arch}/lib/qt/bin/" ]] && \
+ find "${pkgdir}/usr/${_arch}/lib/qt/bin/" -exec strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
+ popd
+ done
done
}