summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:10:45 +0100
committerMartchus2020-01-29 19:10:45 +0100
commit993e58db11bf7d5432b872a901767b6ff71c3089 (patch)
tree35da5f3b1b7525622655eddb81118cfa98c21a3a
parentdd82c73450a40eae2db5fd62b2846174197b091c (diff)
downloadaur-993e58db11bf7d5432b872a901767b6ff71c3089.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Hardcode-linker-flags-for-platform-plugin.patch4
-rw-r--r--PKGBUILD24
-rw-r--r--PKGBUILD.sh.ep13
-rw-r--r--qtwebglplugin-sha256.txt1
5 files changed, 36 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5b4c673ea17..243bca357fb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = mingw-w64-qt5-webglplugin
pkgdesc = QPA plugin for running an application via a browser using streamed WebGL commands (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
- arch = i686
- arch = x86_64
+ arch = any
groups = mingw-w64-qt5
license = GPL3
license = LGPL3
@@ -19,10 +18,10 @@ pkgbase = mingw-w64-qt5-webglplugin
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtwebglplugin-everywhere-src-5.14.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtwebglplugin-everywhere-src-5.14.1.tar.xz
source = 0001-Hardcode-linker-flags-for-platform-plugin.patch
- sha256sums = 9707f7b860d798d478c0237c49ab43d4b99e1ad5b297555a4df6ffac4c5a1a76
- sha256sums = 8804dc7a55f74c738dc0f64eefb75f912647bceaf4a3f3e783a141507c92162a
+ sha256sums = de7768ab6a8de06e09467b6dc8714fa71ed5781e2654aa3498a7105328f565a6
+ sha256sums = 018bb036b93ff1235918fa1e96800f2ffb158dec93079819e817780ab3309e4e
pkgname = mingw-w64-qt5-webglplugin
diff --git a/0001-Hardcode-linker-flags-for-platform-plugin.patch b/0001-Hardcode-linker-flags-for-platform-plugin.patch
index d231d07fde69..eee8edfe7429 100644
--- a/0001-Hardcode-linker-flags-for-platform-plugin.patch
+++ b/0001-Hardcode-linker-flags-for-platform-plugin.patch
@@ -1,4 +1,4 @@
-From c321db30663dde0e39ca288642ee3231bbf87873 Mon Sep 17 00:00:00 2001
+From 05301ea948b2ffb644e1216e0e82af3e3d6a1b22 Mon Sep 17 00:00:00 2001
From: Marius Kittler <mkittler@suse.de>
Date: Wed, 12 Dec 2018 18:16:54 +0100
Subject: [PATCH] Hardcode linker flags for platform plugin
@@ -42,5 +42,5 @@ index 7f7227c..45f8f66 100644
qtHaveModule(quick) {
QT += quick
--
-2.24.1
+2.25.0
diff --git a/PKGBUILD b/PKGBUILD
index 0b7a05fba561..ff7ac0ef796e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,37 @@
# Maintainer: Martchus <martchus@gmx.net>
-# Contributor: ant32 <antreimer@gmail.com>
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
+# All patches are managed at https://github.com/Martchus/qtwebglplugin
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtwebglplugin
-pkgname="mingw-w64-qt5-webglplugin"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-webglplugin
+pkgver=5.14.1
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('any')
pkgdesc="QPA plugin for running an application via a browser using streamed WebGL commands (mingw-w64)"
depends=('mingw-w64-qt5-declarative' 'mingw-w64-qt5-websockets')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL3' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Hardcode-linker-flags-for-platform-plugin.patch')
-sha256sums=('9707f7b860d798d478c0237c49ab43d4b99e1ad5b297555a4df6ffac4c5a1a76'
- '8804dc7a55f74c738dc0f64eefb75f912647bceaf4a3f3e783a141507c92162a')
+sha256sums=('de7768ab6a8de06e09467b6dc8714fa71ed5781e2654aa3498a7105328f565a6'
+ '018bb036b93ff1235918fa1e96800f2ffb158dec93079819e817780ab3309e4e')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
@@ -38,7 +44,6 @@ prepare() {
# apply patches; further descriptions can be found in patch files itself
for patch in "$srcdir/"*.patch; do
- msg2 "Applying patch $patch"
patch -p1 -i "$patch"
done
}
@@ -50,7 +55,8 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} QT_INSTALL_PREFIX="/usr/${_arch}"
+ _additional_qmake_args=QT_INSTALL_PREFIX=/usr/${_arch}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..a50b9a4c09a7
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,13 @@
+% layout 'mingw-w64-qt5-module';
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc="QPA plugin for running an application via a browser using streamed WebGL commands (mingw-w64)"
+depends=('mingw-w64-qt5-declarative' 'mingw-w64-qt5-websockets')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+\
+% content_for build_config => begin
+ _additional_qmake_args=QT_INSTALL_PREFIX=/usr/${_arch}
+% end
diff --git a/qtwebglplugin-sha256.txt b/qtwebglplugin-sha256.txt
new file mode 100644
index 000000000000..015ccd827579
--- /dev/null
+++ b/qtwebglplugin-sha256.txt
@@ -0,0 +1 @@
+de7768ab6a8de06e09467b6dc8714fa71ed5781e2654aa3498a7105328f565a6