summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:34 +0100
committerMartchus2022-03-08 23:35:34 +0100
commitae18d22eca187f5f86d0389428f7f3f0f3a44836 (patch)
tree07786558a97f12006fc7f5d9f8f22fc6ee2ecfc7
parent8ccfab118965787c0464871ca0519c0a0ba2725c (diff)
downloadaur-ae18d22eca187f5f86d0389428f7f3f0f3a44836.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7991f9a8543a..71feb65f3d16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-webglplugin
pkgdesc = QPA plugin for running an application via a browser using streamed WebGL commands (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,15 +11,15 @@ pkgbase = mingw-w64-qt5-webglplugin
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-declarative
depends = mingw-w64-qt5-websockets
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtwebglplugin-everywhere-src-5.15.2.tar.xz
+ source = git+https://invent.kde.org/qt/qt/qtwebglplugin#commit=4318ad91c2a8bea3a0aaaa64aaf49d3b997e50a1
source = 0001-Hardcode-linker-flags-for-platform-plugin.patch
- sha256sums = 81e782b517ed29e10bea1aa90c9f59274c98a910f2c8b105fa78368a36b41446
+ sha256sums = SKIP
sha256sums = c855d5b15171ed0f8d730898a62621462a71dbdb0b296d1e0ba2d3cfa87a8bcb
pkgname = mingw-w64-qt5-webglplugin
-
diff --git a/PKGBUILD b/PKGBUILD
index 1cfce71b3ff6..6b38f599c7cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,26 +11,35 @@
_qt_module=qtwebglplugin
pkgname=mingw-w64-qt5-webglplugin
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="QPA plugin for running an application via a browser using streamed WebGL commands (mingw-w64)"
depends=('mingw-w64-qt5-declarative' 'mingw-w64-qt5-websockets')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=4318ad91c2a8bea3a0aaaa64aaf49d3b997e50a1
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
'0001-Hardcode-linker-flags-for-platform-plugin.patch')
-sha256sums=('81e782b517ed29e10bea1aa90c9f59274c98a910f2c8b105fa78368a36b41446'
+sha256sums=('SKIP'
'c855d5b15171ed0f8d730898a62621462a71dbdb0b296d1e0ba2d3cfa87a8bcb')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
prepare() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index b81ebccb536b..7dad5dff5c5f 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt5-module';
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="QPA plugin for running an application via a browser using streamed WebGL commands (mingw-w64)"