summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:53:38 +0200
committerMartchus2020-09-13 13:53:38 +0200
commitb51020b66cdd88c360271ffe77d20f74c5417262 (patch)
tree912bddb5397f8166d4ba1420eced16b16451f54b
parentcf4ff13b4e300f9b4e7ec2195f7cc707c3d9bd95 (diff)
downloadaur-b51020b66cdd88c360271ffe77d20f74c5417262.tar.gz
Update to 5.15.1
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Hardcode-linker-flags-for-platform-plugin.patch4
-rw-r--r--PKGBUILD18
-rw-r--r--PKGBUILD.sh.ep4
-rw-r--r--qtwebglplugin-sha256.txt2
5 files changed, 14 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9977cb9731a..22b1b106d542 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-webglplugin
pkgdesc = QPA plugin for running an application via a browser using streamed WebGL commands (mingw-w64)
- pkgver = 5.15.0
+ pkgver = 5.15.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,17 +11,15 @@ pkgbase = mingw-w64-qt5-webglplugin
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
- makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-declarative
depends = mingw-w64-qt5-websockets
- optdepends = mingw-w64-qt5-base-static: use of static libraries
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.0/submodules/qtwebglplugin-everywhere-src-5.15.0.tar.xz
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.1/submodules/qtwebglplugin-everywhere-src-5.15.1.tar.xz
source = 0001-Hardcode-linker-flags-for-platform-plugin.patch
- sha256sums = f7b81f25ddf7b3a0046daa7224bc1e18c8b754b00b1a33775f30f827a5cdca15
- sha256sums = 4a6e18d8269a3716e7d31b02e520925022fab51956a033fd6ad5abda5df4a351
+ sha256sums = 63c76f384252090694a8a2a8a18441d4fc4502d688cc4ac798a0d27b2221733c
+ sha256sums = c6af011c8517f0874b5b5593b1248061e863add2009ed66a31c84783acf1a360
pkgname = mingw-w64-qt5-webglplugin
diff --git a/0001-Hardcode-linker-flags-for-platform-plugin.patch b/0001-Hardcode-linker-flags-for-platform-plugin.patch
index 101e3a4f37b5..4b55b647a685 100644
--- a/0001-Hardcode-linker-flags-for-platform-plugin.patch
+++ b/0001-Hardcode-linker-flags-for-platform-plugin.patch
@@ -1,4 +1,4 @@
-From 4da196f53569e9d95c272a96f54d3f6a641bd069 Mon Sep 17 00:00:00 2001
+From 69d6b19fd448404c752ce6aa0b60991e22e77e7b Mon Sep 17 00:00:00 2001
From: Marius Kittler <mkittler@suse.de>
Date: Wed, 12 Dec 2018 18:16:54 +0100
Subject: [PATCH] Hardcode linker flags for platform plugin
@@ -42,5 +42,5 @@ index 7f7227c..45f8f66 100644
qtHaveModule(quick) {
QT += quick
--
-2.26.2
+2.28.0
diff --git a/PKGBUILD b/PKGBUILD
index 814ea7d96627..59e9af782199 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,15 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
# Do not edit it manually! See README.md in the repository's root directory
# for more information.
# All patches are managed at https://github.com/Martchus/qtwebglplugin
-# Includes dynamic and static versions; if only one version is requried, just
-# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
-
_qt_module=qtwebglplugin
pkgname=mingw-w64-qt5-webglplugin
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
arch=('any')
pkgdesc="QPA plugin for running an application via a browser using streamed WebGL commands (mingw-w64)"
@@ -27,17 +24,12 @@ url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Hardcode-linker-flags-for-platform-plugin.patch')
-sha256sums=('f7b81f25ddf7b3a0046daa7224bc1e18c8b754b00b1a33775f30f827a5cdca15'
- '4a6e18d8269a3716e7d31b02e520925022fab51956a033fd6ad5abda5df4a351')
+sha256sums=('63c76f384252090694a8a2a8a18441d4fc4502d688cc4ac798a0d27b2221733c'
+ 'c6af011c8517f0874b5b5593b1248061e863add2009ed66a31c84783acf1a360')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-[[ $NO_STATIC_LIBS ]] || \
- makedepends+=('mingw-w64-qt5-base-static') \
- optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
-[[ $NO_SHARED_LIBS ]] || \
- _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
prepare() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 8f5b419de887..9b02cc753e73 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,10 +1,10 @@
% layout 'mingw-w64-qt5-module';
\
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
arch=('any')
pkgdesc="QPA plugin for running an application via a browser using streamed WebGL commands (mingw-w64)"
-depends=('mingw-w64-qt5-declarative' 'mingw-w64-qt5-websockets')
+depends=(<%== qt5deps qw(declarative websockets) %>)
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
\
diff --git a/qtwebglplugin-sha256.txt b/qtwebglplugin-sha256.txt
index 8b65abd5358c..0e3d4755d0d5 100644
--- a/qtwebglplugin-sha256.txt
+++ b/qtwebglplugin-sha256.txt
@@ -1 +1 @@
-f7b81f25ddf7b3a0046daa7224bc1e18c8b754b00b1a33775f30f827a5cdca15
+63c76f384252090694a8a2a8a18441d4fc4502d688cc4ac798a0d27b2221733c