summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2016-04-18 00:42:19 +0200
committerMartchus2016-04-18 00:42:19 +0200
commit32079e603cdc3c4e85a74cdc2ac53057a636e3f5 (patch)
treeeb129c66c5c5385f56ad93c6a7c7537ee96de29a
parent25bee8bd0badd12dbbaca1d0bc24632f7a9a69df (diff)
downloadaur-32079e603cdc3c4e85a74cdc2ac53057a636e3f5.tar.gz
ICU rebuild, added qt5-webkit-pthread.patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
-rw-r--r--qt5-webkit-pthread.patch32
3 files changed, 53 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ee2e562b5d4..e87043884c27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 9 00:51:59 UTC 2016
+# Sun Apr 17 22:41:25 UTC 2016
pkgbase = mingw-w64-qt5-webkit
pkgdesc = Classes for a WebKit2 based implementation and a new QML API (mingw-w64)
pkgver = 5.6.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io/
arch = any
groups = mingw-w64-qt
@@ -40,6 +40,7 @@ pkgbase = mingw-w64-qt5-webkit
source = qtwebkit-opensource-src-5.0.1-debuginfo.patch
source = revert-qt4-unicode-removal.patch
source = webkit-commit-151422.patch
+ source = qt5-webkit-pthread.patch
md5sums = b68565d18db63ee4db998bb8e37608a5
md5sums = ce7d257e2b5b94fe3affd98f52d99d09
md5sums = ac574de962545d6a9e975b4db63c3e09
@@ -50,6 +51,7 @@ pkgbase = mingw-w64-qt5-webkit
md5sums = 6aba6468efafb64943887079e258b799
md5sums = 4e374836f26853b4d82be0e87aa584a5
md5sums = c36fe581e0f3b61cef19415782b257ca
+ md5sums = f65286024f65ca87837171272fc8975d
pkgname = mingw-w64-qt5-webkit
diff --git a/PKGBUILD b/PKGBUILD
index 245ce504c5c5..61188268f279 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,11 +5,13 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# See the comment below for additional dependencies/functionality.
+
_qt_module=qtwebkit
pkgname=mingw-w64-qt5-webkit
pkgver=5.6.0
-pkgrel=1
-arch=(any)
+pkgrel=2
+arch=('any')
pkgdesc="Classes for a WebKit2 based implementation and a new QML API (mingw-w64)"
depends=('mingw-w64-qt5-declarative'
'mingw-w64-qt5-sensors'
@@ -24,6 +26,10 @@ depends=('mingw-w64-qt5-declarative'
'mingw-w64-icu'
'mingw-w64-sqlite'
'mingw-w64-libwebp')
+# these dependencies will enable further functionality
+#depends+=('mingw-w64-webchannel')
+#depends+=('mingw-w64-gst-plugins-base')
+#optdepends+=('mingw-w64-gst-plugins-good: Webm codec support')
makedepends=('mingw-w64-gcc' 'python' 'gperf' 'ruby' 'mingw-w64-pkg-config')
options=('!strip' '!buildflags' 'staticlibs')
license=("custom, FDL, GPL3, LGPL")
@@ -39,7 +45,8 @@ source=("https://download.qt.io/community_releases/${pkgver:0:3}/${pkgver}/${_pk
qtwebkit-dont-use-bundled-angle-libraries.patch
qtwebkit-opensource-src-5.0.1-debuginfo.patch
revert-qt4-unicode-removal.patch
- webkit-commit-151422.patch)
+ webkit-commit-151422.patch
+ qt5-webkit-pthread.patch)
md5sums=('b68565d18db63ee4db998bb8e37608a5'
'ce7d257e2b5b94fe3affd98f52d99d09'
'ac574de962545d6a9e975b4db63c3e09'
@@ -49,14 +56,19 @@ md5sums=('b68565d18db63ee4db998bb8e37608a5'
'f452210683386f9c28f04d7dea0ecfc7'
'6aba6468efafb64943887079e258b799'
'4e374836f26853b4d82be0e87aa584a5'
- 'c36fe581e0f3b61cef19415782b257ca')
+ 'c36fe581e0f3b61cef19415782b257ca'
+ 'f65286024f65ca87837171272fc8975d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/${_pkgfqn}"
- # note: all patches are from http://pkgs.fedoraproject.org/git/rpms/mingw-qt5-qtwebkit.git
+ # see description inside the patch file
+ patch -p1 -i ../qt5-webkit-pthread.patch
+
+ # note: most patches are originally from http://pkgs.fedoraproject.org/git/rpms/mingw-qt5-qtwebkit.git
+ # however, I needed to update most of them in order to update to 5.6.0 and to use the latest ANGLE
# The ICU libraries used for cross-compilation are named exactly the same as their native Linux counterpart
patch -p1 -b -i ../qt5-qtwebkit-use-correct-icu-libs.patch
diff --git a/qt5-webkit-pthread.patch b/qt5-webkit-pthread.patch
new file mode 100644
index 000000000000..53d5439243bf
--- /dev/null
+++ b/qt5-webkit-pthread.patch
@@ -0,0 +1,32 @@
+From 5f359baacdf92fabcece83f0a2b30f74c7c02a3c Mon Sep 17 00:00:00 2001
+From: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
+Date: Mon, 22 Feb 2016 10:57:32 +0100
+Subject: [PATCH] Fix linking with libpthread
+
+WebKit use libpthread directly but is depending on other qt modules
+causing it to be linked against, which might break unless -lpthread
+is last. Instead just add it explicitly after the static libraries.
+
+Change-Id: I2b95cff2c96373f8dce6f95052c4fccbe1982b33
+Reviewed-by: Simon Hausmann <simon.hausmann@theqtcompany.com>
+(cherry picked from commit 5dd4bb67cfce812fd7686e43616e2069f354a7df)
+Reviewed-by: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
+---
+ Tools/qmake/mkspecs/features/default_post.prf | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Tools/qmake/mkspecs/features/default_post.prf b/Tools/qmake/mkspecs/features/default_post.prf
+index 67276b7..39bb3f7 100644
+--- a/Tools/qmake/mkspecs/features/default_post.prf
++++ b/Tools/qmake/mkspecs/features/default_post.prf
+@@ -201,6 +201,7 @@ needToLink() {
+ linkAgainstLibrary($$library, $$eval(WEBKIT.$${library_identifier}.root_source_dir))
+ LIBS += $$eval(WEBKIT.$${library_identifier}.dependent_libs)
+ }
++ posix:!darwin: LIBS += -lpthread
+ }
+
+ creating_module {
+--
+2.7.1
+