summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-29 19:09:53 +0100
committerMartchus2020-01-29 19:09:53 +0100
commit0f2f5d297f8879e8f949f04bdb80ee3c637bd69d (patch)
treeee5ef88a8152c854bd35ec5e81f634599269a59d
parent1a05cd8fb09e6702276c4cf344283dbc28be7cc5 (diff)
downloadaur-0f2f5d297f8879e8f949f04bdb80ee3c637bd69d.tar.gz
Update to 5.14.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--PKGBUILD.sh.ep13
-rw-r--r--qtwebsockets-sha256.txt1
4 files changed, 28 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dbbdce86eee..0476877acbec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-websockets
pkgdesc = Provides WebSocket communication compliant with RFC 6455 (mingw-w64)
- pkgver = 5.14.0
+ pkgver = 5.14.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -17,8 +17,8 @@ pkgbase = mingw-w64-qt5-websockets
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtwebsockets-everywhere-src-5.14.0.tar.xz
- sha256sums = 50b881e83225b21e6657361e1af9b0154117d5efc03ba8c87aecacee3e42b0ad
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtwebsockets-everywhere-src-5.14.1.tar.xz
+ sha256sums = 742fb3d39043728ca4fc1533e9a1e3b701bc5bf4e27cba316077e9f0df0b3fef
pkgname = mingw-w64-qt5-websockets
diff --git a/PKGBUILD b/PKGBUILD
index 1bf68e5aea56..b05ad6ea220c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,35 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
+# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# Do not edit it manually! See README.md in the repository's root directory
+# for more information.
+
# Includes dynamic and static versions; if only one version is requried, just
# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
_qt_module=qtwebsockets
-pkgname="mingw-w64-qt5-websockets"
-pkgver=5.14.0
+pkgname=mingw-w64-qt5-websockets
+pkgver=5.14.1
pkgrel=1
arch=('any')
pkgdesc="Provides WebSocket communication compliant with RFC 6455 (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
-license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('50b881e83225b21e6657361e1af9b0154117d5efc03ba8c87aecacee3e42b0ad')
+sha256sums=('742fb3d39043728ca4fc1533e9a1e3b701bc5bf4e27cba316077e9f0df0b3fef')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
[[ $NO_STATIC_LIBS ]] || \
makedepends+=('mingw-w64-qt5-base-static') \
optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=static')
+ _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
@@ -38,7 +43,7 @@ build() {
for _config in "${_configurations[@]}"; do
msg2 "Building ${_config##*=} version for ${_arch}"
mkdir -p build-${_arch}-${_config##*=} && pushd build-${_arch}-${_config##*=}
- ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config}
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro ${_config} ${_additional_qmake_args}
make
popd
done
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..ce4d3d65ef88
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,13 @@
+% layout 'mingw-w64-qt5-module';
+\
+% content_for additional_contributors => begin
+# Contributor: ant32 <antreimer@gmail.com>
+% end
+\
+pkgver=5.14.1
+pkgrel=1
+arch=('any')
+pkgdesc="Provides WebSocket communication compliant with RFC 6455 (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
+license=('GPL3' 'LGPL' 'FDL' 'custom')
diff --git a/qtwebsockets-sha256.txt b/qtwebsockets-sha256.txt
new file mode 100644
index 000000000000..24d7ee0a8a3e
--- /dev/null
+++ b/qtwebsockets-sha256.txt
@@ -0,0 +1 @@
+742fb3d39043728ca4fc1533e9a1e3b701bc5bf4e27cba316077e9f0df0b3fef