summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2018-02-19 20:15:16 +0100
committerMartchus2018-02-19 20:15:16 +0100
commit3ec05d5eb4e36d0138b57bbf7cbb4ff027d2b471 (patch)
tree8525897e91160d0dece9bc78451e208e03819c89
parent07e4cd68fcd76a3a9e44affb35433963dc87fd49 (diff)
downloadaur-3ec05d5eb4e36d0138b57bbf7cbb4ff027d2b471.tar.gz
Update to 5.10.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 680d80556887..6994b3e6fcf6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Dec 14 00:06:28 UTC 2017
+# Mon Feb 19 19:15:16 UTC 2018
pkgbase = mingw-w64-qt5-websockets
pkgdesc = Provides WebSocket communication compliant with RFC 6455 (mingw-w64)
- pkgver = 5.10.0
+ pkgver = 5.10.1
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -19,8 +19,8 @@ pkgbase = mingw-w64-qt5-websockets
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.10/5.10.0/submodules/qtwebsockets-everywhere-src-5.10.0.tar.xz
- sha256sums = 17ab0fa22007e5485bf98cb5fef5387628274548d5e96923f45d097838f49403
+ source = https://download.qt.io/official_releases/qt/5.10/5.10.1/submodules/qtwebsockets-everywhere-src-5.10.1.tar.xz
+ sha256sums = 6ecf790955ffe42dce731e10557f4ba625e359e867953d73f7fb453c0bad53ea
pkgname = mingw-w64-qt5-websockets
diff --git a/PKGBUILD b/PKGBUILD
index 823a66d5ae30..6406fa357f17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtwebsockets
pkgname="mingw-w64-qt5-websockets"
-pkgver=5.10.0
+pkgver=5.10.1
pkgrel=1
arch=('any')
pkgdesc="Provides WebSocket communication compliant with RFC 6455 (mingw-w64)"
@@ -21,7 +21,7 @@ license=('GPL3' 'LGPL' 'FDL' 'custom')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('17ab0fa22007e5485bf98cb5fef5387628274548d5e96923f45d097838f49403')
+sha256sums=('6ecf790955ffe42dce731e10557f4ba625e359e867953d73f7fb453c0bad53ea')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -53,6 +53,19 @@ package() {
pushd build-${_arch}-${_config##*=}
make INSTALL_ROOT="$pkgdir" install
+
+ # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
@@ -64,5 +77,8 @@ package() {
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
popd
done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
}