summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2017-02-09 21:00:56 +0100
committerMartchus2017-02-09 21:00:56 +0100
commit5ae00a398a76b77353b65ed05757e415a4794946 (patch)
treeecd5a9bb7a801182978b46ab886eb652d83bc883
parent30bb59d3ef09ce2891903698d8932b9ba8cd0193 (diff)
downloadaur-5ae00a398a76b77353b65ed05757e415a4794946.tar.gz
Update to 5.8.0
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch25
-rw-r--r--PKGBUILD22
3 files changed, 50 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f58fcf77fe1..92df621b3f06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
# Generated by mksrcinfo v8
-# Sat Dec 24 12:06:49 UTC 2016
+# Thu Feb 9 20:00:56 UTC 2017
pkgbase = mingw-w64-qt5-winextras
pkgdesc = Classes and functions that enable you to use Windows-specific functions (mingw-w64)
- pkgver = 5.7.1
+ pkgver = 5.8.0
pkgrel = 1
url = https://www.qt.io/
arch = any
+ groups = mingw-w64-qt5
license = GPL3
license = LGPL3
license = LGPL2.1
license = FDL
license = custom
makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
makedepends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-base
depends = mingw-w64-qt5-declarative
@@ -19,8 +21,10 @@ pkgbase = mingw-w64-qt5-winextras
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.7/5.7.1/submodules/qtwinextras-opensource-src-5.7.1.tar.xz
- md5sums = 8c3f7718eea953bf501c1942a8549c18
+ source = https://download.qt.io/official_releases/qt/5.8/5.8.0/submodules/qtwinextras-opensource-src-5.8.0.tar.xz
+ source = 0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch
+ md5sums = fb54b164c07b5dd0994315fc62978a2e
+ md5sums = 9a57a574a20a134d2942351f6a8063c1
pkgname = mingw-w64-qt5-winextras
diff --git a/0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch b/0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch
new file mode 100644
index 000000000000..bec0c2df9b19
--- /dev/null
+++ b/0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch
@@ -0,0 +1,25 @@
+From f00d75eaf8c61607543563d50630bf8084bf936d Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Thu, 9 Feb 2017 01:07:46 +0100
+Subject: [PATCH] Fix condition for _WIN32_IE/SHCreateItemFromParsingName
+
+---
+ src/winextras/qwinjumplist.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/winextras/qwinjumplist.cpp b/src/winextras/qwinjumplist.cpp
+index 9274cc5..962481e 100644
+--- a/src/winextras/qwinjumplist.cpp
++++ b/src/winextras/qwinjumplist.cpp
+@@ -41,7 +41,7 @@
+ #include <QtCore/QtGlobal>
+
+ #ifdef Q_CC_MINGW // MinGW: Enable SHCreateItemFromParsingName()
+-# if defined(_WIN32_IE) && _WIN32_IE << 0x0700 // _WIN32_IE_IE70
++# if defined(_WIN32_IE) && _WIN32_IE < 0x0700 // _WIN32_IE_IE70
+ # undef _WIN32_IE
+ # endif
+ # ifndef _WIN32_IE
+--
+2.11.1
+
diff --git a/PKGBUILD b/PKGBUILD
index eaf0072e7ca6..5ea2d3165b3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,21 @@
_qt_module=qtwinextras
pkgname="mingw-w64-qt5-winextras"
-pkgver=5.7.1
+pkgver=5.8.0
pkgrel=1
arch=('any')
pkgdesc="Classes and functions that enable you to use Windows-specific functions (mingw-w64)"
depends=('mingw-w64-qt5-base' 'mingw-w64-qt5-declarative')
-makedepends=('mingw-w64-gcc')
+makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
options=('!strip' '!buildflags' 'staticlibs')
+groups=('mingw-w64-qt5')
license=('GPL3' 'LGPL3' 'LGPL2.1' 'FDL' 'custom')
-url="https://www.qt.io/"
+url='https://www.qt.io/'
_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-md5sums=('8c3f7718eea953bf501c1942a8549c18')
+source=("https://download.qt.io/official_releases/qt/${pkgver:0:3}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Fix-condition-for-_WIN32_IE-SHCreateItemFromParsingN.patch')
+md5sums=('fb54b164c07b5dd0994315fc62978a2e'
+ '9a57a574a20a134d2942351f6a8063c1')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -30,6 +33,15 @@ _architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_SHARED_LIBS ]] || \
_configurations+=('CONFIG+=shared')
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ # Apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"