summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:19 +0100
committerMartchus2022-03-08 23:35:19 +0100
commit3d57cf234fafa9b5f111249813b4494df9c85d33 (patch)
tree1859a9dd1426d17d4e022a5f00d1efd06c2a920a
parentf5b1da30ce29de037ada9a5fcfbc2604937bafc2 (diff)
downloadaur-3d57cf234fafa9b5f111249813b4494df9c85d33.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd9036eeefe3..339faa2a7cde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-winextras-static
pkgdesc = Classes and functions that enable you to use Windows-specific functions (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -12,14 +12,14 @@ pkgbase = mingw-w64-qt5-winextras-static
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base-static
depends = mingw-w64-qt5-declarative-static
depends = mingw-w64-qt5-winextras
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtwinextras-everywhere-src-5.15.2.tar.xz
- sha256sums = 65b8272005dec00791ab7d81ab266d1e3313a3bbd8e54e546d984cf4c4ab550e
+ source = git+https://invent.kde.org/qt/qt/qtwinextras#commit=051202df9c553d7c0a384f07bd67fde98f3b02c4
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-winextras-static
-
diff --git a/PKGBUILD b/PKGBUILD
index d165da44484b..448fda8a14fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,25 +10,38 @@
_qt_module=qtwinextras
pkgname=mingw-w64-qt5-winextras-static
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Classes and functions that enable you to use Windows-specific functions (mingw-w64)"
depends=('mingw-w64-qt5-base-static' 'mingw-w64-qt5-declarative-static')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'LGPL2.1' 'FDL' 'custom')
+_commit=051202df9c553d7c0a384f07bd67fde98f3b02c4
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('65b8272005dec00791ab7d81ab266d1e3313a3bbd8e54e546d984cf4c4ab550e')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
depends+=(${pkgname%-static}) # the static version relies on the shared version for build tools and headers
_configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"