summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip A Reimer2015-08-26 21:19:41 -0600
committerPhilip A Reimer2015-08-26 21:19:41 -0600
commit230fd70dd28eedf58a6f41fb423e71d7aebd306e (patch)
tree2a13cdb2e04e69d9d55fe3c389b234f0782fa9b9
downloadaur-230fd70dd28eedf58a6f41fb423e71d7aebd306e.tar.gz
Update to 5.5.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD54
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f38f89432ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mingw-w64-qt5-xmlpatterns
+ pkgdesc = Qt5 for Windows -- QtXmlPatterns module (mingw-w64)
+ pkgver = 5.5.0
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = any
+ license = GPL3
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ depends = mingw-w64-qt5-base
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ source = http://download.qt-project.org/official_releases/qt/5.5/5.5.0/submodules/qtxmlpatterns-opensource-src-5.5.0.tar.xz
+ md5sums = 138ab73b2376fcfca92a4bb6ab47e4a4
+
+pkgname = mingw-w64-qt5-xmlpatterns
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5e428022047
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: ant32 <antreimer@gmail.com>
+
+_qt_module=qtxmlpatterns
+pkgname="mingw-w64-qt5-xmlpatterns"
+pkgver=5.5.0
+pkgrel=1
+arch=('any')
+pkgdesc="Qt5 for Windows -- QtXmlPatterns module (mingw-w64)"
+depends=('mingw-w64-qt5-base')
+makedepends=('mingw-w64-gcc')
+options=('!strip' '!buildflags' 'staticlibs')
+license=('GPL3' 'LGPL')
+url="http://qt-project.org/"
+_pkgfqn="${_qt_module}-opensource-src-${pkgver}"
+source=("http://download.qt-project.org/official_releases/qt/5.5/${pkgver}/submodules/${_pkgfqn}.tar.xz")
+md5sums=('138ab73b2376fcfca92a4bb6ab47e4a4')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build()
+{
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+
+ ${_arch}-qmake-qt5 ../${_qt_module}.pro
+ make
+
+ popd
+ done
+}
+
+package() {
+ cd "${srcdir}/${_pkgfqn}"
+
+ for _arch in ${_architectures}; do
+ pushd build-${_arch}
+
+ make INSTALL_ROOT="${pkgdir}" install
+
+ # The .dll's are installed in both bindir and libdir
+ # One copy of the .dll's is sufficient
+ rm -f "${pkgdir}/usr/${_arch}/lib/"*.dll
+
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/bin/"*.dll
+ ${_arch}-strip --strip-unneeded "${pkgdir}/usr/${_arch}/lib/"*.dll.a
+
+ popd
+ done
+
+ # .prl files aren't interesting for us
+ find "${pkgdir}" -name "*.prl" -delete
+}