summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-03-08 23:35:03 +0100
committerMartchus2022-03-08 23:35:03 +0100
commit56a3edf8c3af11ae4309f336b0a22bda47405273 (patch)
tree60d1b04a497fc34f4c5855396ad0ca8c9ff37b08
parent54669d1a317cc56f1094b8804d6395b03f51691f (diff)
downloadaur-56a3edf8c3af11ae4309f336b0a22bda47405273.tar.gz
Rebase against 5.15.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
-rw-r--r--PKGBUILD.sh.ep2
3 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f94c0f9b9729..f26e2b0de44a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt5-xmlpatterns
pkgdesc = Support for XPath, XQuery, XSLT and XML schema validation (mingw-w64)
- pkgver = 5.15.2
+ pkgver = 5.15.3+kde+r0
pkgrel = 1
url = https://www.qt.io/
arch = any
@@ -11,12 +11,12 @@ pkgbase = mingw-w64-qt5-xmlpatterns
license = custom
makedepends = mingw-w64-gcc
makedepends = mingw-w64-pkg-config
+ makedepends = git
depends = mingw-w64-qt5-base
options = !strip
options = !buildflags
options = staticlibs
- source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtxmlpatterns-everywhere-src-5.15.2.tar.xz
- sha256sums = 76ea2162a7c349188d7e7e4f6c77b78e8a205494c90fee3cea3487a1ae2cf2fa
+ source = git+https://invent.kde.org/qt/qt/qtxmlpatterns#commit=af4958af9d628d6124e64abd9743abce42f15a6f
+ sha256sums = SKIP
pkgname = mingw-w64-qt5-xmlpatterns
-
diff --git a/PKGBUILD b/PKGBUILD
index b7db1a4d4fa1..63b3f0c31b69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,24 +10,37 @@
_qt_module=qtxmlpatterns
pkgname=mingw-w64-qt5-xmlpatterns
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Support for XPath, XQuery, XSLT and XML schema validation (mingw-w64)"
depends=('mingw-w64-qt5-base')
makedepends=('mingw-w64-gcc' 'mingw-w64-pkg-config')
license=('GPL3' 'LGPL3' 'FDL' 'custom')
+_commit=af4958af9d628d6124e64abd9743abce42f15a6f
+_basever=$pkgver
+pkgver+=+kde+r0
+makedepends+=('git')
options=('!strip' '!buildflags' 'staticlibs')
groups=('mingw-w64-qt5')
url='https://www.qt.io/'
-_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('76ea2162a7c349188d7e7e4f6c77b78e8a205494c90fee3cea3487a1ae2cf2fa')
+_pkgfqn=${_qt_module}
+source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
+sha256sums=('SKIP')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+pkgver() {
+ cd $_pkgfqn
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgfqn}"
+}
+
build() {
cd "${srcdir}/${_pkgfqn}"
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 3aca17f603d7..72d3ffd61db8 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -4,7 +4,7 @@
# Contributor: ant32 <antreimer@gmail.com>
% end
\
-pkgver=5.15.2
+pkgver=5.15.3
pkgrel=1
arch=('any')
pkgdesc="Support for XPath, XQuery, XSLT and XML schema validation (mingw-w64)"