summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-11-07 13:23:35 +0100
committerMartchus2023-11-07 13:23:35 +0100
commitd2c69f2bc901dec30f2481a30d9974653bed9c11 (patch)
treefcac0ff8caed4be12b38e3f6083d4e1383072e40
parent82b2fdb2de5ca766e25480cbdbd58338a1b3e51d (diff)
downloadaur-mingw-w64-qt6-3d.tar.gz
Update to 6.6.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
-rw-r--r--PKGBUILD.sh.ep7
-rw-r--r--qt3d-sha256.txt2
4 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bcac921de30..ccfe196d4f38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-3d
pkgdesc = C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)
- pkgver = 6.0.0alpha
+ pkgver = 6.6.0
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -12,19 +12,16 @@ pkgbase = mingw-w64-qt6-3d
makedepends = mingw-w64-cmake
makedepends = mingw-w64-vulkan-headers
makedepends = mingw-w64-vulkan-icd-loader
- makedepends = mingw-w64-assimp
makedepends = qt6-shadertools
makedepends = qt6-declarative
makedepends = ninja
depends = mingw-w64-qt6-declarative
- optdepends = mingw-w64-assimp: Import from assimp
optdepends = mingw-w64-qt6-shadertools: RHI renderer
options = !strip
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/development_releases/qt/6.0/6.0.0-alpha/submodules/qt3d-everywhere-src-6.0.0-alpha.tar.xz
- sha256sums = 3362d01c7542af0e902908d2d339374feda1a037552ea625b900278982375c27
+ source = https://download.qt.io/official_releases/qt/6.6/6.6.0/submodules/qt3d-everywhere-src-6.6.0.tar.xz
+ sha256sums = 0da87a46217f4d72f6d0de9768605d5325ef3d093f73a5e0d73dd88e99c1fc2a
pkgname = mingw-w64-qt6-3d
-
diff --git a/PKGBUILD b/PKGBUILD
index f6f6c7eac9ca..08b76c0b5900 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-3d
-_qtver=6.0.0-alpha
+_qtver=6.6.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -12,15 +12,14 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)'
depends=('mingw-w64-qt6-declarative')
-makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'mingw-w64-assimp'
+makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader'
'qt6-shadertools' 'qt6-declarative' 'ninja')
-optdepends=('mingw-w64-assimp: Import from assimp'
- 'mingw-w64-qt6-shadertools: RHI renderer')
+optdepends=('mingw-w64-qt6-shadertools: RHI renderer')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qt3d-everywhere-src-${_qtver}"
-source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('3362d01c7542af0e902908d2d339374feda1a037552ea625b900278982375c27')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('0da87a46217f4d72f6d0de9768605d5325ef3d093f73a5e0d73dd88e99c1fc2a')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -28,10 +27,7 @@ build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
$_arch-cmake -G Ninja -B build-$_arch -S $_pkgfqn \
- -DQT_HOST_PATH=/usr \
- -DFEATURE_pkg_config=ON \
- -DVulkan_LIBRARY="/usr/$_arch/lib/libvulkan.dll.a" \
- -DVulkan_INCLUDE_DIR="/usr/$_arch/include"
+ -DFEATURE_pkg_config=ON
cmake --build build-$_arch
done
}
@@ -53,8 +49,10 @@ package() {
find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/share/doc"
done
install -d "$pkgdir"/usr/share/licenses
- ln -s /usr/share/licenses/mingw-w64-qt6-base "$pkgdir"/usr/share/licenses/mingw-w64-qt6-3d
+ ln -s /usr/share/licenses/mingw-w64-qt6-base "$pkgdir"/usr/share/licenses/$pkgname
+
}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index fc35d96c697d..e7fe74b2f7c3 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt6-module', has_binaries => 1;
\
-_qtver=6.0.0-alpha
+_qtver=6.6.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -8,7 +8,6 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)'
depends=(<%== qt6deps qw(declarative) %>)
-makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'mingw-w64-assimp'
+makedepends=('mingw-w64-cmake<%== $static_suffix %>' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader'
'qt6-shadertools' 'qt6-declarative' 'ninja')
-optdepends=('mingw-w64-assimp: Import from assimp'
- <%== qt6optdeps shadertools => 'RHI renderer' %>)
+optdepends=(<%== qt6optdeps shadertools => 'RHI renderer' %>)
diff --git a/qt3d-sha256.txt b/qt3d-sha256.txt
index 3184e09d9ae3..d9e8c46a5049 100644
--- a/qt3d-sha256.txt
+++ b/qt3d-sha256.txt
@@ -1 +1 @@
-3362d01c7542af0e902908d2d339374feda1a037552ea625b900278982375c27
+0da87a46217f4d72f6d0de9768605d5325ef3d093f73a5e0d73dd88e99c1fc2a