summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-10-13 11:10:23 +0200
committerMartchus2020-10-13 11:10:23 +0200
commit82b2fdb2de5ca766e25480cbdbd58338a1b3e51d (patch)
treeca10c749d2996c2a16f70d09bb26b6a6f71edb60
downloadaur-82b2fdb2de5ca766e25480cbdbd58338a1b3e51d.tar.gz
Initial import (alpha)
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD60
-rw-r--r--PKGBUILD.sh.ep14
-rw-r--r--qt3d-sha256.txt1
4 files changed, 105 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bcac921de30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = mingw-w64-qt6-3d
+ pkgdesc = C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)
+ pkgver = 6.0.0alpha
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = mingw-w64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-vulkan-headers
+ makedepends = mingw-w64-vulkan-icd-loader
+ makedepends = mingw-w64-assimp
+ makedepends = qt6-shadertools
+ makedepends = qt6-declarative
+ makedepends = ninja
+ depends = mingw-w64-qt6-declarative
+ optdepends = mingw-w64-assimp: Import from assimp
+ optdepends = mingw-w64-qt6-shadertools: RHI renderer
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/development_releases/qt/6.0/6.0.0-alpha/submodules/qt3d-everywhere-src-6.0.0-alpha.tar.xz
+ sha256sums = 3362d01c7542af0e902908d2d339374feda1a037552ea625b900278982375c27
+
+pkgname = mingw-w64-qt6-3d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6f6c7eac9ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=mingw-w64-qt6-3d
+_qtver=6.0.0-alpha
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)'
+depends=('mingw-w64-qt6-declarative')
+makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'mingw-w64-assimp'
+ 'qt6-shadertools' 'qt6-declarative' 'ninja')
+optdepends=('mingw-w64-assimp: Import from assimp'
+ 'mingw-w64-qt6-shadertools: RHI renderer')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(mingw-w64-qt6)
+_pkgfqn="qt3d-everywhere-src-${_qtver}"
+source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('3362d01c7542af0e902908d2d339374feda1a037552ea625b900278982375c27')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+build() {
+ for _arch in ${_architectures}; do
+ export PKG_CONFIG=/usr/bin/$_arch-pkg-config
+ $_arch-cmake -G Ninja -B build-$_arch -S $_pkgfqn \
+ -DQT_HOST_PATH=/usr \
+ -DFEATURE_pkg_config=ON \
+ -DVulkan_LIBRARY="/usr/$_arch/lib/libvulkan.dll.a" \
+ -DVulkan_INCLUDE_DIR="/usr/$_arch/include"
+ cmake --build build-$_arch
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" cmake --install build-$_arch
+
+ # Add symlinks of DLLs in usual bin directory
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/$_arch/bin"
+ for dll in "$pkgdir"/usr/$_arch/lib/qt6/bin/*.dll; do
+ ln -rs "$dll" "$pkgdir/usr/$_arch/bin/${dll##*/}"
+ done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/$_arch/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ done
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/mingw-w64-qt6-base "$pkgdir"/usr/share/licenses/mingw-w64-qt6-3d
+}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..fc35d96c697d
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,14 @@
+% layout 'mingw-w64-qt6-module', has_binaries => 1;
+\
+_qtver=6.0.0-alpha
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)'
+depends=(<%== qt6deps qw(declarative) %>)
+makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'mingw-w64-assimp'
+ 'qt6-shadertools' 'qt6-declarative' 'ninja')
+optdepends=('mingw-w64-assimp: Import from assimp'
+ <%== qt6optdeps shadertools => 'RHI renderer' %>)
diff --git a/qt3d-sha256.txt b/qt3d-sha256.txt
new file mode 100644
index 000000000000..3184e09d9ae3
--- /dev/null
+++ b/qt3d-sha256.txt
@@ -0,0 +1 @@
+3362d01c7542af0e902908d2d339374feda1a037552ea625b900278982375c27