summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-10-13 11:10:03 +0200
committerMartchus2020-10-13 11:10:03 +0200
commitceb3787ff5ff1feef200daf2a87f35fc1d9c5cc9 (patch)
tree026e4ca00b48ec7eb9713c236711364831f5cb93
downloadaur-ceb3787ff5ff1feef200daf2a87f35fc1d9c5cc9.tar.gz
Initial import (alpha)
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD57
-rw-r--r--PKGBUILD.sh.ep11
-rw-r--r--qt5compat-sha256.txt1
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7b46558ae5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mingw-w64-qt6-5compat
+ pkgdesc = Module that contains unsupported Qt 5 APIs (mingw-w64)
+ pkgver = 6.0.0alpha
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = mingw-w64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-cmake
+ makedepends = qt6-base
+ makedepends = ninja
+ depends = mingw-w64-qt6-base
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/development_releases/qt/6.0/6.0.0-alpha/submodules/qt5compat-everywhere-src-6.0.0-alpha.tar.xz
+ sha256sums = e0d2fbfeaf40e2e00b5b124f50b5887ef09f471030536869e3e31c38b8f9e00a
+
+pkgname = mingw-w64-qt6-5compat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eca56c7df4e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=mingw-w64-qt6-5compat
+_qtver=6.0.0-alpha
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Module that contains unsupported Qt 5 APIs (mingw-w64)'
+depends=('mingw-w64-qt6-base')
+makedepends=('mingw-w64-cmake' 'qt6-base' 'ninja')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(mingw-w64-qt6)
+_pkgfqn="qt5compat-everywhere-src-${_qtver}"
+source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('e0d2fbfeaf40e2e00b5b124f50b5887ef09f471030536869e3e31c38b8f9e00a')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+build() {
+ for _arch in ${_architectures}; do
+ export PKG_CONFIG=/usr/bin/$_arch-pkg-config
+ $_arch-cmake -G Ninja -B build-$_arch -S $_pkgfqn \
+ -DQT_HOST_PATH=/usr \
+ -DFEATURE_pkg_config=ON \
+ -DVulkan_LIBRARY="/usr/$_arch/lib/libvulkan.dll.a" \
+ -DVulkan_INCLUDE_DIR="/usr/$_arch/include"
+ cmake --build build-$_arch
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" cmake --install build-$_arch
+
+ # Add symlinks of DLLs in usual bin directory
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/$_arch/bin"
+ for dll in "$pkgdir"/usr/$_arch/lib/qt6/bin/*.dll; do
+ ln -rs "$dll" "$pkgdir/usr/$_arch/bin/${dll##*/}"
+ done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/$_arch/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ done
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/mingw-w64-qt6-base "$pkgdir"/usr/share/licenses/mingw-w64-qt6-5compat
+}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..35bc39f7bbdf
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,11 @@
+% layout 'mingw-w64-qt6-module';
+\
+_qtver=6.0.0-alpha
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Module that contains unsupported Qt 5 APIs (mingw-w64)'
+depends=(<%== qt6deps qw(base) %>)
+makedepends=('mingw-w64-cmake' 'qt6-base' 'ninja')
diff --git a/qt5compat-sha256.txt b/qt5compat-sha256.txt
new file mode 100644
index 000000000000..a51b23842f8c
--- /dev/null
+++ b/qt5compat-sha256.txt
@@ -0,0 +1 @@
+e0d2fbfeaf40e2e00b5b124f50b5887ef09f471030536869e3e31c38b8f9e00a