summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-03-17 16:26:39 +0100
committerMartchus2023-03-17 16:26:39 +0100
commit2c53567ee789150e0957bbc31ec1497ac3772567 (patch)
tree0c82de33f0ca9afb0eafe9f9a95153e9cbfa96a9
parent3672e761097ef81e7b070e041d98c37d82fa58bc (diff)
downloadaur-2c53567ee789150e0957bbc31ec1497ac3772567.tar.gz
Update to 6.4.3
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch8
-rw-r--r--0002-Build-tools-for-the-target-platform.patch4
-rw-r--r--0003-Fix-compile-error-about-missing-QStringView-overload.patch4
-rw-r--r--PKGBUILD10
-rw-r--r--qtactiveqt-sha256.txt2
6 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f413dc0f43ab..10a9bc283ad9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-activeqt-static
pkgdesc = ActiveX integration framework (mingw-w64)
- pkgver = 6.4.2
+ pkgver = 6.4.3
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -21,13 +21,13 @@ pkgbase = mingw-w64-qt6-activeqt-static
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.4/6.4.2/submodules/qtactiveqt-everywhere-src-6.4.2.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.4/6.4.3/submodules/qtactiveqt-everywhere-src-6.4.3.tar.xz
source = 0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
source = 0002-Build-tools-for-the-target-platform.patch
source = 0003-Fix-compile-error-about-missing-QStringView-overload.patch
- sha256sums = 123d0e6c4e31263a91a8e3acd72ace3f0c7109f1b15a2e18d594e450c47dc5cf
- sha256sums = 7cede1ca4b979d56f3047da9d9362c02ae3c44dc9b822743f6f26fea01070c4b
- sha256sums = 24bb6073a6c5e19232336659c8d013921d1c5a200d4ea4c8d76f83335a3ec7f0
- sha256sums = 1a53a66116bc05561152225e178d116d59a971c105373911804efeec0777cd4f
+ sha256sums = 093ee1d1514d32ed2657e32b6370523e57881d843fa87276e20cb7b2fb711c6d
+ sha256sums = 66e5a32fa63add8a712406ebaeb56e948b8ef5b4b24fc43e12d8f714fbac6a44
+ sha256sums = 3ff2118e5b88aa47d053965335c764a4aa803bdafe8340c78f757b2809027e15
+ sha256sums = da3fb21d0ecd45594ed0ad06f37bbbb1bd356fc125948cc47016b8361dbade0f
pkgname = mingw-w64-qt6-activeqt-static
diff --git a/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
index cff9f243bbc3..598270d2bb2b 100644
--- a/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
+++ b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
@@ -1,4 +1,4 @@
-From 6a4bb1150e82c388661552c77e39b373c3c34e99 Mon Sep 17 00:00:00 2001
+From 510fd537b1f6329d429b51e19d593214605d1b4a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:21:08 +0200
Subject: [PATCH 1/3] Handle win64 in dumpcpp and
@@ -11,10 +11,10 @@ See https://bugreports.qt.io/browse/QTBUG-46827
2 files changed, 12 insertions(+)
diff --git a/src/activeqt/container/qaxbase.cpp b/src/activeqt/container/qaxbase.cpp
-index d85ca1f..86ac48f 100644
+index c3b9b0a..ee19ffe 100644
--- a/src/activeqt/container/qaxbase.cpp
+++ b/src/activeqt/container/qaxbase.cpp
-@@ -2117,6 +2117,10 @@ void MetaObjectGenerator::readClassInfo()
+@@ -2118,6 +2118,10 @@ void MetaObjectGenerator::readClassInfo()
const QStringList versions = controls.childGroups();
for (const QString &version : versions) {
tlfile = controls.value(QLatin1Char('/') + version + QLatin1String("/0/win32/.")).toString();
@@ -52,5 +52,5 @@ index fc8bf8c..435ab1e 100644
}
--
-2.39.0
+2.39.2
diff --git a/0002-Build-tools-for-the-target-platform.patch b/0002-Build-tools-for-the-target-platform.patch
index 63a1483e7995..941961283682 100644
--- a/0002-Build-tools-for-the-target-platform.patch
+++ b/0002-Build-tools-for-the-target-platform.patch
@@ -1,4 +1,4 @@
-From 0e8e9fc3605839c94138165817014d67c058f9f3 Mon Sep 17 00:00:00 2001
+From 16fc69c4e2081f3e9c27b98a970bd0c177e78221 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 7 May 2021 16:10:47 +0200
Subject: [PATCH 2/3] Build tools for the target platform
@@ -63,5 +63,5 @@ index 515a5fc..86369ae 100644
main.cpp
PUBLIC_LIBRARIES
--
-2.39.0
+2.39.2
diff --git a/0003-Fix-compile-error-about-missing-QStringView-overload.patch b/0003-Fix-compile-error-about-missing-QStringView-overload.patch
index f40f2d9ec568..eafaff9190ae 100644
--- a/0003-Fix-compile-error-about-missing-QStringView-overload.patch
+++ b/0003-Fix-compile-error-about-missing-QStringView-overload.patch
@@ -1,4 +1,4 @@
-From 1ca6f1cd39edfd37fe601cdd341d50dbd75b070d Mon Sep 17 00:00:00 2001
+From 9bc85106cb4380c723b8e095d700094382d380ac Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Mon, 12 Sep 2022 17:38:47 +0200
Subject: [PATCH 3/3] Fix compile error about missing QStringView overload
@@ -33,5 +33,5 @@ index 435ab1e..3b8c8e9 100644
nextTypeAndForceComplete = startType + lengthType;
} while (true);
--
-2.39.0
+2.39.2
diff --git a/PKGBUILD b/PKGBUILD
index 05b27348bd8d..7048bca42928 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-activeqt-static
-_qtver=6.4.2
+_qtver=6.4.3
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -21,10 +21,10 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch'
'0002-Build-tools-for-the-target-platform.patch'
'0003-Fix-compile-error-about-missing-QStringView-overload.patch')
-sha256sums=('123d0e6c4e31263a91a8e3acd72ace3f0c7109f1b15a2e18d594e450c47dc5cf'
- '7cede1ca4b979d56f3047da9d9362c02ae3c44dc9b822743f6f26fea01070c4b'
- '24bb6073a6c5e19232336659c8d013921d1c5a200d4ea4c8d76f83335a3ec7f0'
- '1a53a66116bc05561152225e178d116d59a971c105373911804efeec0777cd4f')
+sha256sums=('093ee1d1514d32ed2657e32b6370523e57881d843fa87276e20cb7b2fb711c6d'
+ '66e5a32fa63add8a712406ebaeb56e948b8ef5b4b24fc43e12d8f714fbac6a44'
+ '3ff2118e5b88aa47d053965335c764a4aa803bdafe8340c78f757b2809027e15'
+ 'da3fb21d0ecd45594ed0ad06f37bbbb1bd356fc125948cc47016b8361dbade0f')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/qtactiveqt-sha256.txt b/qtactiveqt-sha256.txt
index 28507e5203c1..cec502b4a7ca 100644
--- a/qtactiveqt-sha256.txt
+++ b/qtactiveqt-sha256.txt
@@ -1 +1 @@
-123d0e6c4e31263a91a8e3acd72ace3f0c7109f1b15a2e18d594e450c47dc5cf
+093ee1d1514d32ed2657e32b6370523e57881d843fa87276e20cb7b2fb711c6d