summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-04-05 10:47:45 +0200
committerMartchus2023-04-05 10:47:45 +0200
commit46f03dcd461191acd6461b530cf754f623365a85 (patch)
treeb7cd5d0f57a51fb950cc80cfd3dea157518e46bf
parent2c53567ee789150e0957bbc31ec1497ac3772567 (diff)
downloadaur-46f03dcd461191acd6461b530cf754f623365a85.tar.gz
Update to 6.5.0
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch6
-rw-r--r--0002-Build-tools-for-the-target-platform.patch38
-rw-r--r--0003-Fix-compile-error-about-missing-QStringView-overload.patch6
-rw-r--r--PKGBUILD10
-rw-r--r--qtactiveqt-sha256.txt2
6 files changed, 36 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10a9bc283ad9..ac837a5f88f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-activeqt-static
pkgdesc = ActiveX integration framework (mingw-w64)
- pkgver = 6.4.3
+ pkgver = 6.5.0
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -21,13 +21,13 @@ pkgbase = mingw-w64-qt6-activeqt-static
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.4/6.4.3/submodules/qtactiveqt-everywhere-src-6.4.3.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.5/6.5.0/submodules/qtactiveqt-everywhere-src-6.5.0.tar.xz
source = 0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
source = 0002-Build-tools-for-the-target-platform.patch
source = 0003-Fix-compile-error-about-missing-QStringView-overload.patch
- sha256sums = 093ee1d1514d32ed2657e32b6370523e57881d843fa87276e20cb7b2fb711c6d
- sha256sums = 66e5a32fa63add8a712406ebaeb56e948b8ef5b4b24fc43e12d8f714fbac6a44
- sha256sums = 3ff2118e5b88aa47d053965335c764a4aa803bdafe8340c78f757b2809027e15
- sha256sums = da3fb21d0ecd45594ed0ad06f37bbbb1bd356fc125948cc47016b8361dbade0f
+ sha256sums = 25b0aacbd9aaac3822ee44ac201a159d3e63c77bfbce57599c0368f294f89c3b
+ sha256sums = 869a86ceb1801432bada4f12420703140563393661d9d4283982019d5831cd14
+ sha256sums = 78e8f82cf03e5ce55498f553a98e65b8e990c38038b58bf98afcceb65add27ed
+ sha256sums = c83752006cae2dd3573c88aa674daef6cb62d2e7e1146a8c8ea32cbca9a20362
pkgname = mingw-w64-qt6-activeqt-static
diff --git a/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
index 598270d2bb2b..1314612c105d 100644
--- a/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
+++ b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
@@ -1,4 +1,4 @@
-From 510fd537b1f6329d429b51e19d593214605d1b4a Mon Sep 17 00:00:00 2001
+From cfa5a39b153d434906682f3c89059e2c38a43940 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:21:08 +0200
Subject: [PATCH 1/3] Handle win64 in dumpcpp and
@@ -26,7 +26,7 @@ index c3b9b0a..ee19ffe 100644
break;
}
diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
-index fc8bf8c..435ab1e 100644
+index 9820a76..222aff0 100644
--- a/tools/dumpcpp/main.cpp
+++ b/tools/dumpcpp/main.cpp
@@ -1111,6 +1111,10 @@ int main(int argc, char **argv)
@@ -52,5 +52,5 @@ index fc8bf8c..435ab1e 100644
}
--
-2.39.2
+2.40.0
diff --git a/0002-Build-tools-for-the-target-platform.patch b/0002-Build-tools-for-the-target-platform.patch
index 941961283682..351fc4273bcb 100644
--- a/0002-Build-tools-for-the-target-platform.patch
+++ b/0002-Build-tools-for-the-target-platform.patch
@@ -1,4 +1,4 @@
-From 16fc69c4e2081f3e9c27b98a970bd0c177e78221 Mon Sep 17 00:00:00 2001
+From c20640e04fcc1b26e7d608a85e3e0060e0598124 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 7 May 2021 16:10:47 +0200
Subject: [PATCH 2/3] Build tools for the target platform
@@ -13,55 +13,53 @@ executed using WINE.
3 files changed, 5 insertions(+), 6 deletions(-)
diff --git a/src/tools/idc/CMakeLists.txt b/src/tools/idc/CMakeLists.txt
-index 3a3e946..11dcad5 100644
+index f1d784e..b595ac5 100644
--- a/src/tools/idc/CMakeLists.txt
+++ b/src/tools/idc/CMakeLists.txt
-@@ -5,12 +5,13 @@
+@@ -6,10 +6,11 @@
#####################################################################
qt_get_tool_target_name(target_name idc)
--qt_internal_add_tool(${target_name} # special case
-+qt_internal_add_app(${target_name} # special case
- # BOOTSTRAP # special case
+-qt_internal_add_tool(${target_name}
++qt_internal_add_app(${target_name}
TARGET_DESCRIPTION "Active Qt Interface Description Compiler"
-- TOOLS_TARGET AxServer # special case
+- TOOLS_TARGET AxServer
SOURCES
main.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
)
qt_internal_return_unless_building_tools()
-
diff --git a/tools/dumpcpp/CMakeLists.txt b/tools/dumpcpp/CMakeLists.txt
-index fb7b1db..d1806ab 100644
+index 571f830..7cbec30 100644
--- a/tools/dumpcpp/CMakeLists.txt
+++ b/tools/dumpcpp/CMakeLists.txt
-@@ -5,9 +5,8 @@
+@@ -6,9 +6,8 @@
#####################################################################
qt_get_tool_target_name(target_name dumpcpp)
--qt_internal_add_tool(${target_name} # special case
-+qt_internal_add_app(${target_name} # special case
+-qt_internal_add_tool(${target_name}
++qt_internal_add_app(${target_name}
TARGET_DESCRIPTION "Active Qt DumpCpp"
-- TOOLS_TARGET AxContainer # special case
+- TOOLS_TARGET AxContainer
SOURCES
main.cpp
moc.cpp moc.h
diff --git a/tools/dumpdoc/CMakeLists.txt b/tools/dumpdoc/CMakeLists.txt
-index 515a5fc..86369ae 100644
+index 84b4018..1dc4b9e 100644
--- a/tools/dumpdoc/CMakeLists.txt
+++ b/tools/dumpdoc/CMakeLists.txt
-@@ -5,9 +5,8 @@
+@@ -6,9 +6,8 @@
#####################################################################
qt_get_tool_target_name(target_name dumpdoc)
--qt_internal_add_tool(${target_name} # special case
-+qt_internal_add_app(${target_name} # special case
+-qt_internal_add_tool(${target_name}
++qt_internal_add_app(${target_name}
TARGET_DESCRIPTION "Active Qt DumpDoc"
-- TOOLS_TARGET AxContainer # special case
+- TOOLS_TARGET AxContainer
SOURCES
main.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
--
-2.39.2
+2.40.0
diff --git a/0003-Fix-compile-error-about-missing-QStringView-overload.patch b/0003-Fix-compile-error-about-missing-QStringView-overload.patch
index eafaff9190ae..96e47e4dd0bc 100644
--- a/0003-Fix-compile-error-about-missing-QStringView-overload.patch
+++ b/0003-Fix-compile-error-about-missing-QStringView-overload.patch
@@ -1,4 +1,4 @@
-From 9bc85106cb4380c723b8e095d700094382d380ac Mon Sep 17 00:00:00 2001
+From fd8c8a7edd18b3fc310073ca1bf6483f1ad46a08 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Mon, 12 Sep 2022 17:38:47 +0200
Subject: [PATCH 3/3] Fix compile error about missing QStringView overload
@@ -20,7 +20,7 @@ Prevents the following compiler error:
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
-index 435ab1e..3b8c8e9 100644
+index 222aff0..53d2a18 100644
--- a/tools/dumpcpp/main.cpp
+++ b/tools/dumpcpp/main.cpp
@@ -570,7 +570,7 @@ bool generateClassImpl(QTextStream &out, const QMetaObject *mo, const QByteArray
@@ -33,5 +33,5 @@ index 435ab1e..3b8c8e9 100644
nextTypeAndForceComplete = startType + lengthType;
} while (true);
--
-2.39.2
+2.40.0
diff --git a/PKGBUILD b/PKGBUILD
index 7048bca42928..5e03b8efb174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-activeqt-static
-_qtver=6.4.3
+_qtver=6.5.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -21,10 +21,10 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch'
'0002-Build-tools-for-the-target-platform.patch'
'0003-Fix-compile-error-about-missing-QStringView-overload.patch')
-sha256sums=('093ee1d1514d32ed2657e32b6370523e57881d843fa87276e20cb7b2fb711c6d'
- '66e5a32fa63add8a712406ebaeb56e948b8ef5b4b24fc43e12d8f714fbac6a44'
- '3ff2118e5b88aa47d053965335c764a4aa803bdafe8340c78f757b2809027e15'
- 'da3fb21d0ecd45594ed0ad06f37bbbb1bd356fc125948cc47016b8361dbade0f')
+sha256sums=('25b0aacbd9aaac3822ee44ac201a159d3e63c77bfbce57599c0368f294f89c3b'
+ '869a86ceb1801432bada4f12420703140563393661d9d4283982019d5831cd14'
+ '78e8f82cf03e5ce55498f553a98e65b8e990c38038b58bf98afcceb65add27ed'
+ 'c83752006cae2dd3573c88aa674daef6cb62d2e7e1146a8c8ea32cbca9a20362')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/qtactiveqt-sha256.txt b/qtactiveqt-sha256.txt
index cec502b4a7ca..f49193f81458 100644
--- a/qtactiveqt-sha256.txt
+++ b/qtactiveqt-sha256.txt
@@ -1 +1 @@
-093ee1d1514d32ed2657e32b6370523e57881d843fa87276e20cb7b2fb711c6d
+25b0aacbd9aaac3822ee44ac201a159d3e63c77bfbce57599c0368f294f89c3b