summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2022-09-12 18:10:45 +0200
committerMartchus2022-09-12 18:10:45 +0200
commit4f670a7e0c50f75d3f94ce56e0d4a68093f21df6 (patch)
treedec9b259d8a1d9b5fec56a7d41966292a13f4c1d
parente14e7c1718c804ade9a7014d7c749ce448ab06af (diff)
downloadaur-4f670a7e0c50f75d3f94ce56e0d4a68093f21df6.tar.gz
Update to 6.3.2
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch16
-rw-r--r--0002-Build-tools-for-the-target-platform.patch6
-rw-r--r--0003-Fix-compile-error-about-missing-QStringView-overload.patch37
-rw-r--r--PKGBUILD12
-rw-r--r--qtactiveqt-sha256.txt2
6 files changed, 63 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cce0dd4dd983..51bb7c77dbd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-activeqt-static
pkgdesc = ActiveX integration framework (mingw-w64)
- pkgver = 6.3.1
+ pkgver = 6.3.2
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -21,11 +21,13 @@ pkgbase = mingw-w64-qt6-activeqt-static
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.3/6.3.1/submodules/qtactiveqt-everywhere-src-6.3.1.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.3/6.3.2/submodules/qtactiveqt-everywhere-src-6.3.2.tar.xz
source = 0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
source = 0002-Build-tools-for-the-target-platform.patch
- sha256sums = 64b54e93bd3deb325c404ff7c7255b2769963b4096ebc22a97db788b257ebe2b
- sha256sums = b2f1cc5963db2b9d57911dec5b916365586239832733d103afcfa5c989502e61
- sha256sums = 9560597e94dc85c341f745db64d1bdbf3da295c5c0eb1c7c6594334311fda26c
+ source = 0003-Fix-compile-error-about-missing-QStringView-overload.patch
+ sha256sums = fc70894425fa064bb486b6323c3ae9f405e462ed32b7494ab830a16429675514
+ sha256sums = 7d7377d77790a8dbb9f80d1b2539ddb848db59782911ba842d4ce4dfa64b8d55
+ sha256sums = 68473136a589f73c4b04455196ee8b9ca627d368a8f7e19a18864c0cc563a7d7
+ sha256sums = 8c94ab1a21a98fca5912f94eb70fbc64cfa4faa55a165bc01276b4c83e2bb3fd
pkgname = mingw-w64-qt6-activeqt-static
diff --git a/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
index e8340f0a775b..3b9f834ffece 100644
--- a/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
+++ b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
@@ -1,7 +1,7 @@
-From 11bf98cd89b7169d81352ba7f652661964531751 Mon Sep 17 00:00:00 2001
+From 99ecce1582c58af2c9b100c8e33ab1b531307c0a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:21:08 +0200
-Subject: [PATCH 1/2] Handle win64 in dumpcpp and
+Subject: [PATCH 1/3] Handle win64 in dumpcpp and
MetaObjectGenerator::readClassInfo
See https://bugreports.qt.io/browse/QTBUG-46827
@@ -11,10 +11,10 @@ See https://bugreports.qt.io/browse/QTBUG-46827
2 files changed, 12 insertions(+)
diff --git a/src/activeqt/container/qaxbase.cpp b/src/activeqt/container/qaxbase.cpp
-index c97ad9a..37f9f94 100644
+index 29d1ae9..dc871c5 100644
--- a/src/activeqt/container/qaxbase.cpp
+++ b/src/activeqt/container/qaxbase.cpp
-@@ -2104,6 +2104,10 @@ void MetaObjectGenerator::readClassInfo()
+@@ -2164,6 +2164,10 @@ void MetaObjectGenerator::readClassInfo()
const QStringList versions = controls.childGroups();
for (const QString &version : versions) {
tlfile = controls.value(QLatin1Char('/') + version + QLatin1String("/0/win32/.")).toString();
@@ -26,10 +26,10 @@ index c97ad9a..37f9f94 100644
break;
}
diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
-index 3142265..8188657 100644
+index 400ecce..ef44327 100644
--- a/tools/dumpcpp/main.cpp
+++ b/tools/dumpcpp/main.cpp
-@@ -1106,6 +1106,10 @@ int main(int argc, char **argv)
+@@ -1136,6 +1136,10 @@ int main(int argc, char **argv)
typeLib = settings.value(keyPrefix + QLatin1String("win32/.")).toString();
if (QFile::exists(typeLib))
break;
@@ -40,7 +40,7 @@ index 3142265..8188657 100644
}
if (!typeLib.isEmpty())
-@@ -1170,6 +1174,10 @@ int main(int argc, char **argv)
+@@ -1200,6 +1204,10 @@ int main(int argc, char **argv)
typeLib = settings.value(keyPrefix + QLatin1String("win32/.")).toString();
if (QFile::exists(typeLib))
break;
@@ -52,5 +52,5 @@ index 3142265..8188657 100644
}
--
-2.36.1
+2.37.3
diff --git a/0002-Build-tools-for-the-target-platform.patch b/0002-Build-tools-for-the-target-platform.patch
index 98a67f5c24c0..6eadee7193f5 100644
--- a/0002-Build-tools-for-the-target-platform.patch
+++ b/0002-Build-tools-for-the-target-platform.patch
@@ -1,7 +1,7 @@
-From 108c018eb1669292c88430a1639d982eb269e31a Mon Sep 17 00:00:00 2001
+From 474401fa162c3d7497e587d21c7ed296c840ec04 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 7 May 2021 16:10:47 +0200
-Subject: [PATCH 2/2] Build tools for the target platform
+Subject: [PATCH 2/3] Build tools for the target platform
These tools seem to be not portable so they should not be built for the
host platform. If they need to be executed on the host they could be
@@ -63,5 +63,5 @@ index 515a5fc..86369ae 100644
main.cpp
PUBLIC_LIBRARIES
--
-2.36.1
+2.37.3
diff --git a/0003-Fix-compile-error-about-missing-QStringView-overload.patch b/0003-Fix-compile-error-about-missing-QStringView-overload.patch
new file mode 100644
index 000000000000..5dff89d21c00
--- /dev/null
+++ b/0003-Fix-compile-error-about-missing-QStringView-overload.patch
@@ -0,0 +1,37 @@
+From e7b3391c2b5f568ad03282ee0f242e42170b22d0 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Mon, 12 Sep 2022 17:38:47 +0200
+Subject: [PATCH 3/3] Fix compile error about missing QStringView overload
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Prevents the following compiler error:
+```
+/build/mingw-w64-qt6-activeqt/src/qtactiveqt-everywhere-src-6.3.2/tools/dumpcpp/main.cpp:599:41: error: no match for ‘operator+’ (operand types are ‘const QString’ and ‘QStringView’)
+ 599 | moCode.insert(startType, ns + QStringView(u"::"));
+ | ~~ ^ ~~~~~~~~~~~~~~~~~~
+ | | |
+ | | QStringView
+ | const QString
+```
+---
+ tools/dumpcpp/main.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
+index ef44327..997fa24 100644
+--- a/tools/dumpcpp/main.cpp
++++ b/tools/dumpcpp/main.cpp
+@@ -595,7 +595,7 @@ bool generateClassImpl(QTextStream &out, const QMetaObject *mo, const QByteArray
+ const auto namespaceForTypeEntry = namespaceForType.constFind(type.toUtf8());
+ if (namespaceForTypeEntry != namespaceForType.constEnd()) {
+ const auto ns = QString::fromUtf8(namespaceForTypeEntry.value());
+- moCode.insert(startType, ns + QStringView(u"::"));
++ moCode.insert(startType, ns + QStringLiteral("::"));
+ }
+ nextTypeAndForceComplete = startType + lengthType;
+ } while (true);
+--
+2.37.3
+
diff --git a/PKGBUILD b/PKGBUILD
index c4f6e38856b5..f9e8130acbb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-activeqt-static
-_qtver=6.3.1
+_qtver=6.3.2
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -19,10 +19,12 @@ groups=(mingw-w64-qt6)
_pkgfqn="qtactiveqt-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
'0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch'
- '0002-Build-tools-for-the-target-platform.patch')
-sha256sums=('64b54e93bd3deb325c404ff7c7255b2769963b4096ebc22a97db788b257ebe2b'
- 'b2f1cc5963db2b9d57911dec5b916365586239832733d103afcfa5c989502e61'
- '9560597e94dc85c341f745db64d1bdbf3da295c5c0eb1c7c6594334311fda26c')
+ '0002-Build-tools-for-the-target-platform.patch'
+ '0003-Fix-compile-error-about-missing-QStringView-overload.patch')
+sha256sums=('fc70894425fa064bb486b6323c3ae9f405e462ed32b7494ab830a16429675514'
+ '7d7377d77790a8dbb9f80d1b2539ddb848db59782911ba842d4ce4dfa64b8d55'
+ '68473136a589f73c4b04455196ee8b9ca627d368a8f7e19a18864c0cc563a7d7'
+ '8c94ab1a21a98fca5912f94eb70fbc64cfa4faa55a165bc01276b4c83e2bb3fd')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/qtactiveqt-sha256.txt b/qtactiveqt-sha256.txt
index d80bb2939d13..b01b6e004de9 100644
--- a/qtactiveqt-sha256.txt
+++ b/qtactiveqt-sha256.txt
@@ -1 +1 @@
-64b54e93bd3deb325c404ff7c7255b2769963b4096ebc22a97db788b257ebe2b
+fc70894425fa064bb486b6323c3ae9f405e462ed32b7494ab830a16429675514