summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-10-12 10:45:19 +0200
committerMartchus2023-10-12 10:45:19 +0200
commitba1d5409f5d36e6275e4842f7cbc3469b2c8b618 (patch)
tree01d16a7922ef25b159002c66268bf3e1eb57269c
parent83b184ce03dc461164e30bacbc528b2261d69632 (diff)
downloadaur-ba1d5409f5d36e6275e4842f7cbc3469b2c8b618.tar.gz
Update to 6.6.0
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch8
-rw-r--r--0002-Build-tools-for-the-target-platform.patch2
-rw-r--r--0003-Fix-compile-error-about-missing-QStringView-overload.patch8
-rw-r--r--PKGBUILD10
-rw-r--r--qtactiveqt-sha256.txt2
6 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27ddf9e33b89..8d94d9e48da7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-activeqt-static
pkgdesc = ActiveX integration framework (mingw-w64)
- pkgver = 6.5.3
+ pkgver = 6.6.0
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -21,13 +21,13 @@ pkgbase = mingw-w64-qt6-activeqt-static
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.5/6.5.3/submodules/qtactiveqt-everywhere-src-6.5.3.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.6/6.6.0/submodules/qtactiveqt-everywhere-src-6.6.0.tar.xz
source = 0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
source = 0002-Build-tools-for-the-target-platform.patch
source = 0003-Fix-compile-error-about-missing-QStringView-overload.patch
- sha256sums = 32ac51da95ed081f33f5644cd2f26b3a6714d303edb8f994c412f08225605cd1
- sha256sums = f1b0796bcaa226445c582a6f514ef31fdc2d85736679e0253f2f84cee0a3dd7f
- sha256sums = 597d1023ce23e7b8a2115b9d7b14b3e0ebbd66be306a0e7ec3b7d73ace75115d
- sha256sums = 36a437d16056a03eafce76fe593329010f2ceeba12ac00817ce14b17384026ca
+ sha256sums = d254cbc3e914c30aa7b704c4928ff3df1a6049221c89f02a3cf7f4fd9e167a9e
+ sha256sums = a23a55a41e704b1190e54c428d1412b026f59c11f8f2caacf095218c028ae568
+ sha256sums = f7db7051330670398fe55a80f1d2b8f7fac3f3abe2184df525ebfcb31193671c
+ sha256sums = b16d3111c95f0203ad47ab920b7b9bb9f964729aae3ecdad360ac83757617491
pkgname = mingw-w64-qt6-activeqt-static
diff --git a/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
index 2a8b34466dce..5d9d5a6d1baa 100644
--- a/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
+++ b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
@@ -1,4 +1,4 @@
-From cb094997e459b3f22fa268d125861f62f068e79f Mon Sep 17 00:00:00 2001
+From 7df430149d047580d627e92793121ad114331969 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 2 Jun 2017 17:21:08 +0200
Subject: [PATCH 1/3] Handle win64 in dumpcpp and
@@ -26,10 +26,10 @@ index 5ba59c3..a58936b 100644
break;
}
diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
-index 9820a76..222aff0 100644
+index 1b6fbeb..679bf9e 100644
--- a/tools/dumpcpp/main.cpp
+++ b/tools/dumpcpp/main.cpp
-@@ -1111,6 +1111,10 @@ int main(int argc, char **argv)
+@@ -1126,6 +1126,10 @@ int main(int argc, char **argv)
typeLib = settings.value(keyPrefix + QLatin1String("win32/.")).toString();
if (QFile::exists(typeLib))
break;
@@ -40,7 +40,7 @@ index 9820a76..222aff0 100644
}
if (!typeLib.isEmpty())
-@@ -1175,6 +1179,10 @@ int main(int argc, char **argv)
+@@ -1190,6 +1194,10 @@ int main(int argc, char **argv)
typeLib = settings.value(keyPrefix + QLatin1String("win32/.")).toString();
if (QFile::exists(typeLib))
break;
diff --git a/0002-Build-tools-for-the-target-platform.patch b/0002-Build-tools-for-the-target-platform.patch
index a8b9583fa898..798f4aa48ef5 100644
--- a/0002-Build-tools-for-the-target-platform.patch
+++ b/0002-Build-tools-for-the-target-platform.patch
@@ -1,4 +1,4 @@
-From 41a42b2d4a711da4a70aff8bde82009912acb115 Mon Sep 17 00:00:00 2001
+From 8abe25dc12e5e826caf6c8c0221dc982b8c5af3b Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 7 May 2021 16:10:47 +0200
Subject: [PATCH 2/3] Build tools for the target platform
diff --git a/0003-Fix-compile-error-about-missing-QStringView-overload.patch b/0003-Fix-compile-error-about-missing-QStringView-overload.patch
index 05131f8e794d..0aa1eee73e93 100644
--- a/0003-Fix-compile-error-about-missing-QStringView-overload.patch
+++ b/0003-Fix-compile-error-about-missing-QStringView-overload.patch
@@ -1,4 +1,4 @@
-From 3b2893be029cbead28036c24dace50f146754db3 Mon Sep 17 00:00:00 2001
+From db2ede6a2e3cb897b4302a4e6474c457a8bdf8f0 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Mon, 12 Sep 2022 17:38:47 +0200
Subject: [PATCH 3/3] Fix compile error about missing QStringView overload
@@ -20,11 +20,11 @@ Prevents the following compiler error:
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
-index 222aff0..53d2a18 100644
+index 679bf9e..d73457a 100644
--- a/tools/dumpcpp/main.cpp
+++ b/tools/dumpcpp/main.cpp
-@@ -570,7 +570,7 @@ bool generateClassImpl(QTextStream &out, const QMetaObject *mo, const QByteArray
- const auto namespaceForTypeEntry = namespaceForType.constFind(type.toUtf8());
+@@ -585,7 +585,7 @@ bool generateClassImpl(QTextStream &out, const QMetaObject *mo, const QByteArray
+ namespaceForTypeEntry = namespaceForType.constFind(type.toUtf8());
if (namespaceForTypeEntry != namespaceForType.constEnd()) {
const auto ns = QString::fromUtf8(namespaceForTypeEntry.value());
- moCode.insert(startType, ns + QStringView(u"::"));
diff --git a/PKGBUILD b/PKGBUILD
index 98cd48d366e4..073d656dcfa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-activeqt-static
-_qtver=6.5.3
+_qtver=6.6.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -21,10 +21,10 @@ source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/subm
'0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch'
'0002-Build-tools-for-the-target-platform.patch'
'0003-Fix-compile-error-about-missing-QStringView-overload.patch')
-sha256sums=('32ac51da95ed081f33f5644cd2f26b3a6714d303edb8f994c412f08225605cd1'
- 'f1b0796bcaa226445c582a6f514ef31fdc2d85736679e0253f2f84cee0a3dd7f'
- '597d1023ce23e7b8a2115b9d7b14b3e0ebbd66be306a0e7ec3b7d73ace75115d'
- '36a437d16056a03eafce76fe593329010f2ceeba12ac00817ce14b17384026ca')
+sha256sums=('d254cbc3e914c30aa7b704c4928ff3df1a6049221c89f02a3cf7f4fd9e167a9e'
+ 'a23a55a41e704b1190e54c428d1412b026f59c11f8f2caacf095218c028ae568'
+ 'f7db7051330670398fe55a80f1d2b8f7fac3f3abe2184df525ebfcb31193671c'
+ 'b16d3111c95f0203ad47ab920b7b9bb9f964729aae3ecdad360ac83757617491')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/qtactiveqt-sha256.txt b/qtactiveqt-sha256.txt
index 6ee87eecdeb1..c975e10c1c1a 100644
--- a/qtactiveqt-sha256.txt
+++ b/qtactiveqt-sha256.txt
@@ -1 +1 @@
-32ac51da95ed081f33f5644cd2f26b3a6714d303edb8f994c412f08225605cd1
+d254cbc3e914c30aa7b704c4928ff3df1a6049221c89f02a3cf7f4fd9e167a9e