summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-05-08 14:33:24 +0200
committerMartchus2021-05-08 14:33:24 +0200
commitf0b4e1df07f016c451c30dce2ca5d7ec1d46de34 (patch)
treea14dae1f08dbf9cb044a322d84df535f7257c5b5
downloadaur-f0b4e1df07f016c451c30dce2ca5d7ec1d46de34.tar.gz
Update to 6.1.0
-rw-r--r--.SRCINFO32
-rw-r--r--0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch56
-rw-r--r--0002-Build-tools-for-the-target-platform.patch67
-rw-r--r--PKGBUILD64
-rw-r--r--PKGBUILD.sh.ep1
-rw-r--r--qtactiveqt-sha256.txt1
6 files changed, 221 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a7847f046a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = mingw-w64-qt6-activeqt-static
+ pkgdesc = ActiveX integration framework (mingw-w64)
+ pkgver = 6.1.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = mingw-w64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-cmake-static
+ makedepends = mingw-w64-qt6-declarative-static
+ makedepends = mingw-w64-vulkan-headers
+ makedepends = mingw-w64-vulkan-icd-loader
+ makedepends = qt6-declarative
+ makedepends = ninja
+ depends = mingw-w64-qt6-base-static
+ optdepends = mingw-w64-qt6-declarative-static: QML bindings
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/official_releases/qt/6.1/6.1.0/submodules/qtactiveqt-everywhere-src-6.1.0.tar.xz
+ source = 0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
+ source = 0002-Build-tools-for-the-target-platform.patch
+ sha256sums = d79f964054a98b7edcfcb3f3590a58d599bcb2f9569ec10f5f5d9c0070701b4a
+ sha256sums = dc557cc9fed6f542ad8123a0bc3c384a065c019f630c8d80a8c2ff33843d7516
+ sha256sums = e0dfaee2453e03f97c784bdd934ba9f58c21fe0f16a8727154d515191a93f0fa
+
+pkgname = mingw-w64-qt6-activeqt-static
+
diff --git a/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
new file mode 100644
index 000000000000..c13d879e9519
--- /dev/null
+++ b/0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch
@@ -0,0 +1,56 @@
+From 52bafd8ad71ac730ee03a2827b1bda32527c0780 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Fri, 2 Jun 2017 17:21:08 +0200
+Subject: [PATCH 1/2] Handle win64 in dumpcpp and
+ MetaObjectGenerator::readClassInfo
+
+See https://bugreports.qt.io/browse/QTBUG-46827
+---
+ src/activeqt/container/qaxbase.cpp | 4 ++++
+ tools/dumpcpp/main.cpp | 8 ++++++++
+ 2 files changed, 12 insertions(+)
+
+diff --git a/src/activeqt/container/qaxbase.cpp b/src/activeqt/container/qaxbase.cpp
+index e97dd91..e0d9dbd 100644
+--- a/src/activeqt/container/qaxbase.cpp
++++ b/src/activeqt/container/qaxbase.cpp
+@@ -2104,6 +2104,10 @@ void MetaObjectGenerator::readClassInfo()
+ const QStringList versions = controls.childGroups();
+ for (const QString &version : versions) {
+ tlfile = controls.value(QLatin1Char('/') + version + QLatin1String("/0/win32/.")).toString();
++ if(tlfile.isEmpty())
++ {
++ tlfile = controls.value(QLatin1Char('/') + version + QLatin1String("/0/win64/.")).toString();
++ }
+ if (!tlfile.isEmpty())
+ break;
+ }
+diff --git a/tools/dumpcpp/main.cpp b/tools/dumpcpp/main.cpp
+index 092a3c0..c597942 100644
+--- a/tools/dumpcpp/main.cpp
++++ b/tools/dumpcpp/main.cpp
+@@ -1090,6 +1090,10 @@ int main(int argc, char **argv)
+ typeLib = settings.value(keyPrefix + QLatin1String("win32/.")).toString();
+ if (QFile::exists(typeLib))
+ break;
++ typeLib = settings.value(QLatin1String("/") + codes.at(c) + QLatin1String("/0/win64/.")).toByteArray();
++ if (QFile::exists(typeLib)) {
++ break;
++ }
+ }
+
+ if (!typeLib.isEmpty())
+@@ -1154,6 +1158,10 @@ int main(int argc, char **argv)
+ typeLib = settings.value(keyPrefix + QLatin1String("win32/.")).toString();
+ if (QFile::exists(typeLib))
+ break;
++ typeLib = settings.value(key + QLatin1String("/") + codes.at(c) + QLatin1String("/win64/.")).toByteArray();
++ if (QFile::exists(typeLib)) {
++ break;
++ }
+ }
+ }
+
+--
+2.31.1
+
diff --git a/0002-Build-tools-for-the-target-platform.patch b/0002-Build-tools-for-the-target-platform.patch
new file mode 100644
index 000000000000..c53282b24ec4
--- /dev/null
+++ b/0002-Build-tools-for-the-target-platform.patch
@@ -0,0 +1,67 @@
+From 58ecfedd3e4868c7ac9bb3402e6b44c5e0a1091f Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Fri, 7 May 2021 16:10:47 +0200
+Subject: [PATCH 2/2] Build tools for the target platform
+
+These tools seem to be not portable so they should not be built for the
+host platform. If they need to be executed on the host they could be
+executed using WINE.
+---
+ src/tools/idc/CMakeLists.txt | 5 +++--
+ tools/dumpcpp/CMakeLists.txt | 3 +--
+ tools/dumpdoc/CMakeLists.txt | 3 +--
+ 3 files changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/src/tools/idc/CMakeLists.txt b/src/tools/idc/CMakeLists.txt
+index d21b9f0..d401e45 100644
+--- a/src/tools/idc/CMakeLists.txt
++++ b/src/tools/idc/CMakeLists.txt
+@@ -5,12 +5,13 @@
+ #####################################################################
+
+ qt_get_tool_target_name(target_name idc)
+-qt_internal_add_tool(${target_name} # special case
++qt_internal_add_app(${target_name} # special case
+ # BOOTSTRAP # special case
+ TARGET_DESCRIPTION "Active Qt Interface Description Compiler"
+- TOOLS_TARGET AxContainer # special case
+ SOURCES
+ main.cpp
++ PUBLIC_LIBRARIES
++ Qt::Core
+ )
+
+ #### Keys ignored in scope 1:.:.:idc.pro:<TRUE>:
+diff --git a/tools/dumpcpp/CMakeLists.txt b/tools/dumpcpp/CMakeLists.txt
+index 8d8db8f..2c86194 100644
+--- a/tools/dumpcpp/CMakeLists.txt
++++ b/tools/dumpcpp/CMakeLists.txt
+@@ -5,9 +5,8 @@
+ #####################################################################
+
+ qt_get_tool_target_name(target_name dumpcpp)
+-qt_internal_add_tool(${target_name} # special case
++qt_internal_add_app(${target_name} # special case
+ TARGET_DESCRIPTION "Active Qt DumpCpp"
+- TOOLS_TARGET AxContainer # special case
+ SOURCES
+ main.cpp
+ moc.cpp moc.h
+diff --git a/tools/dumpdoc/CMakeLists.txt b/tools/dumpdoc/CMakeLists.txt
+index 073ce62..a646314 100644
+--- a/tools/dumpdoc/CMakeLists.txt
++++ b/tools/dumpdoc/CMakeLists.txt
+@@ -5,9 +5,8 @@
+ #####################################################################
+
+ qt_get_tool_target_name(target_name dumpdoc)
+-qt_internal_add_tool(${target_name} # special case
++qt_internal_add_app(${target_name} # special case
+ TARGET_DESCRIPTION "Active Qt DumpDoc"
+- TOOLS_TARGET AxContainer # special case
+ SOURCES
+ main.cpp
+ PUBLIC_LIBRARIES
+--
+2.31.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0187894bbbd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=mingw-w64-qt6-activeqt-static
+_qtver=6.1.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='ActiveX integration framework (mingw-w64)'
+depends=('mingw-w64-qt6-base-static')
+optdepends=('mingw-w64-qt6-declarative-static: QML bindings')
+makedepends=('mingw-w64-cmake-static' 'mingw-w64-qt6-declarative-static' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'ninja')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(mingw-w64-qt6)
+_pkgfqn="qtactiveqt-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch'
+ '0002-Build-tools-for-the-target-platform.patch')
+sha256sums=('d79f964054a98b7edcfcb3f3590a58d599bcb2f9569ec10f5f5d9c0070701b4a'
+ 'dc557cc9fed6f542ad8123a0bc3c384a065c019f630c8d80a8c2ff33843d7516'
+ 'e0dfaee2453e03f97c784bdd934ba9f58c21fe0f16a8727154d515191a93f0fa')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
+build() {
+ for _arch in ${_architectures}; do
+ export PKG_CONFIG=/usr/bin/$_arch-pkg-config
+ $_arch-cmake-static -G Ninja -B build-$_arch -S $_pkgfqn \
+ -DCMAKE_INSTALL_PREFIX:PATH="/usr/$_arch/static" \
+ -DFEATURE_static_runtime=ON \
+ -DFEATURE_pkg_config=ON
+ cmake --build build-$_arch
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" cmake --install build-$_arch
+
+ find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/static/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/static/share/doc"
+ done
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/mingw-w64-qt6-base-static "$pkgdir"/usr/share/licenses/$pkgname
+
+}
+
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..87756da456f4
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1 @@
+%= include "$default_package_name/mingw-w64/PKGBUILD";
diff --git a/qtactiveqt-sha256.txt b/qtactiveqt-sha256.txt
new file mode 100644
index 000000000000..bdd4eccd06f7
--- /dev/null
+++ b/qtactiveqt-sha256.txt
@@ -0,0 +1 @@
+d79f964054a98b7edcfcb3f3590a58d599bcb2f9569ec10f5f5d9c0070701b4a