summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-10-02 12:46:47 +0200
committerMartchus2021-10-02 12:46:47 +0200
commit6e5e39d707b8af2d9376992ed8ca499581917748 (patch)
treef3d42a4159605feaa790f2f6fde45017948ba106
downloadaur-6e5e39d707b8af2d9376992ed8ca499581917748.tar.gz
Update to 6.2.0
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD57
-rw-r--r--PKGBUILD.sh.ep12
-rw-r--r--qtconnectivity-sha256.txt1
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e3d92627936
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = mingw-w64-qt6-connectivity
+ pkgdesc = Provides access to Bluetooth hardware (mingw-w64)
+ pkgver = 6.2.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = mingw-w64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-qt6-declarative
+ makedepends = mingw-w64-vulkan-headers
+ makedepends = mingw-w64-vulkan-icd-loader
+ makedepends = qt6-declarative
+ makedepends = ninja
+ depends = mingw-w64-qt6-base
+ optdepends = mingw-w64-qt6-declarative: QML bindings
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/official_releases/qt/6.2/6.2.0/submodules/qtconnectivity-everywhere-src-6.2.0.tar.xz
+ sha256sums = 4c689100bb43f78a7e30380296376b7f4dff356d9a02b0bba97362d6b497649c
+
+pkgname = mingw-w64-qt6-connectivity
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bfb617844b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=mingw-w64-qt6-connectivity
+_qtver=6.2.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Provides access to Bluetooth hardware (mingw-w64)'
+depends=('mingw-w64-qt6-base')
+optdepends=('mingw-w64-qt6-declarative: QML bindings')
+makedepends=('mingw-w64-cmake' 'mingw-w64-qt6-declarative' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'ninja')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(mingw-w64-qt6)
+_pkgfqn="qtconnectivity-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('4c689100bb43f78a7e30380296376b7f4dff356d9a02b0bba97362d6b497649c')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+build() {
+ for _arch in ${_architectures}; do
+ export PKG_CONFIG=/usr/bin/$_arch-pkg-config
+ $_arch-cmake -G Ninja -B build-$_arch -S $_pkgfqn \
+ -DFEATURE_pkg_config=ON
+ cmake --build build-$_arch
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" cmake --install build-$_arch
+
+ # Add symlinks of DLLs in usual bin directory
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/$_arch/bin"
+ for dll in "$pkgdir"/usr/$_arch/lib/qt6/bin/*.dll; do
+ ln -rs "$dll" "$pkgdir/usr/$_arch/bin/${dll##*/}"
+ done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/$_arch/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/share/doc"
+ done
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/mingw-w64-qt6-base "$pkgdir"/usr/share/licenses/$pkgname
+
+}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..4dbf66044ddd
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,12 @@
+% layout 'mingw-w64-qt6-module';
+\
+_qtver=6.2.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Provides access to Bluetooth hardware (mingw-w64)'
+depends=(<%== qt6deps qw(base) %>)
+optdepends=(<%== qt6optdeps declarative => 'QML bindings' %>)
+makedepends=('mingw-w64-cmake<%== $static_suffix %>' <%== qt6deps qw(declarative) %> 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'ninja')
diff --git a/qtconnectivity-sha256.txt b/qtconnectivity-sha256.txt
new file mode 100644
index 000000000000..7728763ac1f9
--- /dev/null
+++ b/qtconnectivity-sha256.txt
@@ -0,0 +1 @@
+4c689100bb43f78a7e30380296376b7f4dff356d9a02b0bba97362d6b497649c