summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-04-05 10:45:31 +0200
committerMartchus2023-04-05 10:45:31 +0200
commit75127b12b1602385a62b378778aa50508e47ec0a (patch)
tree3c40da32c5c036df3b87dbd1701ca9363b8018a0
parente15edd1a42f0d61868f5e515ddf9893aae5007bd (diff)
downloadaur-75127b12b1602385a62b378778aa50508e47ec0a.tar.gz
Update to 6.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Exclude-qmltime-when-cross-compiling.patch8
-rw-r--r--PKGBUILD6
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qtdeclarative-sha256.txt2
5 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 182d21fb2a0c..8ed411312d9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-declarative
pkgdesc = Classes for QML and JavaScript languages (mingw-w64)
- pkgver = 6.4.3
+ pkgver = 6.5.0
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -25,9 +25,9 @@ pkgbase = mingw-w64-qt6-declarative
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.4/6.4.3/submodules/qtdeclarative-everywhere-src-6.4.3.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.5/6.5.0/submodules/qtdeclarative-everywhere-src-6.5.0.tar.xz
source = 0001-Exclude-qmltime-when-cross-compiling.patch
- sha256sums = 67ded1b3b988135e3600916b34bb156fe3986c88420c6f87a6d0fd53521ba795
- sha256sums = 1f5b90f3a7b7121d071982d99435a9fa2a4fa19f026d439d393c0fd1c7f9059a
+ sha256sums = f7d631cd8ebc1491dad0f30f1b5326ae812bee4ad706e61157816a82bf588c97
+ sha256sums = abef6f71bd31435262e095d0678458f809f0e6a3990a523c10db9c4ef612f5a2
pkgname = mingw-w64-qt6-declarative
diff --git a/0001-Exclude-qmltime-when-cross-compiling.patch b/0001-Exclude-qmltime-when-cross-compiling.patch
index 375eee5816a8..c07edb77b14e 100644
--- a/0001-Exclude-qmltime-when-cross-compiling.patch
+++ b/0001-Exclude-qmltime-when-cross-compiling.patch
@@ -1,4 +1,4 @@
-From 861e8176f6332d7743530f00b15a1fbac1ea9496 Mon Sep 17 00:00:00 2001
+From 9b02f99cfaafb0bbca2f145dcd6c3bbad62ea23a Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Fri, 5 Feb 2021 02:22:45 +0100
Subject: [PATCH] Exclude qmltime when cross compiling
@@ -14,10 +14,10 @@ That's likely also why upstream did not notice this problem so far.
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
-index 5a34fd4c11..063f38a943 100644
+index a99cd33c24..56243e28e8 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
-@@ -36,7 +36,9 @@ if(QT_FEATURE_qml_preview AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND
+@@ -40,7 +40,9 @@ if(QT_FEATURE_qml_preview AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND
endif()
if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT IOS AND NOT rtems)
add_subdirectory(qmlscene)
@@ -29,5 +29,5 @@ index 5a34fd4c11..063f38a943 100644
if(QT_BUILD_SHARED_LIBS
AND QT_FEATURE_process
--
-2.39.2
+2.40.0
diff --git a/PKGBUILD b/PKGBUILD
index c9291f0de15a..6037ccd78f1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-declarative
-_qtver=6.4.3
+_qtver=6.5.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -22,8 +22,8 @@ groups=(mingw-w64-qt6)
_pkgfqn="qtdeclarative-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
'0001-Exclude-qmltime-when-cross-compiling.patch')
-sha256sums=('67ded1b3b988135e3600916b34bb156fe3986c88420c6f87a6d0fd53521ba795'
- '1f5b90f3a7b7121d071982d99435a9fa2a4fa19f026d439d393c0fd1c7f9059a')
+sha256sums=('f7d631cd8ebc1491dad0f30f1b5326ae812bee4ad706e61157816a82bf588c97'
+ 'abef6f71bd31435262e095d0678458f809f0e6a3990a523c10db9c4ef612f5a2')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 74b89c8ace17..25afbce85e68 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt6-module', has_binaries => 1;
\
-_qtver=6.4.3
+_qtver=6.5.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
diff --git a/qtdeclarative-sha256.txt b/qtdeclarative-sha256.txt
index 03bf395a55e7..79b5396b5f05 100644
--- a/qtdeclarative-sha256.txt
+++ b/qtdeclarative-sha256.txt
@@ -1 +1 @@
-67ded1b3b988135e3600916b34bb156fe3986c88420c6f87a6d0fd53521ba795
+f7d631cd8ebc1491dad0f30f1b5326ae812bee4ad706e61157816a82bf588c97