summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-05-08 14:33:01 +0200
committerMartchus2021-05-08 14:33:01 +0200
commit181419cfce95be78ca5e254c5012decae7d59f54 (patch)
treeb1652fb3cd2ffc82433d391a3d8210493dd351d7
downloadaur-181419cfce95be78ca5e254c5012decae7d59f54.tar.gz
Update to 6.1.0
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD50
-rw-r--r--PKGBUILD.sh.ep1
-rw-r--r--qtlottie-sha256.txt1
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb20e0056eeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = mingw-w64-qt6-lottie-static
+ pkgdesc = A family of player software for a certain json-based file format for describing 2d vector graphics animations (mingw-w64)
+ pkgver = 6.1.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = mingw-w64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-cmake-static
+ makedepends = mingw-w64-qt6-declarative-static
+ makedepends = mingw-w64-vulkan-headers
+ makedepends = mingw-w64-vulkan-icd-loader
+ makedepends = qt6-declarative
+ makedepends = ninja
+ depends = mingw-w64-qt6-base-static
+ optdepends = mingw-w64-qt6-declarative-static: QML bindings
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/official_releases/qt/6.1/6.1.0/submodules/qtlottie-everywhere-src-6.1.0.tar.xz
+ sha256sums = 3c2478f1064574939cfc151d7df0743d6bb1119d8cee6ed3ca3bc1cdfb8fece8
+
+pkgname = mingw-w64-qt6-lottie-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe6be274e54e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=mingw-w64-qt6-lottie-static
+_qtver=6.1.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='A family of player software for a certain json-based file format for describing 2d vector graphics animations (mingw-w64)'
+depends=('mingw-w64-qt6-base-static')
+optdepends=('mingw-w64-qt6-declarative-static: QML bindings')
+makedepends=('mingw-w64-cmake-static' 'mingw-w64-qt6-declarative-static' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'ninja')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(mingw-w64-qt6)
+_pkgfqn="qtlottie-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('3c2478f1064574939cfc151d7df0743d6bb1119d8cee6ed3ca3bc1cdfb8fece8')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+build() {
+ for _arch in ${_architectures}; do
+ export PKG_CONFIG=/usr/bin/$_arch-pkg-config
+ $_arch-cmake-static -G Ninja -B build-$_arch -S $_pkgfqn \
+ -DCMAKE_INSTALL_PREFIX:PATH="/usr/$_arch/static" \
+ -DFEATURE_static_runtime=ON \
+ -DFEATURE_pkg_config=ON
+ cmake --build build-$_arch
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" cmake --install build-$_arch
+
+ find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/static/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/static/share/doc"
+ done
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/mingw-w64-qt6-base-static "$pkgdir"/usr/share/licenses/$pkgname
+
+}
+
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..87756da456f4
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1 @@
+%= include "$default_package_name/mingw-w64/PKGBUILD";
diff --git a/qtlottie-sha256.txt b/qtlottie-sha256.txt
new file mode 100644
index 000000000000..30f27abf2d65
--- /dev/null
+++ b/qtlottie-sha256.txt
@@ -0,0 +1 @@
+3c2478f1064574939cfc151d7df0743d6bb1119d8cee6ed3ca3bc1cdfb8fece8