summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-10-02 12:46:54 +0200
committerMartchus2021-10-02 12:46:54 +0200
commit43527b77e4c58d519ebe5041af77c94e0ce17d3f (patch)
tree134553c70c0a857ca194e35934d80b5ab467b0cc
downloadaur-43527b77e4c58d519ebe5041af77c94e0ce17d3f.tar.gz
Update to 6.2.0
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD57
-rw-r--r--PKGBUILD.sh.ep12
-rw-r--r--qtmultimedia-sha256.txt1
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7533da59a8e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = mingw-w64-qt6-multimedia
+ pkgdesc = Classes for audio, video, radio and camera functionality (mingw-w64)
+ pkgver = 6.2.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = mingw-w64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-qt6-declarative
+ makedepends = mingw-w64-qt6-shadertools
+ makedepends = mingw-w64-vulkan-headers
+ makedepends = mingw-w64-vulkan-icd-loader
+ makedepends = qt6-declarative
+ makedepends = qt6-shadertools
+ makedepends = ninja
+ depends = mingw-w64-qt6-base
+ optdepends = mingw-w64-qt6-declarative: QML bindings
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/official_releases/qt/6.2/6.2.0/submodules/qtmultimedia-everywhere-src-6.2.0.tar.xz
+ sha256sums = f12b96e6da2ebfe84105c0cb6e96fbc6bda012de8998ec5c96b58c85dcb40b4f
+
+pkgname = mingw-w64-qt6-multimedia
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..555f01199527
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=mingw-w64-qt6-multimedia
+_qtver=6.2.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Classes for audio, video, radio and camera functionality (mingw-w64)'
+depends=('mingw-w64-qt6-base')
+optdepends=('mingw-w64-qt6-declarative: QML bindings')
+makedepends=('mingw-w64-cmake' 'mingw-w64-qt6-declarative' 'mingw-w64-qt6-shadertools' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'qt6-shadertools' 'ninja')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(mingw-w64-qt6)
+_pkgfqn="qtmultimedia-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('f12b96e6da2ebfe84105c0cb6e96fbc6bda012de8998ec5c96b58c85dcb40b4f')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+build() {
+ for _arch in ${_architectures}; do
+ export PKG_CONFIG=/usr/bin/$_arch-pkg-config
+ $_arch-cmake -G Ninja -B build-$_arch -S $_pkgfqn \
+ -DFEATURE_pkg_config=ON
+ cmake --build build-$_arch
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" cmake --install build-$_arch
+
+ # Add symlinks of DLLs in usual bin directory
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/$_arch/bin"
+ for dll in "$pkgdir"/usr/$_arch/lib/qt6/bin/*.dll; do
+ ln -rs "$dll" "$pkgdir/usr/$_arch/bin/${dll##*/}"
+ done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/$_arch/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/share/doc"
+ done
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/mingw-w64-qt6-base "$pkgdir"/usr/share/licenses/$pkgname
+
+}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..59705c73b4c2
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,12 @@
+% layout 'mingw-w64-qt6-module';
+\
+_qtver=6.2.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Classes for audio, video, radio and camera functionality (mingw-w64)'
+depends=(<%== qt6deps qw(base) %>)
+optdepends=(<%== qt6optdeps declarative => 'QML bindings' %>)
+makedepends=('mingw-w64-cmake<%== $static_suffix %>' <%== qt6deps qw(declarative shadertools) %> 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'qt6-shadertools' 'ninja')
diff --git a/qtmultimedia-sha256.txt b/qtmultimedia-sha256.txt
new file mode 100644
index 000000000000..8e2fb6816345
--- /dev/null
+++ b/qtmultimedia-sha256.txt
@@ -0,0 +1 @@
+f12b96e6da2ebfe84105c0cb6e96fbc6bda012de8998ec5c96b58c85dcb40b4f