summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-04-06 15:42:28 +0200
committerMartchus2023-04-06 15:42:28 +0200
commitfb88e5c45cf86d0825770e01e171510e2b1f0762 (patch)
treec05af90b65437cc93ca10034125e8014605fcd78
parentf2b86ab11cd2c1d000122136589ef2e941d39d24 (diff)
downloadaur-fb88e5c45cf86d0825770e01e171510e2b1f0762.tar.gz
Update to 6.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-compile-flags-of-resonance-audio-for-mingw-w64.patch34
-rw-r--r--PKGBUILD30
-rw-r--r--PKGBUILD.sh.ep18
-rw-r--r--qtmultimedia-sha256.txt2
5 files changed, 83 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecaab50c0f35..670d915af352 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-multimedia
pkgdesc = Classes for audio, video, radio and camera functionality (mingw-w64)
- pkgver = 6.3.2
+ pkgver = 6.5.0
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -23,7 +23,9 @@ pkgbase = mingw-w64-qt6-multimedia
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.3/6.3.2/submodules/qtmultimedia-everywhere-src-6.3.2.tar.xz
- sha256sums = 7f6829aa4509e23a9804260b6d859531b20a806c4dadedfd2c0c7dd314c01c43
+ source = https://download.qt.io/official_releases/qt/6.5/6.5.0/submodules/qtmultimedia-everywhere-src-6.5.0.tar.xz
+ source = 0001-Fix-compile-flags-of-resonance-audio-for-mingw-w64.patch
+ sha256sums = 9480d0c73abdd01aec4899e340938cec046a3f404b9f9ed945288be574dca146
+ sha256sums = fa134d80bd74c32839407ec348424b55daf251899e5056adb024bad194e02482
pkgname = mingw-w64-qt6-multimedia
diff --git a/0001-Fix-compile-flags-of-resonance-audio-for-mingw-w64.patch b/0001-Fix-compile-flags-of-resonance-audio-for-mingw-w64.patch
new file mode 100644
index 000000000000..ba7a77eebfcc
--- /dev/null
+++ b/0001-Fix-compile-flags-of-resonance-audio-for-mingw-w64.patch
@@ -0,0 +1,34 @@
+From 76fe98d7b9f371320a5a9833b4489bb53c4d3a26 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sat, 1 Oct 2022 17:43:07 +0200
+Subject: [PATCH] Fix compile flags of resonance-audio for mingw-w64
+
+---
+ src/3rdparty/resonance-audio/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/3rdparty/resonance-audio/CMakeLists.txt b/src/3rdparty/resonance-audio/CMakeLists.txt
+index 6af0b3fb3..d94beb0ed 100644
+--- a/src/3rdparty/resonance-audio/CMakeLists.txt
++++ b/src/3rdparty/resonance-audio/CMakeLists.txt
+@@ -82,7 +82,7 @@ if (BUILD_RESONANCE_AUDIO_TESTS OR BUILD_GEOMETRICAL_ACOUSTICS_TESTS)
+ target_include_directories(gtest PUBLIC "${GTEST_DIR}/googletest/include")
+ endif (BUILD_RESONANCE_AUDIO_TESTS OR BUILD_GEOMETRICAL_ACOUSTICS_TESTS)
+
+-if (WIN32)
++if (WIN32 AND NOT MINGW)
+ add_definitions(-D_USE_MATH_DEFINES)
+ add_definitions(-DNOMINMAX)
+ # Disable type conversion warnings.
+@@ -92,7 +92,7 @@ if (WIN32)
+ elseif (APPLE)
+ elseif (ANDROID)
+ set(NEON ON)
+-elseif (UNIX)
++elseif (UNIX OR MINGW)
+ set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+ set(CMAKE_CXX_FLAGS "-fPIC -O3 -Wno-vla -msse -msse2 -msse3 -mfpmath=sse")
+ endif ()
+--
+2.40.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 291db55f3b89..c7b2af517f00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-multimedia
-_qtver=6.3.2
+_qtver=6.5.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -17,16 +17,38 @@ makedepends=('mingw-w64-cmake' 'mingw-w64-qt6-declarative' 'mingw-w64-qt6-shader
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qtmultimedia-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('7f6829aa4509e23a9804260b6d859531b20a806c4dadedfd2c0c7dd314c01c43')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Fix-compile-flags-of-resonance-audio-for-mingw-w64.patch')
+sha256sums=('9480d0c73abdd01aec4899e340938cec046a3f404b9f9ed945288be574dca146'
+ 'fa134d80bd74c32839407ec348424b55daf251899e5056adb024bad194e02482')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+ # work around case-insensitive includes on case-sensitive filesystems
+ sed -i'' 's/\(.*\) \(Mf.*\|Propsys\) HINTS \(.*\)/\1 \L\2 HINTS \3/g' cmake/FindWMF.cmake
+ find src -type f -exec sed -i'' 's/#include <\(Dbt.*\|InitGuid.*\|Mf.*\|Wmcodec.*\|Functiondiscoverykeys_devpkey.*\)>/#include <\L\1>/g' {} \;
+ find src -type f -exec sed -i'' 's/#include "\(Dbt.*\|InitGuid.*\|Mf.*\|Wmcodec.*\|QUrl.*\)"/#include "\L\1"/g' {} \;
+}
+
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
$_arch-cmake -G Ninja -B build-$_arch -S $_pkgfqn \
- -DFEATURE_pkg_config=ON
+ -DFEATURE_pkg_config=ON \
+ -DFEATURE_wmsdk=ON \
+ -DFEATURE_ffmpeg=OFF \
+ -DFEATURE_gstreamer=OFF
+ # note: Enable Windows Media SDK as it is not optional (disabling it would lead to build errors).
+ # Unfortunately it doesn't build as well (maybe it would using a newer mingw-w64 version).
+ # Disabling ffmpeg and gstreamer at this point explicitly due to lack of testing.
cmake --build build-$_arch
done
}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index f5e2e75ec214..fcb1375a3123 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt6-module';
\
-_qtver=6.3.2
+_qtver=6.5.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -10,3 +10,19 @@ pkgdesc='Classes for audio, video, radio and camera functionality (mingw-w64)'
depends=(<%== qt6deps qw(base) %>)
optdepends=(<%== qt6optdeps declarative => 'QML bindings' %>)
makedepends=('mingw-w64-cmake<%== $static_suffix %>' <%== qt6deps qw(declarative shadertools) %> 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'qt6-shadertools' 'ninja')
+% \
+% content_for additional_cmake_args => begin
+ \\
+ -DFEATURE_wmsdk=ON \\
+ -DFEATURE_ffmpeg=OFF \\
+ -DFEATURE_gstreamer=OFF
+ # note: Enable Windows Media SDK as it is not optional (disabling it would lead to build errors).
+ # Unfortunately it doesn't build as well (maybe it would using a newer mingw-w64 version).
+ # Disabling ffmpeg and gstreamer at this point explicitly due to lack of testing.\
+% end
+% content_for prepare => begin
+ # work around case-insensitive includes on case-sensitive filesystems
+ sed -i'' 's/\(.*\) \(Mf.*\|Propsys\) HINTS \(.*\)/\1 \L\2 HINTS \3/g' cmake/FindWMF.cmake
+ find src -type f -exec sed -i'' 's/#include <\(Dbt.*\|InitGuid.*\|Mf.*\|Wmcodec.*\|Functiondiscoverykeys_devpkey.*\)>/#include <\L\1>/g' {} \;
+ find src -type f -exec sed -i'' 's/#include "\(Dbt.*\|InitGuid.*\|Mf.*\|Wmcodec.*\|QUrl.*\)"/#include "\L\1"/g' {} \;
+%end
diff --git a/qtmultimedia-sha256.txt b/qtmultimedia-sha256.txt
index b67e17f39a27..8a80eee7d813 100644
--- a/qtmultimedia-sha256.txt
+++ b/qtmultimedia-sha256.txt
@@ -1 +1 @@
-7f6829aa4509e23a9804260b6d859531b20a806c4dadedfd2c0c7dd314c01c43
+9480d0c73abdd01aec4899e340938cec046a3f404b9f9ed945288be574dca146