summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-05-08 14:32:36 +0200
committerMartchus2021-05-08 14:32:36 +0200
commit23c22f447107e07977fe0ad4ef9c1dc1b72915ab (patch)
tree8825531f162e67ac7d40d608a57d14152fd2b8b9
downloadaur-23c22f447107e07977fe0ad4ef9c1dc1b72915ab.tar.gz
Update to 6.1.0
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD49
-rw-r--r--PKGBUILD.sh.ep1
-rw-r--r--qtnetworkauth-sha256.txt1
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12e35831a0bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mingw-w64-qt6-networkauth-static
+ pkgdesc = Network authentication module (mingw-w64)
+ pkgver = 6.1.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = mingw-w64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-cmake-static
+ makedepends = qt6-base
+ makedepends = ninja
+ depends = mingw-w64-qt6-base-static
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/official_releases/qt/6.1/6.1.0/submodules/qtnetworkauth-everywhere-src-6.1.0.tar.xz
+ sha256sums = bae8a941e4b635a364bdc65ea814adfe75b20b06fce0888612f72fc1e81ebdd3
+
+pkgname = mingw-w64-qt6-networkauth-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2332de2373d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=mingw-w64-qt6-networkauth-static
+_qtver=6.1.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Network authentication module (mingw-w64)'
+depends=('mingw-w64-qt6-base-static')
+makedepends=('mingw-w64-cmake-static' 'qt6-base' 'ninja')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(mingw-w64-qt6)
+_pkgfqn="qtnetworkauth-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('bae8a941e4b635a364bdc65ea814adfe75b20b06fce0888612f72fc1e81ebdd3')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+build() {
+ for _arch in ${_architectures}; do
+ export PKG_CONFIG=/usr/bin/$_arch-pkg-config
+ $_arch-cmake-static -G Ninja -B build-$_arch -S $_pkgfqn \
+ -DCMAKE_INSTALL_PREFIX:PATH="/usr/$_arch/static" \
+ -DFEATURE_static_runtime=ON \
+ -DFEATURE_pkg_config=ON
+ cmake --build build-$_arch
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" cmake --install build-$_arch
+
+ find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/static/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/static/share/doc"
+ done
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/mingw-w64-qt6-base-static "$pkgdir"/usr/share/licenses/$pkgname
+
+}
+
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..87756da456f4
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1 @@
+%= include "$default_package_name/mingw-w64/PKGBUILD";
diff --git a/qtnetworkauth-sha256.txt b/qtnetworkauth-sha256.txt
new file mode 100644
index 000000000000..fc0658fe9319
--- /dev/null
+++ b/qtnetworkauth-sha256.txt
@@ -0,0 +1 @@
+bae8a941e4b635a364bdc65ea814adfe75b20b06fce0888612f72fc1e81ebdd3