summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-10-13 11:10:07 +0200
committerMartchus2020-10-13 11:10:07 +0200
commit262b03a4baa3ff48edaef2a38948e944df343b5b (patch)
tree96ed0b9b290d9a3148600f3ead1752fe328efe7e
downloadaur-262b03a4baa3ff48edaef2a38948e944df343b5b.tar.gz
Initial import (alpha)
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD57
-rw-r--r--PKGBUILD.sh.ep11
-rw-r--r--qtquickcontrols2-sha256.txt1
4 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e5b793a1c7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mingw-w64-qt6-quickcontrols2
+ pkgdesc = Next generation user interface controls based on Qt Quick (mingw-w64)
+ pkgver = 6.0.0alpha
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = mingw-w64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-vulkan-headers
+ makedepends = mingw-w64-vulkan-icd-loader
+ makedepends = qt6-declarative
+ makedepends = ninja
+ depends = mingw-w64-qt6-declarative
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/development_releases/qt/6.0/6.0.0-alpha/submodules/qtquickcontrols2-everywhere-src-6.0.0-alpha.tar.xz
+ sha256sums = 2cf6c41075154e6dd92864f1ce95b58c3da35b4bb171a8fdc48cafb1802a3e00
+
+pkgname = mingw-w64-qt6-quickcontrols2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aeaebbe5b94f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=mingw-w64-qt6-quickcontrols2
+_qtver=6.0.0-alpha
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Next generation user interface controls based on Qt Quick (mingw-w64)'
+depends=('mingw-w64-qt6-declarative')
+makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'ninja')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(mingw-w64-qt6)
+_pkgfqn="qtquickcontrols2-everywhere-src-${_qtver}"
+source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('2cf6c41075154e6dd92864f1ce95b58c3da35b4bb171a8fdc48cafb1802a3e00')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+build() {
+ for _arch in ${_architectures}; do
+ export PKG_CONFIG=/usr/bin/$_arch-pkg-config
+ $_arch-cmake -G Ninja -B build-$_arch -S $_pkgfqn \
+ -DQT_HOST_PATH=/usr \
+ -DFEATURE_pkg_config=ON \
+ -DVulkan_LIBRARY="/usr/$_arch/lib/libvulkan.dll.a" \
+ -DVulkan_INCLUDE_DIR="/usr/$_arch/include"
+ cmake --build build-$_arch
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" cmake --install build-$_arch
+
+ # Add symlinks of DLLs in usual bin directory
+ mkdir -p "$pkgdir/usr/bin" "$pkgdir/usr/$_arch/bin"
+ for dll in "$pkgdir"/usr/$_arch/lib/qt6/bin/*.dll; do
+ ln -rs "$dll" "$pkgdir/usr/$_arch/bin/${dll##*/}"
+ done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/$_arch/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ done
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/mingw-w64-qt6-base "$pkgdir"/usr/share/licenses/mingw-w64-qt6-quickcontrols2
+}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..6c466022c07b
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1,11 @@
+% layout 'mingw-w64-qt6-module';
+\
+_qtver=6.0.0-alpha
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Next generation user interface controls based on Qt Quick (mingw-w64)'
+depends=(<%== qt6deps qw(declarative) %>)
+makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'ninja')
diff --git a/qtquickcontrols2-sha256.txt b/qtquickcontrols2-sha256.txt
new file mode 100644
index 000000000000..25573110de6c
--- /dev/null
+++ b/qtquickcontrols2-sha256.txt
@@ -0,0 +1 @@
+2cf6c41075154e6dd92864f1ce95b58c3da35b4bb171a8fdc48cafb1802a3e00