summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2023-11-30 11:05:03 +0100
committerMartchus2023-11-30 11:05:03 +0100
commit0f73c34225fe22ddc02acba1e1b170cf39450b9f (patch)
treec585a728ccc14becc6ca450c2c8798c83fb11dee
parenteb5489687e91658d2c1bdb3b1932b9ecd97305ed (diff)
downloadaur-0f73c34225fe22ddc02acba1e1b170cf39450b9f.tar.gz
Update to 6.6.1
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix-nullptr-dereference-with-invalid-SVG.patch29
-rw-r--r--PKGBUILD20
-rw-r--r--PKGBUILD.sh.ep4
-rw-r--r--qtsvg-sha256.txt2
5 files changed, 11 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b23f77f4f04f..239ca8a2c6c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-qt6-svg
pkgdesc = Classes for displaying the contents of SVG files (mingw-w64)
- pkgver = 6.6.0
- pkgrel = 2
+ pkgver = 6.6.1
+ pkgrel = 1
url = https://www.qt.io
arch = any
groups = mingw-w64-qt6
@@ -17,9 +17,7 @@ pkgbase = mingw-w64-qt6-svg
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.6/6.6.0/submodules/qtsvg-everywhere-src-6.6.0.tar.xz
- source = 0001-Fix-nullptr-dereference-with-invalid-SVG.patch
- sha256sums = 33da25fef51102f564624a7ea3e57cb4a0a31b7b44783d1af5749ac36d3c72de
- sha256sums = 83f59c72773071df6adca9c0f6f457a460bd63a4d2b85f1e0df9cabf6b1c55e9
+ source = https://download.qt.io/official_releases/qt/6.6/6.6.1/submodules/qtsvg-everywhere-src-6.6.1.tar.xz
+ sha256sums = 248deb56d26a463cf3162f530358ccf90cfb654bbf518bb35ddf81b205e09228
pkgname = mingw-w64-qt6-svg
diff --git a/0001-Fix-nullptr-dereference-with-invalid-SVG.patch b/0001-Fix-nullptr-dereference-with-invalid-SVG.patch
deleted file mode 100644
index 3b84eb4bf691..000000000000
--- a/0001-Fix-nullptr-dereference-with-invalid-SVG.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 50aaab95b65433a6a8ed616c6f473ca12389e3f0 Mon Sep 17 00:00:00 2001
-From: Paul Olav Tvete <paul.tvete@qt.io>
-Date: Tue, 10 Oct 2023 10:14:22 +0200
-Subject: [PATCH] Fix nullptr dereference with invalid SVG
-
-Fixes: QTBUG-117944
-Pick-to: 6.6 6.5 6.2
-Change-Id: I9059dc28c750fc0585f1fb982152b211c323c6cd
-Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@qt.io>
----
- src/svg/qsvghandler.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/svg/qsvghandler.cpp b/src/svg/qsvghandler.cpp
-index 2649422..335500a 100644
---- a/src/svg/qsvghandler.cpp
-+++ b/src/svg/qsvghandler.cpp
-@@ -3606,6 +3606,8 @@ void QSvgHandler::init()
-
- static bool detectCycles(const QSvgNode *node, QList<const QSvgUse *> active = {})
- {
-+ if (Q_UNLIKELY(!node))
-+ return false;
- switch (node->type()) {
- case QSvgNode::DOC:
- case QSvgNode::G:
---
-2.42.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 99296769d964..8f128c9ec364 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-svg
-_qtver=6.6.0
+_qtver=6.6.1
pkgver=${_qtver/-/}
-pkgrel=2
+pkgrel=1
arch=(any)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@@ -16,23 +16,11 @@ makedepends=('mingw-w64-cmake' 'qt6-base' 'ninja')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qtsvg-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
- '0001-Fix-nullptr-dereference-with-invalid-SVG.patch')
-sha256sums=('33da25fef51102f564624a7ea3e57cb4a0a31b7b44783d1af5749ac36d3c72de'
- '83f59c72773071df6adca9c0f6f457a460bd63a4d2b85f1e0df9cabf6b1c55e9')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('248deb56d26a463cf3162f530358ccf90cfb654bbf518bb35ddf81b205e09228')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-prepare () {
- cd $_pkgfqn
-
- # apply patches; further descriptions can be found in patch files itself
- for patch in "$srcdir/"*.patch; do
- msg2 "Applying patch $patch"
- patch -p1 -i "$patch"
- done
-}
-
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 919d93b6c5ba..8ad286f6ee7e 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,8 +1,8 @@
% layout 'mingw-w64-qt6-module';
\
-_qtver=6.6.0
+_qtver=6.6.1
pkgver=${_qtver/-/}
-pkgrel=2
+pkgrel=1
arch=(any)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
diff --git a/qtsvg-sha256.txt b/qtsvg-sha256.txt
index 58c20fe592b1..f240935650e1 100644
--- a/qtsvg-sha256.txt
+++ b/qtsvg-sha256.txt
@@ -1 +1 @@
-33da25fef51102f564624a7ea3e57cb4a0a31b7b44783d1af5749ac36d3c72de
+248deb56d26a463cf3162f530358ccf90cfb654bbf518bb35ddf81b205e09228