summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2024-10-08 23:10:40 +0200
committerMartchus2024-10-08 23:10:40 +0200
commit5eeb7174b1f8f2bc856855f1a7928af2a71c1f7b (patch)
treed6998940a751ca4efb4dcc3fce930d8a0739f956
parentfc217451486008220fa0187d1d6a871f740d6a62 (diff)
downloadaur-5eeb7174b1f8f2bc856855f1a7928af2a71c1f7b.tar.gz
Update to 6.8.0
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Enable-only-SQL-plugins-which-are-known-to-work.patch8
-rw-r--r--PKGBUILD6
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qttools-sha256.txt2
5 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6565453c7c40..c8a5c006d11b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-tools
pkgdesc = A cross-platform application and UI framework (tools, mingw-w64)
- pkgver = 6.7.3
+ pkgver = 6.8.0
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -21,9 +21,9 @@ pkgbase = mingw-w64-qt6-tools
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.7/6.7.3/submodules/qttools-everywhere-src-6.7.3.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.8/6.8.0/submodules/qttools-everywhere-src-6.8.0.tar.xz
source = 0001-Enable-only-SQL-plugins-which-are-known-to-work.patch
- sha256sums = f03bb7df619cd9ac9dba110e30b7bcab5dd88eb8bdc9cc752563b4367233203f
- sha256sums = 270e410cf6942eb6ad9f278b89442849e3425b574f4299ffd7d8d51073a649c5
+ sha256sums = 403115d8268503c6cc6e43310c8ae28eb9e605072a5d04e4a2de8b6af39981f7
+ sha256sums = dcc695dd98d53daa715f3a7a9bfded88ff33f7656ed3f52bdfe0d794c58f8b7d
pkgname = mingw-w64-qt6-tools
diff --git a/0001-Enable-only-SQL-plugins-which-are-known-to-work.patch b/0001-Enable-only-SQL-plugins-which-are-known-to-work.patch
index 6a2f065d58a5..aecca1ea61fb 100644
--- a/0001-Enable-only-SQL-plugins-which-are-known-to-work.patch
+++ b/0001-Enable-only-SQL-plugins-which-are-known-to-work.patch
@@ -1,4 +1,4 @@
-From 31598d6b3f071da0090a737e954649214853da4d Mon Sep 17 00:00:00 2001
+From 11faf0e97aa396c5436aa11b0d707f7fffd2ba50 Mon Sep 17 00:00:00 2001
From: Martchus <martchus@gmx.net>
Date: Wed, 9 Jun 2021 17:25:27 +0200
Subject: [PATCH] Enable only SQL plugins which are known to work
@@ -9,10 +9,10 @@ Change-Id: I0abc44db77cecbd323edc936529fb557e1664de8
1 file changed, 8 insertions(+)
diff --git a/src/assistant/assistant/CMakeLists.txt b/src/assistant/assistant/CMakeLists.txt
-index 10df7f777..3a2b677c5 100644
+index 2cefb3bfd..cf4af1707 100644
--- a/src/assistant/assistant/CMakeLists.txt
+++ b/src/assistant/assistant/CMakeLists.txt
-@@ -154,6 +154,14 @@ qt_internal_extend_target(assistant CONDITION UNIX
+@@ -156,6 +156,14 @@ qt_internal_extend_target(assistant CONDITION UNIX
stdinlistener.cpp stdinlistener.h
)
@@ -28,5 +28,5 @@ index 10df7f777..3a2b677c5 100644
set_target_properties(assistant PROPERTIES
MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info_mac.plist"
--
-2.46.2
+2.47.0
diff --git a/PKGBUILD b/PKGBUILD
index b8ea75717276..fa7b75faa0a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-tools
-_qtver=6.7.3
+_qtver=6.8.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -18,8 +18,8 @@ groups=(mingw-w64-qt6)
_pkgfqn="qttools-everywhere-src-${_qtver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
'0001-Enable-only-SQL-plugins-which-are-known-to-work.patch')
-sha256sums=('f03bb7df619cd9ac9dba110e30b7bcab5dd88eb8bdc9cc752563b4367233203f'
- '270e410cf6942eb6ad9f278b89442849e3425b574f4299ffd7d8d51073a649c5')
+sha256sums=('403115d8268503c6cc6e43310c8ae28eb9e605072a5d04e4a2de8b6af39981f7'
+ 'dcc695dd98d53daa715f3a7a9bfded88ff33f7656ed3f52bdfe0d794c58f8b7d')
_architectures=${MINGW_W64_QT6_ARCHS:-x86_64-w64-mingw32}
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index c32bac8983cb..aa3d7d7f380b 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt6-module', has_binaries => 1;
\
-_qtver=6.7.3
+_qtver=6.8.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
index f581afd5ce19..5cc4673e56cb 100644
--- a/qttools-sha256.txt
+++ b/qttools-sha256.txt
@@ -1 +1 @@
-f03bb7df619cd9ac9dba110e30b7bcab5dd88eb8bdc9cc752563b4367233203f
+403115d8268503c6cc6e43310c8ae28eb9e605072a5d04e4a2de8b6af39981f7