summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-11-08 20:26:10 +0100
committerMartchus2020-11-08 20:26:10 +0100
commit6f1d328aa26dedb0696d03d824ac179bf1b48241 (patch)
treebd0a4f7bf473374149d8f32d02e59d707a3d912d
parenta250d8a60e68665df74241b9889ff08f563435ce (diff)
downloadaur-6f1d328aa26dedb0696d03d824ac179bf1b48241.tar.gz
Add static mingw-w64-qt6-* packages
-rw-r--r--.SRCINFO2
-rw-r--r--0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch25
-rw-r--r--PKGBUILD16
-rw-r--r--PKGBUILD.sh.ep2
4 files changed, 42 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36124ef7d091..db94186a82f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,7 +22,9 @@ pkgbase = mingw-w64-qt6-tools
options = staticlibs
options = !emptydirs
source = https://download.qt.io/development_releases/qt/6.0/6.0.0-beta3/submodules/qttools-everywhere-src-6.0.0-beta3.tar.xz
+ source = 0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch
sha256sums = 8409de28939c79dc3eb2d1bb8bac085f35f3dcc35df107633b474733aa33bba8
+ sha256sums = 03ed0cf3fb604d773cae1de19c862e65e8a44a8245db0bfba750557e541f5620
pkgname = mingw-w64-qt6-tools
diff --git a/0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch b/0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch
new file mode 100644
index 000000000000..0ce2aad99483
--- /dev/null
+++ b/0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch
@@ -0,0 +1,25 @@
+From 60a7db7b539515ba8f0fcff6cbc31435797f4b86 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sun, 8 Nov 2020 17:10:15 +0100
+Subject: [PATCH] windeployqt: Fix name of qt6CoreName variable
+
+---
+ src/windeployqt/main.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/windeployqt/main.cpp b/src/windeployqt/main.cpp
+index 21321457..1b331024 100644
+--- a/src/windeployqt/main.cpp
++++ b/src/windeployqt/main.cpp
+@@ -1461,7 +1461,7 @@ static DeployResult deploy(const Options &options,
+ }
+
+ if (options.patchQt && !options.dryRun) {
+- const QString qt5CoreName = QFileInfo(libraryPath(libraryLocation, "Qt6Core", qtLibInfix,
++ const QString qt6CoreName = QFileInfo(libraryPath(libraryLocation, "Qt6Core", qtLibInfix,
+ options.platform, result.isDebug)).fileName();
+ #ifndef QT_RELOCATABLE
+ if (!patchQtCore(targetPath + QLatin1Char('/') + qt6CoreName, errorMessage)) {
+--
+2.29.2
+
diff --git a/PKGBUILD b/PKGBUILD
index a6816b90d18f..e63644698870 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,11 +16,23 @@ makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qttools-everywhere-src-${_qtver}"
-source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('8409de28939c79dc3eb2d1bb8bac085f35f3dcc35df107633b474733aa33bba8')
+source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch')
+sha256sums=('8409de28939c79dc3eb2d1bb8bac085f35f3dcc35df107633b474733aa33bba8'
+ '03ed0cf3fb604d773cae1de19c862e65e8a44a8245db0bfba750557e541f5620')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 49073c01d47f..fc5906e27a1f 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -8,4 +8,4 @@ url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='A cross-platform application and UI framework (tools, mingw-w64)'
depends=(<%== qt6deps qw(base) %>)
-makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' <%== qt6deps qw(declarative) %> 'qt6-declarative' 'qt6-tools' 'ninja')
+makedepends=('mingw-w64-cmake<%== $static_suffix %>' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' <%== qt6deps qw(declarative) %> 'qt6-declarative' 'qt6-tools' 'ninja')