summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-06-10 15:43:08 +0200
committerMartchus2021-06-10 15:43:08 +0200
commit92e6ae84f0491ad842ce4db9377e205242f1cfca (patch)
tree32476f441592ec37efbeb520e333e5e0ea7b5323
parente805eab0aa1e1da173a3475ee3c1be2cc2ac7b82 (diff)
downloadaur-92e6ae84f0491ad842ce4db9377e205242f1cfca.tar.gz
Update to 6.1.1
-rw-r--r--.SRCINFO9
-rw-r--r--0001-Enable-only-SQL-plugins-which-are-known-to-work.patch32
-rw-r--r--PKGBUILD18
-rw-r--r--PKGBUILD.sh.ep2
-rw-r--r--qttools-sha256.txt2
5 files changed, 54 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a374a3e124a..d45a75211727 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-tools
pkgdesc = A cross-platform application and UI framework (tools, mingw-w64)
- pkgver = 6.1.0
+ pkgver = 6.1.1
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -21,8 +21,9 @@ pkgbase = mingw-w64-qt6-tools
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.1/6.1.0/submodules/qttools-everywhere-src-6.1.0.tar.xz
- sha256sums = 6263030c1120a30b0541d37b52dc0be0ea04bbb8d1695ec9648f0bd77e421f3e
+ source = https://download.qt.io/official_releases/qt/6.1/6.1.1/submodules/qttools-everywhere-src-6.1.1.tar.xz
+ source = 0001-Enable-only-SQL-plugins-which-are-known-to-work.patch
+ sha256sums = cba8d9a836e83b7a5e6d068239635b261f7ca4a059992b2b66cd546380091273
+ sha256sums = 7254956e64929072ab0dae3aa14ad392eaceb070a7c02da75b3f3c770b1f7cfa
pkgname = mingw-w64-qt6-tools
-
diff --git a/0001-Enable-only-SQL-plugins-which-are-known-to-work.patch b/0001-Enable-only-SQL-plugins-which-are-known-to-work.patch
new file mode 100644
index 000000000000..09edac7d029f
--- /dev/null
+++ b/0001-Enable-only-SQL-plugins-which-are-known-to-work.patch
@@ -0,0 +1,32 @@
+From 12f2659035f73cf4a405c4a185978c74291b8e85 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Wed, 9 Jun 2021 17:25:27 +0200
+Subject: [PATCH] Enable only SQL plugins which are known to work
+
+Change-Id: I0abc44db77cecbd323edc936529fb557e1664de8
+---
+ src/assistant/assistant/CMakeLists.txt | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/src/assistant/assistant/CMakeLists.txt b/src/assistant/assistant/CMakeLists.txt
+index eb5a04a0..5b28ae65 100644
+--- a/src/assistant/assistant/CMakeLists.txt
++++ b/src/assistant/assistant/CMakeLists.txt
+@@ -173,6 +173,14 @@ qt_internal_extend_target(assistant CONDITION UNIX
+ stdinlistener.cpp stdinlistener.h
+ )
+
++if(MINGW)
++ # enable only SQL plugins which are known to work
++ # note: The static plugins for MySQL/PostgreSQL don't work because these libs come with their
++ # own pthread implementation which has conflicting symbols with the normal pthread library
++ # leading to linker errors.
++ qt_import_plugins(assistant INCLUDE_BY_TYPE sqldrivers Qt6::QSQLiteDriverPlugin Qt6::QODBCDriverPlugin)
++endif()
++
+ if(APPLE)
+ set_target_properties(assistant PROPERTIES
+ MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info_mac.plist"
+--
+2.32.0
+
diff --git a/PKGBUILD b/PKGBUILD
index c6ab422a6b70..585befad5e86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-tools
-_qtver=6.1.0
+_qtver=6.1.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -16,11 +16,23 @@ makedepends=('mingw-w64-cmake' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qttools-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('6263030c1120a30b0541d37b52dc0be0ea04bbb8d1695ec9648f0bd77e421f3e')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Enable-only-SQL-plugins-which-are-known-to-work.patch')
+sha256sums=('cba8d9a836e83b7a5e6d068239635b261f7ca4a059992b2b66cd546380091273'
+ '7254956e64929072ab0dae3aa14ad392eaceb070a7c02da75b3f3c770b1f7cfa')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
index 54ca499c44cf..23c238f56db6 100644
--- a/PKGBUILD.sh.ep
+++ b/PKGBUILD.sh.ep
@@ -1,6 +1,6 @@
% layout 'mingw-w64-qt6-module', has_binaries => 1;
\
-_qtver=6.1.0
+_qtver=6.1.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
index 956a1496011d..0ceec92b21f2 100644
--- a/qttools-sha256.txt
+++ b/qttools-sha256.txt
@@ -1 +1 @@
-6263030c1120a30b0541d37b52dc0be0ea04bbb8d1695ec9648f0bd77e421f3e
+cba8d9a836e83b7a5e6d068239635b261f7ca4a059992b2b66cd546380091273