summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-02-05 22:21:36 +0100
committerMartchus2021-02-05 22:21:36 +0100
commit622407d1a260f5e7f7dba2bbf956c1f79127b0dd (patch)
tree24a343f4879c4f4b443cee36995c6a6d207a8aa1
parent39f8d9073c535de0129fe1e8a97c1356ad2e931b (diff)
downloadaur-622407d1a260f5e7f7dba2bbf956c1f79127b0dd.tar.gz
Update to 6.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Make-windeployqt-an-optional-feature.patch26
-rw-r--r--PKGBUILD20
-rw-r--r--qttools-sha256.txt2
4 files changed, 9 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1769ff3dc57f..c1179769796d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-tools-static
pkgdesc = A cross-platform application and UI framework (tools, mingw-w64)
- pkgver = 6.0.0
+ pkgver = 6.0.1
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -21,10 +21,8 @@ pkgbase = mingw-w64-qt6-tools-static
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.0/6.0.0/submodules/qttools-everywhere-src-6.0.0.tar.xz
- source = 0001-Make-windeployqt-an-optional-feature.patch
- sha256sums = b6dc559db447bf394d09dfb238d5c09108f834139a183888179e855c6566bfae
- sha256sums = f316cdb87dcc84d1fe9ebd262812118e35571aa0fadd3da6ac3b9f42af19b8bb
+ source = https://download.qt.io/official_releases/qt/6.0/6.0.1/submodules/qttools-everywhere-src-6.0.1.tar.xz
+ sha256sums = dc354358f7d2ed56d17190f4ad7e3fc3ad88185be1eb74b9132b8b66185c349f
pkgname = mingw-w64-qt6-tools-static
diff --git a/0001-Make-windeployqt-an-optional-feature.patch b/0001-Make-windeployqt-an-optional-feature.patch
deleted file mode 100644
index 76a8d8dbd889..000000000000
--- a/0001-Make-windeployqt-an-optional-feature.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 007674dc717498f33a8e30a558e8d6560369a0fd Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Thu, 26 Nov 2020 01:53:27 +0100
-Subject: [PATCH] Make windeployqt an optional feature
-
-Change-Id: I3c797df913c07ed80929b41d367b1ebb41d8400f
----
- src/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index 770f1cab..d5d34064 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -51,7 +51,7 @@ endif()
- if(TARGET Qt::DBus)
- add_subdirectory(qdbus)
- endif()
--if(WIN32)
-+if(QT_FEATURE_windeployqt)
- add_subdirectory(windeployqt)
- endif()
- if(QT_FEATURE_commandlineparser AND TARGET Qt::Gui AND NOT ANDROID AND NOT QNX AND NOT UIKIT AND NOT WASM)
---
-2.29.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 032dd5a0023e..d2037ea586d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-tools-static
-_qtver=6.0.0
+_qtver=6.0.1
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -16,28 +16,17 @@ makedepends=('mingw-w64-cmake-static' 'mingw-w64-vulkan-headers' 'mingw-w64-vulk
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qttools-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
- '0001-Make-windeployqt-an-optional-feature.patch')
-sha256sums=('b6dc559db447bf394d09dfb238d5c09108f834139a183888179e855c6566bfae'
- 'f316cdb87dcc84d1fe9ebd262812118e35571aa0fadd3da6ac3b9f42af19b8bb')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('dc354358f7d2ed56d17190f4ad7e3fc3ad88185be1eb74b9132b8b66185c349f')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-prepare () {
- cd $_pkgfqn
-
- # apply patches; further descriptions can be found in patch files itself
- for patch in "$srcdir/"*.patch; do
- msg2 "Applying patch $patch"
- patch -p1 -i "$patch"
- done
-}
-
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
$_arch-cmake-static -G Ninja -B build-$_arch -S $_pkgfqn \
-DCMAKE_INSTALL_PREFIX:PATH="/usr/$_arch/static" \
+ -DFEATURE_static_runtime=ON \
-DFEATURE_pkg_config=ON \
-DFEATURE_windeployqt=OFF
cmake --build build-$_arch
@@ -51,6 +40,7 @@ package() {
find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/static/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/static/share/doc"
done
install -d "$pkgdir"/usr/share/licenses
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
index 253cf3ba23b1..a80646fd63a6 100644
--- a/qttools-sha256.txt
+++ b/qttools-sha256.txt
@@ -1 +1 @@
-b6dc559db447bf394d09dfb238d5c09108f834139a183888179e855c6566bfae
+dc354358f7d2ed56d17190f4ad7e3fc3ad88185be1eb74b9132b8b66185c349f