summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-11-26 13:21:54 +0100
committerMartchus2020-11-26 13:21:54 +0100
commitf441107097d38439d6ae031a717146285b348957 (patch)
treedbf5f7f2d63bbaea6b3f7e7e6c17784bb875ab17
parentae2ec95364eeb396f36fbde63b003f2516baf13e (diff)
downloadaur-f441107097d38439d6ae031a717146285b348957.tar.gz
Update to rc
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Make-windeployqt-an-optional-feature.patch26
-rw-r--r--0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch25
-rw-r--r--PKGBUILD11
-rw-r--r--qttools-sha256.txt2
5 files changed, 38 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28e09ac426aa..fb1429c9678e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-tools-static
pkgdesc = A cross-platform application and UI framework (tools, mingw-w64)
- pkgver = 6.0.0beta4
+ pkgver = 6.0.0rc
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -21,10 +21,10 @@ pkgbase = mingw-w64-qt6-tools-static
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/development_releases/qt/6.0/6.0.0-beta4/submodules/qttools-everywhere-src-6.0.0-beta4.tar.xz
- source = 0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch
- sha256sums = cd15384ed635fc9efa0f5f6679040082f138f28748a17f65b4b415a3d2e639ca
- sha256sums = 1f428c44520364d9a0dd03c4f017739fcaccec13a6800e69183c08c91a8d2f57
+ source = https://download.qt.io/development_releases/qt/6.0/6.0.0-rc/submodules/qttools-everywhere-src-6.0.0-rc.tar.xz
+ source = 0001-Make-windeployqt-an-optional-feature.patch
+ sha256sums = 6fe789cf7e1abc7f0ac39027c53e7880433425b234d448d1500e583e9c3ba498
+ sha256sums = 5655e188088c8345ba3aed72c74d98800d270bc65f9298676eeb40e3796d17c8
pkgname = mingw-w64-qt6-tools-static
diff --git a/0001-Make-windeployqt-an-optional-feature.patch b/0001-Make-windeployqt-an-optional-feature.patch
new file mode 100644
index 000000000000..34b85d1c4c07
--- /dev/null
+++ b/0001-Make-windeployqt-an-optional-feature.patch
@@ -0,0 +1,26 @@
+From adbcd437ab61010cec31a3e52a1fd0b7e772173f Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Thu, 26 Nov 2020 01:53:27 +0100
+Subject: [PATCH] Make windeployqt an optional feature
+
+Change-Id: I3c797df913c07ed80929b41d367b1ebb41d8400f
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 770f1cab..d5d34064 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -51,7 +51,7 @@ endif()
+ if(TARGET Qt::DBus)
+ add_subdirectory(qdbus)
+ endif()
+-if(WIN32)
++if(QT_FEATURE_windeployqt)
+ add_subdirectory(windeployqt)
+ endif()
+ if(QT_FEATURE_commandlineparser AND TARGET Qt::Gui AND NOT ANDROID AND NOT QNX AND NOT UIKIT AND NOT WASM)
+--
+2.29.2
+
diff --git a/0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch b/0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch
deleted file mode 100644
index e58ef2aa9c9e..000000000000
--- a/0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From b675d7e907c0a0cd415322879fa1738e5f7323c8 Mon Sep 17 00:00:00 2001
-From: Martchus <martchus@gmx.net>
-Date: Sun, 8 Nov 2020 17:10:15 +0100
-Subject: [PATCH] windeployqt: Fix name of qt6CoreName variable
-
----
- src/windeployqt/main.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/windeployqt/main.cpp b/src/windeployqt/main.cpp
-index 21321457..1b331024 100644
---- a/src/windeployqt/main.cpp
-+++ b/src/windeployqt/main.cpp
-@@ -1461,7 +1461,7 @@ static DeployResult deploy(const Options &options,
- }
-
- if (options.patchQt && !options.dryRun) {
-- const QString qt5CoreName = QFileInfo(libraryPath(libraryLocation, "Qt6Core", qtLibInfix,
-+ const QString qt6CoreName = QFileInfo(libraryPath(libraryLocation, "Qt6Core", qtLibInfix,
- options.platform, result.isDebug)).fileName();
- #ifndef QT_RELOCATABLE
- if (!patchQtCore(targetPath + QLatin1Char('/') + qt6CoreName, errorMessage)) {
---
-2.29.2
-
diff --git a/PKGBUILD b/PKGBUILD
index 9f62ecf94a0f..36a19b9d4201 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-tools-static
-_qtver=6.0.0-beta4
+_qtver=6.0.0-rc
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -17,9 +17,9 @@ options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qttools-everywhere-src-${_qtver}"
source=("https://download.qt.io/development_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
- '0001-windeployqt-Fix-name-of-qt6CoreName-variable.patch')
-sha256sums=('cd15384ed635fc9efa0f5f6679040082f138f28748a17f65b4b415a3d2e639ca'
- '1f428c44520364d9a0dd03c4f017739fcaccec13a6800e69183c08c91a8d2f57')
+ '0001-Make-windeployqt-an-optional-feature.patch')
+sha256sums=('6fe789cf7e1abc7f0ac39027c53e7880433425b234d448d1500e583e9c3ba498'
+ '5655e188088c8345ba3aed72c74d98800d270bc65f9298676eeb40e3796d17c8')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
@@ -38,7 +38,8 @@ build() {
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
$_arch-cmake-static -G Ninja -B build-$_arch -S $_pkgfqn \
-DCMAKE_INSTALL_PREFIX:PATH="/usr/$_arch/static" \
- -DFEATURE_pkg_config=ON
+ -DFEATURE_pkg_config=ON \
+ -DFEATURE_windeployqt=OFF
cmake --build build-$_arch
done
}
diff --git a/qttools-sha256.txt b/qttools-sha256.txt
index 2038fb6c4deb..20ac2b90ea0a 100644
--- a/qttools-sha256.txt
+++ b/qttools-sha256.txt
@@ -1 +1 @@
-cd15384ed635fc9efa0f5f6679040082f138f28748a17f65b4b415a3d2e639ca
+6fe789cf7e1abc7f0ac39027c53e7880433425b234d448d1500e583e9c3ba498