summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-07-04 16:18:18 +0200
committerMartchus2021-07-04 16:18:18 +0200
commit9578d480d91c8f52f1da3855b7d59806f4917635 (patch)
treedb922aca828a0acca35811b399c91902293d8a87
parent91c4845d9236d92613daeb9bd9ec0d632ae9b4b2 (diff)
downloadaur-9578d480d91c8f52f1da3855b7d59806f4917635.tar.gz
Update to 6.1.2
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-linking-against-imm32-with-mingw-w64.patch25
-rw-r--r--PKGBUILD18
-rw-r--r--qtvirtualkeyboard-sha256.txt2
4 files changed, 46 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16760b74d94d..df397ae6f167 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-qt6-virtualkeyboard-static
pkgdesc = Virtual keyboard framework (mingw-w64)
- pkgver = 6.1.1
+ pkgver = 6.1.2
pkgrel = 1
url = https://www.qt.io
arch = any
@@ -20,7 +20,9 @@ pkgbase = mingw-w64-qt6-virtualkeyboard-static
options = !buildflags
options = staticlibs
options = !emptydirs
- source = https://download.qt.io/official_releases/qt/6.1/6.1.1/submodules/qtvirtualkeyboard-everywhere-src-6.1.1.tar.xz
- sha256sums = 246d1acdcd953819b09b1da22bd359335d145d8a3550d9e827dc1fd27b6bd3ff
+ source = https://download.qt.io/official_releases/qt/6.1/6.1.2/submodules/qtvirtualkeyboard-everywhere-src-6.1.2.tar.xz
+ source = 0001-Fix-linking-against-imm32-with-mingw-w64.patch
+ sha256sums = 25cbdf595f5c82d8bc8aea4c95c5adfc08555d540451afac4a1bc0194db3eae0
+ sha256sums = 8d643061931023d8f307b09d4522eb3aea18c7f5964373cde6dbf6e499d93eed
pkgname = mingw-w64-qt6-virtualkeyboard-static
diff --git a/0001-Fix-linking-against-imm32-with-mingw-w64.patch b/0001-Fix-linking-against-imm32-with-mingw-w64.patch
new file mode 100644
index 000000000000..e99d2d467c61
--- /dev/null
+++ b/0001-Fix-linking-against-imm32-with-mingw-w64.patch
@@ -0,0 +1,25 @@
+From 7c0a27cb2dfd036f7b782fad387d74ac0815dbb5 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Sat, 3 Jul 2021 20:12:26 +0200
+Subject: [PATCH] Fix linking against imm32 with mingw-w64
+
+---
+ src/plugin/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/plugin/CMakeLists.txt b/src/plugin/CMakeLists.txt
+index 32042e0..f34a641 100644
+--- a/src/plugin/CMakeLists.txt
++++ b/src/plugin/CMakeLists.txt
+@@ -42,7 +42,7 @@ qt_internal_extend_target(QVirtualKeyboardPlugin CONDITION disable-layouts
+
+ qt_internal_extend_target(QVirtualKeyboardPlugin CONDITION WIN32
+ LIBRARIES
+- Imm32.lib
++ imm32
+ )
+
+ #### Keys ignored in scope 4:.:.:plugin.pro:WIN32:
+--
+2.32.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 2750dc248e84..137a9e44a631 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=mingw-w64-qt6-virtualkeyboard-static
-_qtver=6.1.1
+_qtver=6.1.2
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -16,11 +16,23 @@ makedepends=('mingw-w64-cmake-static' 'mingw-w64-vulkan-headers' 'mingw-w64-vulk
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(mingw-w64-qt6)
_pkgfqn="qtvirtualkeyboard-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('246d1acdcd953819b09b1da22bd359335d145d8a3550d9e827dc1fd27b6bd3ff')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Fix-linking-against-imm32-with-mingw-w64.patch')
+sha256sums=('25cbdf595f5c82d8bc8aea4c95c5adfc08555d540451afac4a1bc0194db3eae0'
+ '8d643061931023d8f307b09d4522eb3aea18c7f5964373cde6dbf6e499d93eed')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
for _arch in ${_architectures}; do
export PKG_CONFIG=/usr/bin/$_arch-pkg-config
diff --git a/qtvirtualkeyboard-sha256.txt b/qtvirtualkeyboard-sha256.txt
index d7330b2bfc80..5ddc058bd2c6 100644
--- a/qtvirtualkeyboard-sha256.txt
+++ b/qtvirtualkeyboard-sha256.txt
@@ -1 +1 @@
-246d1acdcd953819b09b1da22bd359335d145d8a3550d9e827dc1fd27b6bd3ff
+25cbdf595f5c82d8bc8aea4c95c5adfc08555d540451afac4a1bc0194db3eae0