summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2021-10-02 12:47:25 +0200
committerMartchus2021-10-02 12:47:25 +0200
commit655059f5220adf1ee3cd034ab821ec5a1c0c85b6 (patch)
tree3c865101ba7d0c9fb46fbc0070634cce27a29314
downloadaur-655059f5220adf1ee3cd034ab821ec5a1c0c85b6.tar.gz
Update to 6.2.0
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD49
-rw-r--r--PKGBUILD.sh.ep1
-rw-r--r--qtwebchannel-sha256.txt1
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ec68a160c7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = mingw-w64-qt6-webchannel-static
+ pkgdesc = Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)
+ pkgver = 6.2.0
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = any
+ groups = mingw-w64-qt6
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = mingw-w64-cmake-static
+ makedepends = mingw-w64-vulkan-headers
+ makedepends = mingw-w64-vulkan-icd-loader
+ makedepends = qt6-declarative
+ makedepends = ninja
+ depends = mingw-w64-qt6-declarative-static
+ options = !strip
+ options = !buildflags
+ options = staticlibs
+ options = !emptydirs
+ source = https://download.qt.io/official_releases/qt/6.2/6.2.0/submodules/qtwebchannel-everywhere-src-6.2.0.tar.xz
+ sha256sums = 518391ed74b087da3c15058c9c17760204425599ef3ffe61b1b73edc2028c171
+
+pkgname = mingw-w64-qt6-webchannel-static
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f2c3c6d651b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=mingw-w64-qt6-webchannel-static
+_qtver=6.2.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(any)
+url='https://www.qt.io'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Provides access to QObject or QML objects from HTML clients for seamless integration of Qt applications with HTML/JavaScript clients (mingw-w64)'
+depends=('mingw-w64-qt6-declarative-static')
+makedepends=('mingw-w64-cmake-static' 'mingw-w64-vulkan-headers' 'mingw-w64-vulkan-icd-loader' 'qt6-declarative' 'ninja')
+options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
+groups=(mingw-w64-qt6)
+_pkgfqn="qtwebchannel-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('518391ed74b087da3c15058c9c17760204425599ef3ffe61b1b73edc2028c171')
+
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+
+build() {
+ for _arch in ${_architectures}; do
+ export PKG_CONFIG=/usr/bin/$_arch-pkg-config
+ $_arch-cmake-static -G Ninja -B build-$_arch -S $_pkgfqn \
+ -DCMAKE_INSTALL_PREFIX:PATH="/usr/$_arch/static" \
+ -DFEATURE_static_runtime=ON \
+ -DFEATURE_pkg_config=ON
+ cmake --build build-$_arch
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ DESTDIR="$pkgdir" cmake --install build-$_arch
+
+ find "$pkgdir/usr/$_arch" -iname '*.exe' -exec $_arch-strip --strip-all {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.dll' -exec $_arch-strip --strip-unneeded {} \;
+ find "$pkgdir/usr/$_arch" -iname '*.a' -exec $_arch-strip -g {} \;
+ [[ -d "$pkgdir/usr/$_arch/static/share/doc" ]] && rm -r "$pkgdir/usr/$_arch/static/share/doc"
+ done
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/mingw-w64-qt6-base-static "$pkgdir"/usr/share/licenses/$pkgname
+
+}
+
diff --git a/PKGBUILD.sh.ep b/PKGBUILD.sh.ep
new file mode 100644
index 000000000000..87756da456f4
--- /dev/null
+++ b/PKGBUILD.sh.ep
@@ -0,0 +1 @@
+%= include "$default_package_name/mingw-w64/PKGBUILD";
diff --git a/qtwebchannel-sha256.txt b/qtwebchannel-sha256.txt
new file mode 100644
index 000000000000..8439142d860b
--- /dev/null
+++ b/qtwebchannel-sha256.txt
@@ -0,0 +1 @@
+518391ed74b087da3c15058c9c17760204425599ef3ffe61b1b73edc2028c171