summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkfg2022-08-21 23:32:26 +0200
committerkfg2022-08-21 23:32:26 +0200
commit0419b7fa474b12bd9e78d403b3df81d2d9a37154 (patch)
treeb81dcd112b0d4bb5ad2dacc13f031f39299c6ae3
parent327d34734a8374030cbb993f5066f94a6bd08a59 (diff)
downloadaur-0419b7fa474b12bd9e78d403b3df81d2d9a37154.tar.gz
upgpkg: mingw-w64-rav1e 0.5.1-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a51988589118..96cef9a168a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mingw-w64-rav1e
pkgdesc = An AV1 encoder focused on speed and safety (mingw-w64)
- pkgver = 0.4.1
- pkgrel = 2
+ pkgver = 0.5.1
+ pkgrel = 1
url = https://github.com/xiph/rav1e/
arch = any
license = BSD
@@ -15,8 +15,9 @@ pkgbase = mingw-w64-rav1e
options = !strip
options = !buildflags
options = staticlibs
- source = git+https://github.com/xiph/rav1e.git#tag=29a9c604879bc27d319edc03e2c97ba9e9628c86
+ source = git+https://github.com/xiph/rav1e.git#tag=1aff20cd23f718866ae7460e866f8d60b41f4422
+ source = https://github.com/xiph/rav1e/releases/download/v0.5.1/Cargo.lock
sha256sums = SKIP
+ sha256sums = 6baeb4e72ee86dd4c3d6c9acfcfac6a2e58a580101eb181daced09199a136868
pkgname = mingw-w64-rav1e
-
diff --git a/PKGBUILD b/PKGBUILD
index 881827916e01..f16654136a7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Chocobo1 <chocobo1@archlinux.net>
pkgname=mingw-w64-rav1e
-pkgver=0.4.1
-pkgrel=2
+pkgver=0.5.1
+pkgrel=1
pkgdesc='An AV1 encoder focused on speed and safety (mingw-w64)'
arch=(any)
url=https://github.com/xiph/rav1e/
@@ -22,9 +22,13 @@ makedepends=(
mingw-w64-rust
mingw-w64-wine
)
-_tag=29a9c604879bc27d319edc03e2c97ba9e9628c86
-source=(git+https://github.com/xiph/rav1e.git#tag=${_tag})
-sha256sums=(SKIP)
+_tag=1aff20cd23f718866ae7460e866f8d60b41f4422
+source=(
+ git+https://github.com/xiph/rav1e.git#tag=${_tag}
+ https://github.com/xiph/rav1e/releases/download/v${pkgver}/Cargo.lock
+)
+sha256sums=('SKIP'
+ '6baeb4e72ee86dd4c3d6c9acfcfac6a2e58a580101eb181daced09199a136868')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
pkgver() {
@@ -34,6 +38,8 @@ pkgver() {
}
prepare() {
+ cp -f Cargo.lock rav1e/
+
if [[ -d "${RUST_PATH}" ]] ; then
export PATH="${RUST_PATH}:${PATH}"
else